#353 closed defect (reporter unresponsive)

Plug-in not found

Reported by: xynixme Owned by: lewisr
Priority: major Milestone: 1.4.1
Component: Backend Version: 1.4.0
Keywords: Cc:

Description

After a manual install (including environment variables and pathin INI), opening any PDF file doesn't work because of, translated from memory: "Cannot find specific plug-in to display file".

It's a simple, old PDF (v1.1?) file. No PDF file works.

v1.3.5 was installed in the same directory (which tends to crash the first time a PDF file is opened).

Change History (7)

comment:1 Changed 19 months ago by diver

did you install all pre requisites like poppler?

comment:2 Changed 16 months ago by lewisr

This was a manual install. How did you install the prerequisite packages? If you used yum or rpm, please report the results of:

[c:\]rpm -qa | grep poppler

From the main menu in Lucide, what do you see when you select Document | Plugins list?

comment:3 Changed 16 months ago by lewisr

  • Owner set to lewisr
  • Status changed from new to assigned

comment:4 Changed 15 months ago by xynixme

I've installed all unique required DLLs.

I have to fully uninstall upgrade attempts and cannot re-re-re-re-retry it now, but ISTR the list was either empty or I'm 100% the plug-in wasn't listed.

I'm not using any English nor German OS, so no YUM/RPM. Nor do I want that. No @UNIXROOT, and so on. I have to use the RPM ZIP files, with a minimal install of requirements and reuqirements of requirement. The spell checker of FF/SM may be an example of such a minimal install. All FF/SM needs is a DLL. If so, then I won't install any other useless files of this spell checker DLL, like dictionary files.

Are there DLLs which won't be reported as technically missing, but which are required? Are there requirements of DLLs, which aren't DLLs?

If a "minimal install" is not clear., then try to keep in mind I'm just installing all strictly missing DLLs. Not all (unneeded) DLLs of all packages. If it isn't required nor recommended (with a good reason), then I'm not installing it. Sources of information for missing DLLs may be PM DLL, a direct error message of Lucide, or some indirect warning.

I've tried to install 1.4.0 several times, and each time the error message was the same. I'll try it again later tonight, but I'm not expecting an improvement. If there is an improvement, then I'll report it ASAP. The expected result is the "fatal" error message of this ticket.

I cannot report any clue why the plug-in cannot be found, other than that this error message appears to be right: the plug-in is missing, according to Lucide (error message, list of plug-ins).

Last edited 15 months ago by xynixme (previous) (diff)

comment:5 Changed 14 months ago by lewisr

I've installed all unique required DLLs

I do not think this is the case.

If the PDF plugin is not listed, it cannot be loaded.

Please download an install PMDLL from:

http://hobbes.nmsu.edu/h-search.php?key=pmdll-2.12.zip

Start PMDLL and select lupplr.dll from the Lucide program directory. from the menu, select Options | Load System DLLs and Options | Test load DLLs. You may need to run File | Refresh after that. Note any modules which could not be found. These will be listed in red.

After that, please select the popple DLL listed (I'm not looking at a Lucide 1.4.0 GA install to recall which module that is. It should be popple63.dll or popple66.dll. See if that loads without errors. If so, select another dependent module, such as TIFF5.DLL, etc. PMDLL does not fully load all possible DLLs at one time, so a dependency of a dependency of a dependency may not be loaded.

This is why RPM/YUM is highly recommended. All of these issues are automatically handled. Manually installing from zip is fine for testing specific things, but not for keeping a system in a supported, current state.

Last thought: You said that this was the same directory where Lucide 1.3.5 was previously installed. Please ensure that no old files (particularly lu*.dll files) remain in the directory and certainly that no poppler DLLs are present in the directory, as they would likely be loaded ahead of any others of the same name located in LIBPATH.

Last edited 14 months ago by lewisr (previous) (diff)

comment:6 Changed 14 months ago by gyoung

  • Milestone changed from 1.4.0 to 1.4.1

Ticket retargeted after milestone closed

comment:7 Changed 11 months ago by lewisr

  • Resolution set to reporter unresponsive
  • Status changed from assigned to closed

If this is still an issue, please read comment:5 above and provide your results from PMDLL.

poppler requires a number of other packages, which in turn, have their own requirements. As examples, poppler 0.59.0 requires fontconfig. fontconfig 2.12.4 requires fontconfig-legacy, and so forth. The dependencies listed in the Lucide readme are only dependencies of specific RPMs. The package manager (ANPM and/or YUM) is left to handle all of the various dependencies of those packages, which may, in fact, change from release to release (the Lucide project could never keep up). Trying to install only required DLLs is not a viable path (there are other files which are not DLLs, too).

As to the plugin not being found, this will also be reported if the plugin itself (lupopplr.dll) can be located on disk but cannot be loaded. The wording may seem inaccurate, but we don't currently trap the difference between not found and can't be loaded. Generally, later versions (1.4.1 RC1) will load the plugin, but attempting to load a document with it will result in a message that a suitable plugin is not available.

Note: See TracTickets for help on using tickets.