Opened 16 months ago

Last modified 16 months ago

#347 reopened defect

Lucide release 1.4.0 GA crashes if more than single instance started

Reported by: darcio Owned by: gyoung
Priority: major Milestone: 1.4.0
Component: Lucide Core Version: 1.4.0
Keywords: Cc: steve53@…

Description

Attempting to open more than a single instance of Lucide causes a crash.

It does not appear to matter what document is being displayed. I encountered this while attempting to display multiple PDFs, however upon additional testing I can confirm that even when starting just the Lucide program, any other attempts to start a new instance will TRAP.

Attachments (1)

006D_01.TRP (92.5 KB) - added by darcio 16 months ago.
Lucide Exception Handler dump

Download all attachments as: .zip

Change History (18)

Changed 16 months ago by darcio

Lucide Exception Handler dump

comment:1 Changed 16 months ago by darcio

I also have the OS/2 process dump, much larger file though, so if you guys want/need it let me know how to upload.

comment:2 Changed 16 months ago by abwillis

Confirmed.

comment:3 Changed 16 months ago by stevenhl

  • Cc steve53@… added

comment:4 Changed 16 months ago by stevenhl

The crash can be avoided by applying BEGINLIBPATHSTRICT=T to the instances. This implies that one or more of the Lucide DLLs was not built with per-process initialization. Since wlink is doing the linking, this will require

FORMAT DLL INITINSTANCE

comment:5 Changed 16 months ago by stevenhl

The problem child is Lucide1.dll. It's missing INITINSTANCE and TERMINSTANCE. Patching them on allows multiple instances to co-exist.

comment:6 Changed 16 months ago by lewisr

  • Summary changed from Lucide release 1.4.0 GA crashes if more then single instance started to Lucide release 1.4.0 GA crashes if more than single instance started

Thanks, Steve. Mine was working perfectly well until you and I poked at it today with lxlite. Now, this crash is consistent. The same build had at least a half dozen instances running in parallel just yesterday. Go figure. ;-)

comment:7 Changed 16 months ago by gyoung

  • Owner set to gyoung
  • Status changed from new to assigned

comment:8 Changed 16 months ago by gyoung

  • Resolution set to fixed
  • Status changed from assigned to closed

CS [633]

comment:9 Changed 16 months ago by darcio

Hey guys!!!

Thrilled to see the ticket flagged as "closed"...but does anyone care to actually ask the guy who reported the issue (me!) to concurr that the issue has been resolved?

I'm sorry, but having been part of corporate IS support organization for over 20 yrs this type of a thing just boggles my mind. Do not get me wrong, I sure appreciate your work...but process is process. Else, if no one actually cares for the "customer" to test anything then why should the "customer" even bother to tell you anything about the problems in the first place?

My hope is that you do not precieve this as an over-reacting, but man, we have such a small community (OS/2) I would expect a lot more closer co-operation.

comment:10 follow-up: Changed 16 months ago by gyoung

darcio

I don't have a good way to have you test. The dll is too large to attach to the ticket and I don't have a way to send it to you that I am aware of. I was able to reproduce the problem and the fix has eliminated it here. If you wish to test the updated dll tell me where to send it. I greatly appreciate your help in identifying problems and if the problem persists reopen the ticket. This large organization is actually pretty much one developer who is a volunteer. I apologize for closing the ticket but I am use to doing that because normally I opened it.

comment:11 follow-up: Changed 16 months ago by lewisr

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening, pending confirmation of resolution by OP.

Please download the latest 1.4.0 package from FTP, install, and confirm.

Thanks!

comment:12 in reply to: ↑ 10 Changed 16 months ago by darcio

Replying to gyoung:

darcio

I don't have a good way to have you test. The dll is too large to attach to the ticket and I don't have a way to send it to you that I am aware of.

Sorry about the delay guys...I think you could email to my address, it will handle up to 10Meg : dariusz (at) mnsi (dot) net

Replying to gyoung:

I apologize for closing the ticket but I am use to doing that >because normally I opened it.

No problem, I simply wanted to let you guys know I am VERY much interested in helping to troubleshoot and resolve the issue. I am not at all one of these "complain but do not do any follow-up" type users...maybe a tad late, but I get to it.

comment:13 in reply to: ↑ 11 Changed 16 months ago by darcio

Replying to lewisr:

Reopening, pending confirmation of resolution by OP.

Please download the latest 1.4.0 package from FTP, install, and confirm.

Thanks!

Sorry...I missed your update Lewis before I responded.

Alright, so I pulled the Apr-21st release, filename was same as the old one, no biggie, just making sure I got the right thing.

The results are:

1) multiple Lucide instances start

BUT

2) the 2nd and 3rd and 4th instances complain with the following Error msg "Can't find suitable plugin for specified document!", in this case it's a PDF, even though the 1st instance of Lucide clearly had no such problems and is currently open with a PDF document loaded

Now to debug this, I took a quick peek at what plugins actually show in the 2nd instance, I only found the following listed: ludjvu, whereas the 1st instance still shows: ludjvu, lujpeg and lupplr.

So it almost appears as if there is a problem with the plug-in load?

Please note, I just installed the updated release and did NOT get a chance to re-boot. I will try later on and update the ticket with the results.

comment:14 Changed 16 months ago by gyoung

I don't see the PDF issue here. Also a clean install of 1.4.0 should list ludjvu lugmb and lupplr. If you still have a problem uninstall Lucide including renaming its install directory (if warpin doesn't delete it because it contains stuff not in its database) and then reinstall to the original directory name. If that fixes it we need to figure out what was left over in the original install directory that causes the problem.

Last edited 16 months ago by gyoung (previous) (diff)

comment:15 Changed 16 months ago by darcio

Found it!!!

Alright, so here is the thing. I re-booted, no change. I then un-installed the app, wiped out the directory and re-installed. I then re-booted, still no change, exactly the same behaviour.

I went through the readme to identify the one thing I did not do, which was to install the GBMDLL plug-in. I went ahead and did so...and surprise...all of a sudden stuff works...!!!

So, the only difference is that the RPM package has been installed. Lucide starts up fine, reports all the plug-ins and opens up multiple documents.

Given the above, I can only assume that the 1.4.0 GA somehow relies on GBMDLL plug-in being in place, this behaviour is different from the prior releases as I never had this plug-in installed (I had to install the RPM package this time actually).

comment:16 follow-up: Changed 16 months ago by lewisr

The reason I didn't mention anything about GBM before (this one has bitten me, too; the old GBM.DLL should rightfully be removed from LIBPATH, but it's even there in ArcaOS, something I've been meaning to address) is that you mentioned that you couldn;t open a PDF. The outdated GBM module should have no bearing on this.

Lucide has no dependency upon GBM or the GBM plugin being loaded in order to read PDFs. GBM is not a prerequisite for Poppler, so I have no idea what the correlation between the two may have been.

Nevertheless, I guess we can close this, now?

comment:17 in reply to: ↑ 16 Changed 16 months ago by darcio

Replying to lewisr:

...the old GBM.DLL should rightfully be removed from LIBPATH, but it's even there in ArcaOS, something I've been meaning to address) is that you mentioned that you couldn;t open a PDF. The outdated GBM module should have no bearing on this.

Right, there exists an entry in the MMOS2 tree for this DLL:

Directory of G:\mmos2\DLL

6-15-02 5:06p 279468 316 gbm.dll

...however, I have no idea how it got there, other than a suspicion that I must have installed it as part of a previous update (does not show up in Warpin, so maybe a ZIP file install?)

Replying to lewisr:

Nevertheless, I guess we can close this, now?

Yes, I completely agree. My Lucide install is now working correctly, all plug-ins are visible and multiple Lucide instances are created. What was needed was the install of the GBMDLL RPM package, as per the readme.

My only suggestion would be to perhaps change the readme wording so that it does not appear that GBMDLL is an optional package, in my case it clearly was not.

Thank you again for reviewing this issue and troubleshooting!!!

Note: See TracTickets for help on using tickets.