Opened 13 years ago

Closed 13 years ago

#32 closed task (fixed)

Fonts.cache-1 issues

Reported by: gerrit@… Owned by: eros2
Priority: major Milestone:
Component: Lucide Core Version:
Keywords: Cc:

Description

Each time you try to load a PDF-file in a new LUCIDE window it takes an awful lot of time to load the document. But if you keep on loading PDf's in the same LUCIDE instance which was once already opened by a PDF, the PDF documents are opening extremely fast.

Probably this is caused by each time reading/creating the fonts.cache-1 file in C:\PSFONTS each time a PDF is opened in a new LUCIDE window.

Furthermore the fonts.cache-1 file is also created by Alex Taylor's GIMP installation routine. I have noticed that starting HOBLink X11 and The GIMP some fonts from C:\PSFONTS were not available anymore when LUCIDE was run before. I got them back by running the font-script delivered by ALEX TAYLORS GIMP package. Conclusion: fonts.cache-1 created by Lucide is not the same as the one created by The GIMP installation routine. Most probably LUCIDE will cause the same trouble with XFree86/2 .

Solution? LUCIDE must check if there is a FONTS.CACHE-1 file already present. Furthermore FONTS.CACHE-1 files should be independent from the program they were created by, or Lucide should create it's own cachefile (with an unique name)

This is more or less aduplicate of http://svn.netlabs.org/lucide/ticket/30

Change History (1)

comment:1 Changed 13 years ago by eros2

  • Resolution set to fixed
  • Status changed from new to closed

(In [58]) save fonts information in cache file to avoid rescan (closes #30, #32, #35)

Note: See TracTickets for help on using tickets.