Opened 3 years ago

Closed 7 months ago

#306 closed defect (unable to reproduce)

Errant print driver causes Lucide to crash

Reported by: Lewisr Owned by:
Priority: major Milestone: 1.4.1
Component: Backend Version: 1.3.6
Keywords: print, driver, crash Cc:

Description

The actual error is in ECUPS driver. It does appear under other apps, but it does not crash the entire application. This bug is specifically about handling such unexpected conditions more gracefully.

Opened document. Selected Print, then clicked Properties button. Set output to raw PostScript file and entered filename. Upon clicking OK, Lucide crashed with a TRP (attached).

This condition is repeatable with this driver (ECUPS 30.800) and this printer (HP LaserJet 3800).

Attachments (1)

0133_01.zip (41.8 KB) - added by Lewisr 3 years ago.
exception accepting print driver settings from properties notebook

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Lewisr

exception accepting print driver settings from properties notebook

comment:1 Changed 10 months ago by gyoung

  • Milestone changed from 1.4.0 to 1.4.1

Ticket retargeted after milestone closed

comment:2 Changed 7 months ago by lewisr

  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this, either because it has been fixed (testing with 1.4.1 RC1) or because my configuration has changed.

comment:3 Changed 7 months ago by lewisr

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:4 Changed 7 months ago by lewisr

  • Resolution set to cannot reproduce
  • Status changed from reopened to closed

comment:5 Changed 7 months ago by lewisr

  • Resolution cannot reproduce deleted
  • Status changed from closed to reopened

comment:6 Changed 7 months ago by lewisr

  • Resolution set to unable to reproduce
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.