Opened 3 years ago

Closed 8 months ago

#294 closed defect (reporter unresponsive)

Unable to print with CUPS 1.4.8

Reported by: Anchieri Owned by: lewisr
Priority: Feedback Pending Milestone: 1.4.1
Component: Printing Version: 1.3.6
Keywords: Cc:

Description

I have installed the last version of Lucide : Lucide-1.3.6-rc1.zip and I want print to my USB printer: HP 1610 All in One, but nothing go to CUPS. It's possible to print using the normal HP DESKJET driver. With the previous version I was able to print using CUPS, almost all PDF file, in many case also with the 'BOUNDING BOX' error.

Attachments (6)

2016-TEST-LUCIDE-1.jpg (45.5 KB) - added by Anchieri 3 years ago.
image of print dialog
2016-TEST-LUCIDE-2.jpg (54.7 KB) - added by Anchieri 3 years ago.
window error
error_log.TXT (59.8 KB) - added by Anchieri 3 years ago.
log of CUPS session
2016-prove-invalsi.zip (243.4 KB) - added by Anchieri 3 years ago.
cups.log (17.8 KB) - added by Lewisr 3 years ago.
CUPS error_log for successful print using PSCRIPT driver
SPOOLER.jpg (22.9 KB) - added by Anchieri 3 years ago.

Download all attachments as: .zip

Change History (27)

comment:1 Changed 3 years ago by lewisr

Please try RC2a, which is available for testing.

Does the CUPS queue show any data waiting to be sent? For example, when printing to a currently-unavailable HP PhotoSmart printer here (PostScript), my queue shows:

processing since
Mon Aug 22 11:36:08 EDT 2016 
"No %%BoundingBox: comment in header!"

At least I am getting data in the CUPS queue. Your report indicates that you are not even getting the data sent to the queue. Please confirm.

comment:2 Changed 3 years ago by Anchieri

By now I have installed the last version rc2a.zip file, but the result is the same, in CUPS no job received, if I print to file I obtain a file in PostScrip? format that is possible to view using GSVIEW

G,M, Anchieri

comment:3 Changed 3 years ago by Anchieri

This morning, after booting my desktop, I received a little window with this msg:

  • Error during spooling to CUPS Server

I don't now if this can help you to resolve this ticket.

G.M.Anchieri

comment:4 Changed 3 years ago by lewisr

I'm curious about the timing of the CUPS error.

You can print other things? Is there anything showing in the CUPS queue?

comment:5 Changed 3 years ago by Anchieri

For your knowledge, my poppler is version 042, with version 135ga of lucide no problem to print to CUPS, and also qPDFVIEW function perfectly with CUPS 1.4.8. I have retested Lucide and I attach a image (2016-test-lucide-1.jpg) of the print dialog and (2016-test-lucide-2.jpg) of error during printing and the log file of CUPS of the session of test.

Changed 3 years ago by Anchieri

image of print dialog

Changed 3 years ago by Anchieri

window error

Changed 3 years ago by Anchieri

log of CUPS session

comment:6 Changed 3 years ago by Anchieri

Hi, I have update my poppler to version 047 using yum, but keeping also the old popple59.dll file active. In this manner I was able to print with LUCIDE and qPDFVIEW. If I rename or delete the popple59.dll the LUCIDE don't work, for me, compilation of new version of LUCIDE contain some request to old version and then if I delete the old version of poppler LUCIDE don't function correctly.

comment:7 Changed 3 years ago by lewisr

Lucide RC2a has a dependency upon popple59.dll. This is a known issue, and we are working to make Lucide handle Poppler upgrades better (like qPDFView). See #297.

Can you print to the CUPS queue if you select the option to print as image? I would suspect so, but want to be certain.

Also, if you could please print the PostScript to file from a PDF and attach that, it would be helpful, as I'm fairly certain I know what the issue is (though we don't have a fix, yet).

Thanks.

comment:8 Changed 3 years ago by Anchieri

1) no, Lucide don't print as image

2) I attach the file: 2016-prove-invalsi.ps, obtained using option print to file.

G.M.Anchieri

Changed 3 years ago by Anchieri

comment:9 Changed 3 years ago by Lewisr

This is interesting, if frustrating.

I am able to successfully print to a CUPS printer using the PSCRIPT.DRV 30.822. CUPS log, attached.

Either something is odd with the way in which we are handling PSPRINT jobs (I need to test PSPRINT further, though) or something else (page size, perhaps?) is causing the port driver to not pass the data to CUPS. There was nothing wrong with the PS output you attached.

Changed 3 years ago by Lewisr

CUPS error_log for successful print using PSCRIPT driver

comment:10 Changed 3 years ago by Anchieri

I have installed the last version of lucide: 1.4.0-RC3, and after testing it with a PDF file, the result is the same of this, nothing come printed by CUPS 1.4.8 but lucide return the same error in: 2016-TEST-LUCIDE-2.jpg.

I can print the same PDF file using qPDFVIEW.

The version of Poppler is the same, why this malfunction?.

comment:11 Changed 3 years ago by lewisr

Can you please check to see that your spooler is enabled? The error message you received previously tells me that it may have shut itself down. A PM printer object cannot print to a CUPS queue without the spooler enabled.

That does not explain why 1.3.5GA prints and 1.4.0RC3 does not, however.

I am able to print to my HP Color LaserJet 3800 via CUPS from Lucide. There are printing oddities, but those are for other tickets. I am getting data through to the CUPS queue, but for some reason, you are not.

The main difference between Lucide's printing setup and qPDFView is that qPDFView will only print to CUPS printers. Lucide prints to PM printers. Lucide also adjusts the PostScript data (which we should probably review, at this point).

Lucide's PS data is much larger than when printing directly to CUPS. The same page,when printed from qPDFView, is 186KB, but when printed from Lucide (as PostScript) is 535KB. That's an awful lot of bloat. Still, that does not explain why we are not even seeing the job hit CUPS in your setup.

Know that we are still working on this. Meanwhile, check your spooler, please and confirm that it is enabled.

comment:12 Changed 3 years ago by Anchieri

My spooler is enabled, as you can view in SPOOLER.JPG attached. In pulldown menu it has an entry with the possibility to enable/disable it. I have also the same printer defined using the HP deskject 660 driver, and I can print on it with LUCIDE.

Changed 3 years ago by Anchieri

comment:13 Changed 2 years ago by gyoung

This occurred between CS [518] and CS [543]

comment:14 Changed 2 years ago by gyoung

The only changes to print.cpp was the addition of exceptq. I did change from the C version to the C++ class after the last release.

comment:15 Changed 2 years ago by gyoung

I would like to send you the very latest Lucide1.dll for you to try. It is too large to post here. Please email me at ygk at qwest dot net. Thanks. Assuming the new dll file fails can you please provide the following:

  1. The PS file from a print to file using 1.3.5GA and a PS of the same file using any later versions. Use the smallest pdf you have if possible. Print only the 1st page if you only have multi-page pdfs
  2. Please verify that the cups print works for the 1.3.5 version and that it fails for the later version.
  3. A screen shot of the print dialog so I can see the settings used for the 1.3.5 version and one for the later version.

comment:16 Changed 10 months ago by lewisr

  • Owner set to lewisr

Still an issue with 1.4.0GA?

comment:17 Changed 10 months ago by lewisr

  • Priority changed from critical to Feedback Pending

comment:18 Changed 10 months ago by gyoung

  • Milestone set to 1.4.1

comment:19 Changed 8 months ago by lewisr

  • Resolution set to suspended
  • Status changed from new to closed

Closing as reporter unresponsive. If this is still an issue, please re-open. Latest CUPS is 2.1.3.

comment:20 Changed 8 months ago by lewisr

  • Resolution suspended deleted
  • Status changed from closed to reopened

comment:21 Changed 8 months ago by lewisr

  • Resolution set to reporter unresponsive
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.