Opened 3 years ago

Closed 3 years ago

#289 closed defect (invalid)

Clicking Job properties in Print dialog toggles toolbar off

Reported by: lewisr Owned by:
Priority: major Milestone:
Component: UI Version: 1.3.6
Keywords: Cc:

Description

1.3.6 RC2:

When the Print dialog is visible, clicking the Job properties button to raise the system Job settings notebook causes the toolbar to disappear. To get it back, it seems necessary to switch to Presentation (F5) and back again.

Change History (6)

comment:1 Changed 3 years ago by gyoung

It doesn't happen here. List exact steps to reproduce staring from opening Lucide. Does it only happen with some PDFs and not all? I will send you the latest build (trap fix switch to libc 0.6.6) to confirm it is still happening.

comment:2 Changed 3 years ago by lewisr

Okay, I can confirm that the only print driver I have installed which triggers this is LASERJET.DRV 30.827. PSPRINT.DRV and PSCRIPT.DRV do not cause it, so this may not be a Lucide bug at all.

Steps to reproduce:

  1. Load supported document (type does not matter, so this is not plugin-specific).
  2. Open Print dialog (any method will do).
  3. Select a PCL printer which uses LASERJET.DRV.
  4. Click Job properties.

What's weird is that I was not aware that there was any method to toggle the toolbar on or off at all. It's certainly not in the UI anywhere.

comment:3 Changed 3 years ago by gyoung

My default printer is a PCL printer using LASERJET.DRV and I don't see this. Mine uses LPT1 but is actually on a peer network. Have you tried rebooting to see if it is something messed up in the system that will simply go away?

comment:4 Changed 3 years ago by lewisr

Confirmed on three bare metal machines, all running LASERJET.DRV 30.827, amd all configured for the HP LaserJet Mopier 320, printing to LPT1.

Two of these systems are running eCS 2.1, with the latest YUM updates. The third is running eCS 1.2R, and is somewhat out of date in terms of YUM updates. It should also be noted that I could not get this to occur under Lucide 1.3.3. I need to test 1.3.5 GA.

I could not get the condition to occur under VirtualBox, however, using eCS 2.1 and current YUM updates. Are you testing on bare metal or in a VM, Gregg?

comment:5 Changed 3 years ago by gyoung

Bare metal eCS 2.2 beta with basically every update available (actually some that really aren't widely available). My driver is configured for an HP 2100 laser jet.

comment:6 Changed 3 years ago by lewisr

  • Resolution set to invalid
  • Status changed from new to closed

This must be as a result of low shared memory. After closing SeaMonkey, Rdesktop, Citrix, and several other apps - hey, this is OS/2! - I am unable to reproduce the condition. Closing this as not our problem.

Note: See TracTickets for help on using tickets.