Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#277 closed defect (worksforme)

Intei pdf manual doesn't render properly works in old lucide ePDF and ghost view

Reported by: gyoung Owned by: gyoung
Priority: minor Milestone: 1.4.0
Component: Backend Version: 1.3.6
Keywords: Cc:

Description

No text is shown see attached screen shot. It is fine in the other viewers listed. The document is the one listed below. Hopefully the link hasn't changed.

Documentation Changes.pdf http://www.intel.com/Assets/PDF/manual/252046.pdf

Attachments (6)

intel manual in lucide 1.36 beta.png (4.6 KB) - added by gyoung 3 years ago.
Missing_fonts_Lucide.png (27.2 KB) - added by lewisr 3 years ago.
Intel manual page snippet from Lucide 1.3.6
Missing_fonts_qPDFView.png (24.3 KB) - added by lewisr 3 years ago.
Intel manual page snippet from qPDFView 0.4.10
DeJaVu_fonts_installed_Lucide.png (26.3 KB) - added by lewisr 3 years ago.
Same page after installation of Déja Vu fonts
MS_Core_fonts_installed_Lucide.png (26.4 KB) - added by lewisr 3 years ago.
Same page after installation of MS Core fonts (Lucide)
MS_Core_fonts_installed_qPDFView.png (24.3 KB) - added by lewisr 3 years ago.
Same page after installation of MS Core fonts (qPDFView)

Download all attachments as: .zip

Change History (20)

Changed 3 years ago by gyoung

comment:1 Changed 3 years ago by lewisr

Hi, Gregg...

The link comes back with a 404 for me, but is this Document Number: 252046-050, Intel ® 64 and IA-32 Architectures Software Developer's Manual? If so, I got it from http://www.intel.com/content/dam/www/public/us/en/documents/manuals/64-ia-32-architectures-software-developers-manual.pdf .

If that is the document, I can render it just fine. Can you please post the content of View | Fonts info... ?

I show for the above:

Verdana                   | TrueType       | Embedded subset
Verdana,Bold              | TrueType       | Not embedded
Verdana,BoldItalic        | TrueType       | Not embedded
Verdana,Italic            | TrueType       | Not embedded
NeoSansIntelMedium        | TrueType       | Embedded subset
Arial                     | TrueType       | Embedded subset
NeoSansIntel              | TrueType       | Embedded subset
Symbol                    | Type 1C        | Embedded subset
NeoSansIntel,Italic       | TrueType       | Embedded subset
NeoSansIntel              | TrueType (CID) | Embedded subset
Arial                     | TrueType (CID) | Embedded subset
Verdana                   | TrueType (CID) | Embedded subset
Wingdings                 | TrueType (CID) | Embedded subset
Arial,Bold                | TrueType       | Not embedded
NeoSansIntelMedium,Italic | TrueType       | Embedded subset
TimesNewRoman             | TrueType       | Not embedded
Arial                     | Type 1C        | Embedded subset
Calibri                   | TrueType (CID) | Embedded subset
Courier                   | Type 1C        | Embedded subset
Calibri                   | TrueType       | Embedded subset

You are indeed using Matthias' build utilizing popple57.dll?

comment:2 Changed 3 years ago by gyoung

Here is what I get

Verdana | TrueType? | Not embedded Verdana-Bold | TrueType? | Not embedded Verdana-BoldItalic? | TrueType? | Not embedded Verdana-Italic | TrueType? | Not embedded NeoSansIntel?-Medium | TrueType? | Not embedded Arial-BoldMT | TrueType? | Not embedded NeoSansIntel? | TrueType? | Not embedded NeoSansIntel?-Italic | TrueType? | Not embedded ArialMT | TrueType? | Not embedded SymbolMT | TrueType? (CID) | Embedded subset NeoSansIntel?-MediumItalic? | TrueType? | Not embedded TimesNewRomanPSMT | TrueType? | Not embedded TimesNewRomanPS-BoldMT | TrueType? | Not embedded

The link is broken because it is out of the subject on the file from the original download 5+ years ago.

A second document that fails to load the text view -> fonts shows

Times New Roman | TrueType? | Not embedded

I wish I could post it since it is small but it contains confidential information.The Intel manual is 1.5mg.

It is the version from the link in your netlabs news group post. I also built it from the current netlabs source. However I now see that I have popple59.dll installed. This must be our latest production release since I don't use the experimental repository.

Last edited 3 years ago by gyoung (previous) (diff)

Changed 3 years ago by lewisr

Intel manual page snippet from Lucide 1.3.6

Changed 3 years ago by lewisr

Intel manual page snippet from qPDFView 0.4.10

comment:3 Changed 3 years ago by lewisr

Right. It moved to netlabs-rel. Use ANPM, and select Get specific release..., and select poppler 0.38.0. You currently have poppler 0.42.0 installed.

That should get you to the point of rendering (see my screenshots). The rest, however, is as a result of missing fonts, I believe (I can't render it in either Lucide or qPDFView).

Last edited 3 years ago by lewisr (previous) (diff)

Changed 3 years ago by lewisr

Same page after installation of Déja Vu fonts

Changed 3 years ago by lewisr

Same page after installation of MS Core fonts (Lucide)

Changed 3 years ago by lewisr

Same page after installation of MS Core fonts (qPDFView)

comment:4 Changed 3 years ago by lewisr

Note the later screenshots, after installing first Déja Vu (some available substitutions) and then the MS Core fonts (best matching, as this does indeed appear to have been created from a Word doc under Windows). Both of these packages are available on Hobbes under /pub/multimedia/fonts/truetype/ .

I added the qPDFView image as a quick comparison. I think Lucide renders the page much better.

Anyway, Gregg, try installing the MS Core fonts. Also try some of Alex's packages which he discussed at WSE. Font issues will be common for all PDFs without embedded fonts (though they lead to smaller PDFs as a result). Blue Lion will ship with a decent collection of modern fonts, though.

comment:5 Changed 3 years ago by gyoung

I downgraded poppler and the Intel manual works. Lucide traps if I use 0.38.0-3.oc00. I actually built lucide against 0.42.0 and it works fine for every pdf I tried except the 2 talked about in this ticket. However adding fonts didn't fix them.

comment:6 Changed 3 years ago by gyoung

  • Summary changed from Intei pdf manual doesn't reder properly works in old lucide ePDF and ghost view to Intei pdf manual doesn't render properly works in old lucide ePDF and ghost view

comment:7 Changed 3 years ago by gyoung

I added a local.conf to fontconf that provided for replacement fonts for the NeoSansItel? fonts in the Intel manual. I know they were picked up because as I changed the substitutions the fonts used by qPDF changed to match. However, Lucide still failed to render any fonts.

comment:8 Changed 3 years ago by gyoung

More craziness I just made a object of my test program. I had been running it from command line out of FM/2. When I ran it from the object it rendered all the fonts and fixed a new problem I was seeing. I was trying to add the substitute font list to the Font Dialog box but while everything seem like it should work no font names showed up in the new forth column of the dialog. (GooString?)info->getSubstituteName(); was always NULL. However it now works fine in Lucide started from the object. The final test tells me where to look. I ran a command prompt from Xcenter and ran Lucide from that and yes all the fonts and the new font dialog worked as expected. Now I just need to figure out what entry in my build environment causes the problem.

comment:9 Changed 3 years ago by gyoung

This is caused by UNIXROOT not being pointed to the root that contains the fonts.conf file. Re-pointing it fixes this issue, I did notice that the preview fails to show any fonts on the preview of the scanned letter I talked about above. It does however show fonts on the Intel manual preview.

comment:10 Changed 3 years ago by lewisr

Gregg, what does the document information show for the PDF which still does not render? Perhaps we can find a similar one for testing.

comment:11 Changed 3 years ago by gyoung

  • Owner set to gyoung
  • Status changed from new to assigned

comment:12 Changed 3 years ago by lewisr

Gregg, as I have not been able to reproduce this with my fonts installed. your motes to me indicate that you have addressed this in your 7-30-16 build of 1.3.6. Feel free to close this as fixed. I'll leave that to you.

comment:13 Changed 3 years ago by gyoung

  • Resolution set to worksforme
  • Status changed from assigned to closed

This was a UNIXROOT issue not a lucide issue

comment:14 Changed 3 years ago by gyoung

  • Milestone set to 1.4.0
Note: See TracTickets for help on using tickets.