Opened 2 years ago

Last modified 9 days ago

#242 new enhancement

Lucide does not print on laser printer automatic

Reported by: peter Owned by:
Priority: Feedback Pending Milestone:
Component: Lucide Core Version: 1.3
Keywords: printing Cc: xhajt03

Description

Any application is able to print on my laser printer except LUCIDE 1.3.4. and predessor. Transfer of output from Lucide to printpool works. Ready light on printer is ON. After transfer of output to printer the ready light goes OFF and error light is blinking.

When I hit the start button in this situation the printer lights are switching back and the printer prints the output without any problems. I can expirience this behaviour on any of my PCs and printers.

Change History (12)

comment:1 Changed 2 years ago by diver

  • Priority changed from major to Feedback Pending

try print as image, this should work

comment:2 Changed 2 years ago by peter

I am sorry, but where can I define "print as image"? At printer or lucide? I am not familiar with it.

comment:3 Changed 2 years ago by peter

I am sorry, I never used this feature and the german text of printer dialog is a little bit misleading in this case. I made some tests with my newer printer HP laserjet 2055 and it works as described. My older printer HP laserjet 1320 works only partially. But I thinks it works! Many thanks!

comment:4 Changed 2 years ago by xhajt03

  • Cc xhajt03 added
  • Keywords printing added
  • Priority changed from Feedback Pending to major
  • Type changed from enhancement to defect

Well, I can confirm the problem (already observed with previous Lucide versions). It appears completely consistently with all recent versions (I cannot say for sure since when - but it certainly worked in the past. "Print as image" does not help me; actually, I have no other option because I have a PCL printer (no postscript). I tried sending the output to a file instead of the printer port by changing the printer driver properties and it revealed that the created PCL file is basically empty - it contains just the correct PCL header, but that's it (which corresponds to the observed printer behaviour - the printer LEDs blink since the printer receives some communication from the PC, but then the LED blinking stops and nothing else happens). I'm willing to help with some experimenting if necessary (e.g. sending the generated PCL file if that's of any use, testing various options or even possibly provided debug builds, etc. - in that case I suggest contacting me by e-mail using XHajT03 at domain hajny dot biz).

I use eCS 1.0 with fixpacks (English version), my printer is Lexmark E321 (using the last official Lexmark driver).

comment:5 Changed 2 years ago by diver

  • Type changed from defect to enhancement

Lucide only prints to Postscript direct. To print to a non PS printer you need to use the "Print as image" in the printeroptions of lucide.

comment:6 Changed 2 years ago by xhajt03

As outlined yesterday, "Print as image" is the only option available to me (and thus it is selected), but it gives the result described above (i.e. no output). I don't understand why this behaviour should be classified as an enhancement request rather than a defect (I try to use an existing feature and it doesn't provide the expected result).

comment:7 Changed 2 years ago by melf

I wonder if this is related to my ticket #220 "Just printing the first page". I now use GsView? as my standard pdf-viewer as it reliably print as it should.

comment:8 Changed 2 years ago by diver

as i have no idea why, your only choice is "Print as image"
eventually we will once look at it, but i really doubt right now.

comment:9 Changed 2 years ago by xhajt03

Could you please read the comments above again? "Print as image" does not help (it is the only selectable option in my case, but _it_does_not_print_anything_)! This is the reason why I really don't like the fact that you classified the ticket as "enhancement" instead of "defect" - there's no way for me to get Lucide printing using my PCL printer.

Also regarding reproducibility on your side - have you tried installing a PCL driver (such as the one for Lexmark I mentioned above) and request the driver to store the output as file instead of sending it to a printer? As mentioned above, this scenario allows full reproducibility without having any PCL driver attached because the generated file contains no data (just an empty PCL header).

comment:10 Changed 2 years ago by diver

i can classify it back, but it will not help, as i have no time to look at it. i'm sorry.
but as the source is open everyone can look at it.

comment:11 Changed 2 weeks ago by diver

  • Priority changed from major to Feedback Pending

did you try qpdfview

comment:12 Changed 9 days ago by xhajt03

I haven't been using QT applications previously. In order to try your suggestion, I installed the QT4 libraries now (including CUPS, etc., as suggested in install.os2 included in the QT4 runtime package). I also added QT\bin to libpath, path to cups.dll to libpath + path to cups binaries to path, etc., and restarted. If starting QPDFView directly from the directory of qpdfview.exe, it died silently without telling me anything. The only possible way for opening it was if I added path to QPDFView\bin to endlibpath and started qpdfview.exe while being in qt\bin. This way qpdfview.exe started at least (the window opened). After resolution of some DLL conflicts due to libraries/applications compiled for kLibC not being compatible to libraries compiled for emxlibc (not reported by the application, but fortunately found in popuperr.os2) I can open PDF files as well. However, I still have to find out how to install/configure cups for my (non-PS) Lexmark printer (I hope that it would be supported - the fact that I have a perfectly working native printer driver for it doesn't help me in this case, of course). I'll let you know once I manage to move on with this.

Note: See TracTickets for help on using tickets.