Opened 6 years ago

Last modified 8 months ago

#242 reopened defect

Print as image produces no output

Reported by: peter Owned by: lewisr
Priority: Feedback Pending Milestone: Future
Component: Lucide Core Version: 1.3
Keywords: printing Cc: xhajt03

Description

Any application is able to print on my laser printer except LUCIDE 1.3.4. and predessor. Transfer of output from Lucide to printpool works. Ready light on printer is ON. After transfer of output to printer the ready light goes OFF and error light is blinking.

When I hit the start button in this situation the printer lights are switching back and the printer prints the output without any problems. I can expirience this behaviour on any of my PCs and printers.

Attachments (4)

pdfprint.zip (40.8 KB) - added by xhajt03 9 months ago.
Result of PDF printing with Lucide to a laser (PCL) printer
luc120output.zip (14.3 KB) - added by xhajt03 9 months ago.
(Correct) print-out of the sample file from Lucide 1.20
Lexmark printer choices.png (6.9 KB) - added by gyoung 9 months ago.
luc140rc4print.png (20.5 KB) - added by xhajt03 9 months ago.
Screenshot of the Lucide print dialog (1.40 RC4)

Download all attachments as: .zip

Change History (32)

comment:1 Changed 6 years ago by diver

  • Priority changed from major to Feedback Pending

try print as image, this should work

comment:2 Changed 6 years ago by peter

I am sorry, but where can I define "print as image"? At printer or lucide? I am not familiar with it.

comment:3 Changed 6 years ago by peter

I am sorry, I never used this feature and the german text of printer dialog is a little bit misleading in this case. I made some tests with my newer printer HP laserjet 2055 and it works as described. My older printer HP laserjet 1320 works only partially. But I thinks it works! Many thanks!

comment:4 Changed 6 years ago by xhajt03

  • Cc xhajt03 added
  • Keywords printing added
  • Priority changed from Feedback Pending to major
  • Type changed from enhancement to defect

Well, I can confirm the problem (already observed with previous Lucide versions). It appears completely consistently with all recent versions (I cannot say for sure since when - but it certainly worked in the past. "Print as image" does not help me; actually, I have no other option because I have a PCL printer (no postscript). I tried sending the output to a file instead of the printer port by changing the printer driver properties and it revealed that the created PCL file is basically empty - it contains just the correct PCL header, but that's it (which corresponds to the observed printer behaviour - the printer LEDs blink since the printer receives some communication from the PC, but then the LED blinking stops and nothing else happens). I'm willing to help with some experimenting if necessary (e.g. sending the generated PCL file if that's of any use, testing various options or even possibly provided debug builds, etc. - in that case I suggest contacting me by e-mail using XHajT03 at domain hajny dot biz).

I use eCS 1.0 with fixpacks (English version), my printer is Lexmark E321 (using the last official Lexmark driver).

comment:5 Changed 6 years ago by diver

  • Type changed from defect to enhancement

Lucide only prints to Postscript direct. To print to a non PS printer you need to use the "Print as image" in the printeroptions of lucide.

comment:6 Changed 6 years ago by xhajt03

As outlined yesterday, "Print as image" is the only option available to me (and thus it is selected), but it gives the result described above (i.e. no output). I don't understand why this behaviour should be classified as an enhancement request rather than a defect (I try to use an existing feature and it doesn't provide the expected result).

comment:7 Changed 5 years ago by melf

I wonder if this is related to my ticket #220 "Just printing the first page". I now use GsView? as my standard pdf-viewer as it reliably print as it should.

comment:8 Changed 5 years ago by diver

as i have no idea why, your only choice is "Print as image" eventually we will once look at it, but i really doubt right now.

comment:9 Changed 5 years ago by xhajt03

Could you please read the comments above again? "Print as image" does not help (it is the only selectable option in my case, but _it_does_not_print_anything_)! This is the reason why I really don't like the fact that you classified the ticket as "enhancement" instead of "defect" - there's no way for me to get Lucide printing using my PCL printer.

Also regarding reproducibility on your side - have you tried installing a PCL driver (such as the one for Lexmark I mentioned above) and request the driver to store the output as file instead of sending it to a printer? As mentioned above, this scenario allows full reproducibility without having any PCL driver attached because the generated file contains no data (just an empty PCL header).

comment:10 Changed 5 years ago by diver

i can classify it back, but it will not help, as i have no time to look at it. i'm sorry. but as the source is open everyone can look at it.

comment:11 Changed 3 years ago by diver

  • Priority changed from major to Feedback Pending

did you try qpdfview

comment:12 Changed 3 years ago by xhajt03

I haven't been using QT applications previously. In order to try your suggestion, I installed the QT4 libraries now (including CUPS, etc., as suggested in install.os2 included in the QT4 runtime package). I also added QT\bin to libpath, path to cups.dll to libpath + path to cups binaries to path, etc., and restarted. If starting QPDFView directly from the directory of qpdfview.exe, it died silently without telling me anything. The only possible way for opening it was if I added path to QPDFView\bin to endlibpath and started qpdfview.exe while being in qt\bin. This way qpdfview.exe started at least (the window opened). After resolution of some DLL conflicts due to libraries/applications compiled for kLibC not being compatible to libraries compiled for emxlibc (not reported by the application, but fortunately found in popuperr.os2) I can open PDF files as well. However, I still have to find out how to install/configure cups for my (non-PS) Lexmark printer (I hope that it would be supported - the fact that I have a perfectly working native printer driver for it doesn't help me in this case, of course). I'll let you know once I manage to move on with this.

comment:13 Changed 14 months ago by lewisr

  • Owner set to lewisr
  • Type changed from enhancement to defect

To everyone having issues with printer output contributing to this bug:

Please try again under Lucide 1.3.5 with a small PDF (no personal information, please!) using a printer object (for your usual printer) configured to print to file, and attach the output to this ticket.

We will have a new Lucide 1.3.6 available soon, so if you get no output now, please test as described, and then test again with the 1.3.6 build.

Thanks

comment:14 Changed 13 months ago by gyoung

  • Milestone set to Future

comment:15 Changed 9 months ago by lewisr

  • Resolution set to feedback
  • Status changed from new to closed

No feedback from OP. As mentioned in this ticket, printing as image is the acceptable option for non-PS printers. An enhancement request could be opened to possibly detect a non-PS printer and set this option by default, but this is not a defect.

comment:16 Changed 9 months ago by xhajt03

As mentioned before, the real issue is that printing as image does not provide any output since some older version (i.e. the point is not having a different default option but rather having some working possibility at all - I have to use the old version if I want to get any print-out). Please, reopen the ticket, it should not be closed. I have been really busy recently, but I can provide the output (I already did it in the past with a different ticket, but anyway).

comment:17 Changed 9 months ago by lewisr

  • Resolution feedback deleted
  • Status changed from closed to reopened
  • Summary changed from Lucide does not print on laser printer automatic to Print as image produces no output

Reopened and renamed to reflect the underlying problem. Apologies for closing too soon!

Please retest with the latest 1.4.0 RC (RC4). Ensure that you have met all the prerequisites. Please post printer and driver details, as well (to this ticket, or provide a link to the other one).

Thanks!

Changed 9 months ago by xhajt03

Result of PDF printing with Lucide to a laser (PCL) printer

comment:18 Changed 9 months ago by xhajt03

As discussed, I added an attachment containing 4 files:

  1. A very simple LibreOffice? document
  2. PDF file created by exporting this document (on a MS Windows machine)
  3. Print-out of this PDF document from Acrobat Reader DC running on MS Windows to my Lexmark E321 printer but redirected to a file.
  4. Result of my attempt to print the same PDF file to the same printer using Lucide 1.4.0 RC4 running on my eCS 1.0 machine. The document displays correctly on screen (thus there should be no problem with dependencies/prerequisites), but the output is empty.

The printer driver is the original driver by Lexmark (apparently the last one they produced for OS/2 - it was created for Lexmark E320, i.e. the previous model, but it's fully compatible with my model and I can print with it without any issues from other OS/2 applications). For completeness sake, the driver version mentioned in properties/About is 2.711.

comment:19 Changed 9 months ago by xhajt03

BTW, please, make sure to read the whole thread - I already provided most of the information (including the printer model, the fact of using print as image, etc., in my previous comments long time ago).

comment:20 Changed 9 months ago by xhajt03

Sorry, one more bit of information - Lucide 1.20 has been the last version for which printing has worked correctly for me. I can still print with it (using the same printer and the same driver) - the attached file luc120output.zip is the output from that version.

Changed 9 months ago by xhajt03

(Correct) print-out of the sample file from Lucide 1.20

Changed 9 months ago by gyoung

comment:21 follow-up: Changed 9 months ago by gyoung

What versions have you tried? There was a 1.21 which was followed by 1.30 - 1.35 (note to self I have 1.32 installed on drive D: of my laptop). I do not have the print driver you indicated above. See attached screenshot showing my choices.

comment:22 follow-up: Changed 9 months ago by gyoung

Compare of last line of failing version with 1.20 successful version success: &l1X&l26A&l1H&n6WdPlain&l0O*r0F&l00E%1BCO"Lexmark Enhanced failed: &l1X&l26A&l1H&n6WdPlain&l0O*r0F%-12345X

Have you tried checking the Higher image quality checkbox? Please provide a screenshot of the lucide print dialog.

comment:23 in reply to: ↑ 21 Changed 9 months ago by xhajt03

Replying to gyoung:

What versions have you tried? There was a 1.21 which was followed by 1.30 - 1.35 (note to self I have 1.32 installed on drive D: of my laptop).

It didn't work at least since 1.30. I'm not 100% sure about version 1.21; I could try to install that version too if I find it somewhere and if it helps in some way.

I do not have the print driver you indicated above. See attached screenshot showing my choices.

As mentioned above, this is the driver provided by Lexmark, not the generic LaserJet? driver. Some version of the driver seems to be still available from Lexmark - see http://support.lexmark.com/index?page=content&docLocale=en_US&id=DR2171 (I'm not sure if it is the same version, or not - the download page suggests that the driver build is from year 1999, but it contains files from February 2002 which exist on my OS/2 machine too).

Changed 9 months ago by xhajt03

Screenshot of the Lucide print dialog (1.40 RC4)

comment:24 in reply to: ↑ 22 Changed 9 months ago by xhajt03

Replying to gyoung:

Compare of last line of failing version with 1.20 successful version success: &l1X&l26A&l1H&n6WdPlain&l0O*r0F&l00E%1BCO"Lexmark Enhanced failed: &l1X&l26A&l1H&n6WdPlain&l0O*r0F%-12345X

Have you tried checking the Higher image quality checkbox? Please provide a screenshot of the lucide print dialog.

I didn't have the Higher image quality checkbox ticked in either of the two Lucide versions creating the print output. Enabling this option in the latest Lucide version makes no difference, the output file is byte for byte identical with the previous one.

comment:25 Changed 9 months ago by gyoung

Knowing it worked in 1.20 and didn't in 1.30 probably narrows it down enough for what I need. I really didn't expect the higher image quality checkbox would change anything but stranger things have happened. I got the driver from the link you indicated and will try installing it. I probably won't get to this until the end of the week.

comment:26 Changed 9 months ago by xhajt03

Don't worry, I won't have any chance for further testing until the 2nd of January anyway (I'm going to leave the city tomorrow and not having access to my OS/2 machine until coming back home). As seen in the ticket history (and also indicated by the discussed version numbers and their release dates), it's not like that one or two weeks more would make any difference. ;-)

comment:27 Changed 9 months ago by gyoung

Ok this is a pdf only problem jpgs and djvu files print fine (at least produce reasonable looking pcl files). The good news is I know what change caused this. The bad news is reverting it very noticeably slows page rendering. This gives 4 choices I can see if I can fix it while maintaining the new rendering system. I can revert it and put up with the slow rendering. I can leave the new rendering in place and mark this won't fix or I can add a setting that chooses between 3 bit rendering (old) and 4 bit rendering (new). The last would default to 4 bit rendering and need a readme and help file entry saying it might workaround print failures where a pdf is printed as a blank page.

comment:28 Changed 8 months ago by xhajt03

Why is this - is it because some printer drivers can work with the (faster) 4 bit rendering, whereas other drivers fail on this and require 3 bit rendering, or what is the reason? Another question - is it necessary to use the same rendering approach for screen and the printer, or would the slow-down affect only the speed of printing, while displaying the file on screen might still use the faster approach?

Note: See TracTickets for help on using tickets.