Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#223 closed defect (feedback)

DesktopxxxxCopy added to filename

Reported by: melf Owned by:
Priority: minor Milestone:
Component: Lucide Core Version: 1.2
Keywords: Cc:

Description

Every time a pdf is saved, Lucide (since ver GA?) adds "Desktop" before file name and "Copy" afterwords. I find it very unnecessary and this is something I have to change every time. Why? Is this due to some copyright-laws or..?

Can we please get rid of this function or optionally turn it off?

Attachments (4)

lucide2_1.jpg (3.2 KB) - added by melf 8 years ago.
lucide2.jpg (6.4 KB) - added by melf 8 years ago.
lucide3.jpg (1.7 KB) - added by melf 8 years ago.
lucide3_1.jpg (5.8 KB) - added by melf 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by diver

  • Priority changed from major to minor
  • Resolution set to feedback
  • Status changed from new to closed

i can't reproduce it here. when i save a pdf with save as it only adds copy to the file name. and this is ok. but desktop is not added.

which lucide version do you use? do you have FOC installed? if FOC is installed deinstall it and try again please.

comment:2 Changed 8 years ago by melf

I use 1.32 GA and had FOC installed. Now FOC is unistalled,but still see the same issue if:

a) I open a pdf from the web and the save it. b) open a pdf in from my harddrive and the save it.

If I just use "Save target as": from the web, there is no problems.

PS. Regarding your comment: I can't see why the "Copy" after filename should be OK, Why is it needed?

comment:3 Changed 8 years ago by diver

sorry but i still don't get what you mean. i only have save as and this adds "copy" to it. and i still think this "copy" is ok.

Changed 8 years ago by melf

Changed 8 years ago by melf

Changed 8 years ago by melf

Changed 8 years ago by melf

comment:4 Changed 8 years ago by melf

Open pdf from desktop (lucide2_1.jpg) and saving somewhere (lucide2.jpg). Opening a pdf form the web, Google (lucide3.jpg) and saving somewhere (lucide3_1.jpg).

In these pictures you'll notice I use FOC, but I have uninstalled FOC (and rebooted) and the result is the same without it. (That's why I again installed FOC). I cannot reproduce it with any other program. As you see the file name in both cases are surrounded by Desktop Copy. Could it be due to eco runtime?? But then why only in Lucide?

comment:5 follow-up: Changed 8 years ago by diver

sorry but i still cant reproduce it. of course it adds "copy" to it but no desktop. and to be honest i asked a couple of ppl. and no one else can reproduce it.

comment:6 in reply to: ↑ 5 Changed 8 years ago by melf

Replying to diver:

sorry but i still cant reproduce it. of course it adds "copy" to it but no desktop. and to be honest i asked a couple of ppl. and no one else can reproduce it.

OK, I'll be in touch if I can figure out the problem.

comment:7 Changed 8 years ago by melf

Well, it turned out to be a key in the os2.ini file. Under Lucide there was a key named "Last Used Dir" or something like that. It never changed regardless which "dir" I used latest. It was "C:\Desktop" all the time.

When I changed it to C:\Programs I instead got Programs[filename]Copy.pdf when saving a file. So I deleted everything about Lucide in the ini-file and then reinstalled Lucide (1.3.3). Then this key was no longer present and the file name just got Copy afterwards and nothing before.

comment:8 Changed 8 years ago by diver

ok thats the expected behaviour. so all works as designed for you now.

Note: See TracTickets for help on using tickets.