Opened 3 years ago

Last modified 20 months ago

#220 new defect

Just printing the first page

Reported by: melf Owned by:
Priority: major Milestone: 1.4
Component: Lucide Core Version: 1.3
Keywords: Cc:

Description

If my system has been running for a while, let's say an hour (I have no exact time)Lucide just print the first page of a pdf. But if I restart eCS2.0 and print directly after this reboot, Lucide is printing normally, all pages.

Other apps don't show that behaviour. I'm printing on a Kyocera FS-1000 via SLPR (the printer is connected to another computer with eCS2.0). I can't see any difference in the LPR-command window on the receiving computer, in regard to successful or failed prints, both shows up as received and printed.

Change History (17)

comment:1 Changed 3 years ago by diver

did you try print as image? does this show the same problem?

comment:2 Changed 3 years ago by melf

Print as image is my only option.

comment:3 Changed 3 years ago by melf

Additional info. Just tried to print out a pdf - first side only with Lucide, but trying Acrobat reader 5 works alright.

An observation: In Lucide pages not being printed is numbered faster than the printed page. When all pages are printed, each pagenumber (e.g. 1/8, 2/8, 3/8 and so on) is displayed for about one second. But if printing just works for the first page, this number (e.g. 1/8)is displayed about one second, while the following (2/8, 3/8, 4/8 and so on) is displayed much faster, like 0,25 seconds each.

comment:4 follow-up: Changed 3 years ago by diver

  • Milestone set to Feedback Pending

is the printing problem only with one pdf? or with all pdf?
as i don't see that behaviour here.

please try 1.3.3

comment:5 in reply to: ↑ 4 ; follow-up: Changed 3 years ago by melf

Replying to diver:

is the printing problem only with one pdf? or with all pdf?
as i don't see that behaviour here.

please try 1.3.3

It goes for "all" pdf:s, not just for special ones. I'll try the 1.3.3 and report back.

comment:6 in reply to: ↑ 5 Changed 3 years ago by melf

Replying to melf:

Replying to diver:

is the printing problem only with one pdf? or with all pdf?
as i don't see that behaviour here.

please try 1.3.3

It goes for "all" pdf:s, not just for special ones. I'll try the 1.3.3 and report back.

The behaviour with 1.3.3 is unfortunately the same.

comment:7 follow-up: Changed 3 years ago by diver

i need to see if i can reproduce that somehow. as i only use PS printer i don't have that problem.

comment:8 Changed 3 years ago by diver

  • Milestone changed from Feedback Pending to 1.3.3

comment:9 in reply to: ↑ 7 Changed 3 years ago by melf

Replying to diver:

i need to see if i can reproduce that somehow. as i only use PS printer i don't have that problem.

Just a reminder and update. The problem is persistent, also with 1.3.4 beta.

comment:10 Changed 2 years ago by melf

My printserver has been changed to a win2000 with line printer daemon running. The printing behaviour of Lucide is persistent.

comment:11 Changed 2 years ago by herwigb

Just my 2 cents:
Your bugreport lacks several important pieces of information:

  • Which OS/2 printer driver (type and revision) is used?
  • Which printer language is used (PCL, PS, ESC/P, other)?
  • As the Kyocera FS-1000 appears to be a GDI printer, is CUPS used or not?
  • The spooler is enabled or disabled?
  • Which applications are run on the machine between a reboot, when printing of all pages works, and the moment, when only the first page is printed anymore.
  • What happens if you install and use a PDF writer? It may be pointless to print a PDF to a PDF writer, but it will provide several important informations about the printing process and where it fails.

From your description, I would guess that it is possibly NOT Lucides fault, but some other component in the printing process (Lucide would likely crash), but without additional information there is no chance to pin down your problem, as diver does not have the problem (me neither).

Last edited 2 years ago by herwigb (previous) (diff)

comment:12 Changed 2 years ago by melf

OS2 driver? - the one shipped with eCS 2.1 - 30.827

Printer language? - "HP-GL/2" is checked.

CUPS? - CUPS is not used.

Spooling? - Enabled. "Print while spooling" is checked also

Which apps between? - Usually Open office, Thunderbird and Firefox

Pdf writer? - Using ePdf when printer just print first page - a complete set of pages is created.

Please also notice that NO other application behaves like Lucide does. I can print with eg Open Office, Acrobat reader, Text editor, and so on WITHOUT the described problem.

Last edited 2 years ago by melf (previous) (diff)

comment:13 Changed 2 years ago by melf

Have made some tests: 1)Using different apps (FF,OO,Thunderbird,Texteditor) in between two print-tryouts didn't seem to affect behaviour. Printing worked fine before and after.

2) Printing with other apps (OO,Texteditor, Word Pro) in between in two sets with reboot between: In set one printing changed to "one-page-printing" after printing with WordPro?. In set two printing worked fine whatever app (OO,Texteditor, Word Pro) I printed with in between.

Simple tests maybe, but they doesn't point to any direct connection to other apps I normally use. Also again: any other tried app print the amount of pages I request. And a reboot make Lucide print normal again (for a while).

Last edited 2 years ago by melf (previous) (diff)

comment:14 Changed 2 years ago by melf

Printing via Ghostscript (GsView?) is also fully functional and does not show the described problems.

Version 0, edited 2 years ago by melf (next)

comment:15 Changed 20 months ago by melf

Related to #242??

comment:16 Changed 20 months ago by diver

if "Print as image" works please use that for this printer.

comment:17 Changed 20 months ago by melf

As you can see in the beginning of this thread "print as image" is my only choice - so it is used.

Note: See TracTickets for help on using tickets.