Opened 10 years ago

Last modified 13 months ago

#173 assigned enhancement

Cannot handle scripted PDF forms (dropdowns, etc.)

Reported by: hanno Owned by: gyoung
Priority: minor Milestone: 1.4.1
Component: Lucide Core Version: 1.3
Keywords: Cc:

Description

Thanks for your great work and the feature to fill forms!

In general it works, but I have a "difficult" form with some problems (so I included a file to test):

  • If there is a pulldown menu within the PDF, no data entry is possible (see field "fur den Kalendermonat")
  • font size problems
  • calculations are not made within the form

I think it's the best to test this PDF with Acrobat Reader 5.1.0, to see how it should work.

Thanks again! Hanno

Attachments (1)

U30.zip (127.7 KB) - added by hanno 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by hanno

comment:1 Changed 10 years ago by diver

  • Milestone changed from 1.3 to 2.0 and further

ah this is due to the scripting in Acrobat. poppler doesn't support that. we can't do anything about that sorry

comment:2 Changed 4 years ago by lewisr

  • Type changed from defect to enhancement

Moving to enhancement, as improvements to poppler may have impacted this (not sure).

comment:3 Changed 4 years ago by lewisr

  • Milestone changed from 2.0 and further to Future

Milestone renamed

comment:4 Changed 3 years ago by lewisr

  • Priority changed from major to minor
  • Summary changed from Lucide 1.30 and filling forms to Cannot handle scripted PDF forms (dropdowns, etc.)

Editing summary to better reflect the specific issue, here. This is indeed a poppler limitation, and not a Lucide limitation, however.

comment:5 Changed 3 years ago by lewisr

Related: #229

comment:6 Changed 13 months ago by gyoung

  • Milestone changed from Future to 1.4.1

comment:7 Changed 13 months ago by gyoung

  • Owner set to gyoung
  • Status changed from new to assigned
Note: See TracTickets for help on using tickets.