Opened 9 years ago

Closed 3 years ago

#170 closed defect (fixed)

Mouseproblem in fullscreen-mode (xPager)

Reported by: Batchheizer Owned by:
Priority: major Milestone:
Component: Lucide Core Version: 1.3
Keywords: Cc:

Description

Viewing a file in fullscreen mode makes the mouse disappear even if an other xPager (ePager)-Screen is activated.

Maybe an option "Do not hide mouse in fullcreen" could help.

Version 1.21 eCS 2 Silver Release, Amouse.

Change History (4)

comment:1 Changed 9 years ago by Batchheizer

  • Version changed from 1.2 to 1.3

Problem still exist in 1.3

comment:2 Changed 9 years ago by dmik

I think that's because WM_MOVE messages are not delivered to Lucide when you move the mouse pointer over a different xPager screen and as a result the mouse isn't unhidden. There are two solutions: either handle undocumented WM_MOUSELEAVE message and unhide the mouse pointer on it or capture the mouse on going to presentation mode (so that WM_MOVE still gets delivered to Lucide even if it happens not under its window).

comment:3 Changed 4 years ago by lewisr

Late, late follow-up!

I am not seeing this in 1.3.5 under SNAP Pro. is this still an issue?

comment:4 Changed 3 years ago by lewisr

  • Resolution set to fixed
  • Status changed from new to closed

Resolving as fixed as cannot reproduce under 1.3.6 beta, and no follow-up from reporter.

Note: See TracTickets for help on using tickets.