Opened 13 years ago

Closed 10 years ago

#17 closed defect (wontfix)

slow rendering of certain pages

Reported by: joachim@… Owned by: eros2
Priority: minor Milestone:
Component: Plugin: PDF Version: 1.0 Beta 1
Keywords: slow rendering Cc:

Description

Please see page 3,4,6 etc. of this PDF document. They seem to render quite slow, especially when compared to Acrobat Reader 4.

Change History (6)

comment:2 Changed 13 years ago by ktk

I tested this with Evince on Linux, on the same machine as my eCS Installation with Lucide. It's quite hard to say if it is faster on Linux, the thing is that Evince seems to render the page first completely and then display it fast. This means if the rendering is not yet done you see a white page first for a short period. Then it seems to cache around 4 pages so if you klick forward/backward it is fast but when you scroll too fast it gets rather slow again and has to calculate it first.

This means probably it's indeed a Poppler problem but it's hard to confirm.

comment:3 Changed 13 years ago by anonymous

  • Milestone Beta 1 deleted
  • Version set to 1.0 Beta 1

Reassignment to beta 1, needs more testing. After some more tests I am pretty sure the OS/2 version is a bit slower than for example Evince on the same system.

comment:4 Changed 10 years ago by diver

is this still true with lucide 1.21?

comment:5 Changed 10 years ago by jojo

Judge for yourself. It seems fairly acceptable now (on a T60) but it is still 'noticably' rendering these pages with images. It is no doubt caused by the way these graphics are implemented.

That said, it is not *annoyingly* slow anymore, which it was at the time I reported this issue.

comment:6 Changed 10 years ago by diver

  • Resolution set to wontfix
  • Status changed from new to closed

so i close this issue. please test again with 1.3 when it's out. if it's again slow like hell open a new ticket.

Note: See TracTickets for help on using tickets.