Opened 13 years ago

Closed 12 years ago

#115 closed defect (fixed)

Cannot install 1.0 GA when drive C: is unavailable

Reported by: guest Owned by: eros2
Priority: major Milestone:
Component: Lucide Core Version: 1.0
Keywords: Installation Cc:

Description

Lucide installation now requires that UClip be installed first.

UClip installation (once the file has been found) requires WarpIN, this week's version.

Running the UClip .wpi file, WarpIN (after it has been updated) then asks where UClip should be installed (suggesting a directory on the eComStation boot volume, F:, which is fine).

But then it reports that a directory on C: does not exist, and should it create it?

The answer to the question (on my system) is NO! C: is not available as a dumping ground for some extraneous files. (At any given time, I have one "live" C: and another hidden C:).

WarpIN does not provide an opportunity to install UClip to any other directory or drive. When the response is not to create a file on C:, the program shuts down, game over.

For want of a nail, the kingdom was lost. Lucide cannot be installed unless one is willing to have drive C: trashed.

Windows always requires C:; OS/2 never has. Lucide has mimicked this deplorable trait of Windows.

Change History (4)

comment:1 Changed 13 years ago by guest

Moan at the author of UClip then, not the author of WarpIN. WarpIN is only doing what it is told by the UClip packge.

I don't appreciate your "this week's version" quip either. You're damned if you do update software and you're damned if you don't. Go to hell whoever you are.

PR

comment:2 follow-up: Changed 13 years ago by guest

Well, leaving the bashing aside:

What is the specific reason for Lucide to require UClip ? Couldn't these few function be loaded dynamically, so that Lucide would use UClip only, if it's avalable ?

comment:3 in reply to: ↑ 2 Changed 12 years ago by eros2

Couldn't these few function be loaded dynamically, so that Lucide would use UClip only, if it's avalable ?

Well, it's possible.

comment:4 Changed 12 years ago by eros2

  • Resolution set to fixed
  • Status changed from new to closed

(In [218]) make UClip package optional (closes #115)

Note: See TracTickets for help on using tickets.