Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#112 closed defect (fixed)

kmk_sed fails if kBuild was compiled with gcc 4.7

Reported by: Sérgio Monteiro Basto Owned by: bird
Priority: major Milestone:
Component: kBuild Version: noversion
Keywords: Cc:

Description

when we packaging on Fedora we use kBuild compiled by us: http://koji.fedoraproject.org/koji/packageinfo?packageID=7356

after use kBuild (trunk version), compiled with gcc 4.7. I got this error on building virtuaBox

/usr/bin/kmk_sed: file /builddir/build/BUILD/VirtualBox-4.1.8_OSE/src/VBox/Runtime/common/err/errmsg.sed line 31: Unmatched [ or [^
kmk: *** [/builddir/build/BUILD/VirtualBox-4.1.8_OSE/obj/obj/Runtime/errmsgdata.h] Error 1
kmk: *** Deleting file `/builddir/build/BUILD/VirtualBox-4.1.8_OSE/obj/obj/Runtime/errmsgdata.h'
kmk: *** Waiting for unfinished jobs....

kmk_sed doesn't read well /builddir/build/BUILD/VirtualBox-4.1.10/src/VBox/Runtime/common/err/errmsg.sed

the problem is when is generate errmsgdata.h.

Change History (5)

comment:1 Changed 8 years ago by Sérgio Monteiro Basto

Summary: kmk_sed fails if kBuild was compile with gcc 4.7kmk_sed fails if kBuild was compiled with gcc 4.7

comment:2 Changed 8 years ago by Sérgio Monteiro Basto

Using kBuild revision 2570 compiled with gcc in Fedora 17, (kBuild-0.1.9998-6.2570.fc17.x86_64.rpm ) I got same problem if try compile VirtualBox? on F16 , so is a kmk_sed especific problem with gcc 4.7

comment:3 Changed 7 years ago by Sérgio Monteiro Basto

any news ?

comment:4 Changed 7 years ago by bird

Resolution: fixed
Status: newclosed

Fixed in r2727. Kudos to glen (aka Elan Ruusamäe) for pointing me in the right direction here. The problem was fixed upstream (which in this case is glibc) a good while back: https://sourceware.org/git/?p=glibc.git;a=commitdiff;h=2ba92745c36eb3c3f3af0ce1b0aebd255c63a13b;hp=c0da14cdda1fa552262ce3624156194eef43e973

comment:5 Changed 6 years ago by Sérgio Monteiro Basto

Many thanks

Note: See TracTickets for help on using tickets.