Changes between Version 78 and Version 79 of WikiStart


Ignore:
Timestamp:
May 12, 2011, 10:58:40 PM (8 years ago)
Author:
dmik
Comment:

Added WSE announce.

Legend:

Unmodified
Added
Removed
Modified
  • WikiStart

    v78 v79  
    3939== Latest Version ==
    4040
    41 The latest version of OpenJDK 6 is '''1.6.0-b22 RC2''' released on 28.03.2011. This is a second release candidate version that fixes a number of bugs in the previous release candidate as well as updates OpenJDK to beta 22 (released February, 2011, the detailed change log is available [http://blogs.sun.com/darcy/resource/OpenJDK_6/openjdk6-b22-changes-summary.html here]).
     41The latest version of OpenJDK 6 is '''1.6.0-b22 WSE''' released on 12.05.2011. This is a special build dedicated to the [http://www.warpstock.eu/ Warpstock Europe 2011] event that took place 6 to 8 May 2011 in the nice city of Haarlem in The Netherlands. This build brings fixed printing support and the fix for the Java process hang on SMP machines.
    4242
    43 The more detailed list of changes can be found [source:/tags/rc2/doc/CHANGES.OS2 here].
     43The more detailed list of changes can be found [source:/tags/wse/doc/CHANGES.OS2 here].
    4444
    45 Version '''1.6.0-b22 RC2''' is available for downloading in the following packages and formats.
     45Version '''1.6.0-b22 WSE''' is available for downloading in the following packages and formats.
    4646
    4747==== Prerequisites ====
    4848
    4949||'''GCC 4 Core Libraries'''||[http://download.smedley.info/gcc452.zip ZIP]||GCC 4 runtime libraries needed for all Odin32 based installations.||
    50 ||'''Odin32 Library'''||[ftp://ftp.netlabs.org/pub/odin/odin32bin-20110328-release.wpi WPI]||Odin32 runtime libraries version '''0.6.21606''' needed for all OpenJDK packages.||
     50||'''Odin32 Library'''||[ftp://ftp.netlabs.org/pub/odin/odin32bin-20110512-release.wpi WPI]||Odin32 runtime libraries version '''0.6.21632''' needed for all OpenJDK packages.||
    5151||'''xsystray widget'''||[ftp://ftp.netlabs.org/pub/qt4/xsystray/xsystray-0_1_1.wpi WPI]||Extended system tray widget for XCenter/eCenter version '''0.1.1''' needed to support system tray functionality in Java applications.||
    5252
    5353==== OpenJDK Packages ====
    5454
    55 ||'''OpenJDK 6 JRE'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_rc2/openjdk6_b22_jre_os2_rc2-20110328.zip ZIP]||JRE package needed to run Java programs. '''Not recommended for SMP systems''' (see below).||
    56 ||'''OpenJDK 6 SDK'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_rc2/openjdk6_b22_sdk_os2_rc2-20110328.zip ZIP]||SDK package needed to compile Java programs. Includes a copy of the JRE package. '''Not recommended for SMP systems''' (see below).||
    57 ||'''OpenJDK 6 JRE (SMP Friendly)'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_rc2/openjdk6_b22_jre_os2_rc2-20110328_mpunsafe.zip ZIP]||JRE package, same as above but with all executables marked as MPUNSAFE which makes them more or less stable on SMP machines by sticking to a single core (rare hangs are still possible).||
    58 ||'''OpenJDK 6 SDK (SMP Friendly)'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_rc2/openjdk6_b22_sdk_os2_rc2-20110328_mpunsafe.zip ZIP]||SDK package, same as above but with all executables marked as MPUNSAFE which makes them more or less stable on SMP machines by sticking to a single core (rare hangs are still possible).||
     55||'''OpenJDK 6 JRE'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_wse/openjdk6_b22_jre_os2_wse-20110512.zip ZIP]||JRE package needed to run Java programs. '''Not recommended for SMP systems''' (see below).||
     56||'''OpenJDK 6 SDK'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_wse/openjdk6_b22_sdk_os2_wse-20110512.zip ZIP]||SDK package needed to compile Java programs. Includes a copy of the JRE package. '''Not recommended for SMP systems''' (see below).||
     57||'''OpenJDK 6 JRE (SMP Friendly)'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_wse/openjdk6_b22_jre_os2_wse-20110512_mpunsafe.zip ZIP]||JRE package, same as above but with all executables marked as MPUNSAFE which makes them more or less stable on SMP machines by sticking to a single core (rare hangs are still possible).||
     58||'''OpenJDK 6 SDK (SMP Friendly)'''||[ftp://ftp.netlabs.org/pub/java/openjdk6_b22_wse/openjdk6_b22_sdk_os2_wse-20110512_mpunsafe.zip ZIP]||SDK package, same as above but with all executables marked as MPUNSAFE which makes them more or less stable on SMP machines by sticking to a single core (rare hangs are still possible).||
    5959
    6060If you want to play with the latest development version, you can check it out directly from the SVN repository. In order to do so you need to download and install the subversion client for eCS (OS/2). Use the following command to check out the full source tree to a ''<local_directory>'':
     
    6363}}}
    6464
    65 The required tools and build instructions are described in the [source:/tags/rc2/README README] file.
     65The required tools and build instructions are described in the [source:/tags/wse/README README] file.
    6666[[br]][[br]]
    6767