Opened 4 years ago

Closed 4 years ago

#98 closed defect (fixed)

Some texts are missing on Java Application

Reported by: djcaetano Owned by:
Priority: major Milestone: GA
Component: general Version: 1.6.0-b22 RC2
Severity: medium Keywords: text printing
Cc:

Description

I have noticed some swing applications are displayed with missing parts on eComStation, text data, for instance. This is an exemple of such application: http://www.receita.fazenda.gov.br/publico/programas/IRPF/2011/PGDIRPF2011/Java/zip/IRPF2011v1.0.zip

I am attaching two snapshots: one taken when running this program on Windows and another running it on eComStation. Although it runs on eComStation, the missing text renders it unusable.

Attachments (2)

irpf_win.jpg (124.6 KB) - added by djcaetano 4 years ago.
Java program running on Windows
irpf_ecs.jpg (93.4 KB) - added by djcaetano 4 years ago.
Java program running on eComStation

Download all attachments as: .zip

Change History (6)

Changed 4 years ago by djcaetano

Java program running on Windows

Changed 4 years ago by djcaetano

Java program running on eComStation

comment:1 Changed 4 years ago by dmik

Turned out that the problem is that it wants to use HTML in label widgets in the side bar but HTML formatting doesn't get turned on. You may also see various HTML markup like   instead of the HTML-formatted text in the help window. The very same problem exists in other applications, e.g. the Help screen of jEdit. I will try to look at it before GA.

Thank you for the report!

comment:2 Changed 4 years ago by dmik

The simple test case

  JLabel label = new JLabel ("<html><i>Hello World</i></html>");

reveals the problem too. The label contains nothing and I get some strange java.io.EOFException.

The fun thing is that the debug version works.

comment:3 Changed 4 years ago by dmik

To say more, it's a regression of RC2 (i.e. updating to from b19 to b22). This explains why the debug version works: some parts of my debug build are still at b19 level. This regression needs to be solved for GA.

comment:4 Changed 4 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r288. Turned out to be a tricky vendor bug (see the changeset). This code makes an impression of being too raw actually.

Note: See TracTickets for help on using tickets.