Opened 9 years ago

Closed 8 years ago

#87 closed defect (fixed)

Jeti/2 crashes often at startup

Reported by: yoda Owned by:
Priority: major Milestone: GA
Component: general Version: 1.6.0-b22 WSE
Severity: high Keywords: jeti
Cc: yoda

Description

approx half the times I try to start Jeti/2
it crashes.

If it starts OK, it can usually run for a long time.

Logs attached.

Attachments (5)

Crash073.zip (6.4 KB) - added by yoda 9 years ago.
Crash083.zip (1.1 KB) - added by yoda 9 years ago.
Crash087.zip (2.1 KB) - added by yoda 9 years ago.
Crash093.zip (6.8 KB) - added by yoda 9 years ago.
Crash100.zip (1.8 KB) - added by yoda 9 years ago.

Download all attachments as: .zip

Change History (22)

Changed 9 years ago by yoda

comment:1 Changed 9 years ago by dmik

  • Milestone changed from RC2 to GA

Will try to look at it once more before GA.

comment:2 Changed 9 years ago by dmik

  • Priority changed from major to Feedback Pending

Please check it with RC2 and attach new logs if the problem still persists.

comment:3 Changed 9 years ago by yoda

  • Priority changed from Feedback Pending to major
  • Version changed from 1.6.0-b19 RC to 1.6.0-b22 RC2

RC2 seems to have improved on these particular crashes. After
starting Jeti/2 maybe 10 times now, I haven't seen it. However
Jeti/2 now sometimes disconnects - likely in same situation
where it before would have crashed. I'm still trying to catch
that situation for logs....

Since RC2 now should have fixed sound support, I re enabled sound.
Now, half the times I start Jeti, one of the sounds will suddanly
starts repeating a small piece of itself for some seconds, and then
app crashes. There is only an entry in popuplog.os2 (attached)

Changed 9 years ago by yoda

comment:4 Changed 9 years ago by yoda

Just had another crash, logs attached

Changed 9 years ago by yoda

comment:5 Changed 9 years ago by yoda

Another weird crash, log93 attached

Changed 9 years ago by yoda

comment:6 Changed 9 years ago by yoda

Another crash, log100 attached

Changed 9 years ago by yoda

comment:7 follow-up: Changed 8 years ago by dmik

  • Priority changed from major to Feedback Pending

Crash083 is in MMPM.DLL, most likely there is a problem with your audio driver.

Crash087 and Crash100 are at JVM+0x25cdd1 which is java_lang_Throwable::fill_in_stack_trace(Handle throwable, TRAPS) again. Which most likely means that it fails when trying to write the java stack trace to the log. So what we ses is not the original problem...

Crash093 is at c1_ValueType.cpp:118 which looks like some memory corruption.

In either case, I need the full stack trace. Please grab the crash data with PROCDUMP. And too bad that I can't reproduce it here.

comment:8 in reply to: ↑ 7 Changed 8 years ago by yoda

  • Priority changed from Feedback Pending to major

I am now testing Jeti/2 on my laptop. It has HDA audio,
and uses the latest UNIAUD driver.

Replying to dmik:

Crash083 is in MMPM.DLL, most likely there is a problem with your audio driver.

I can start Jeti/2 with no problems using Java 1.41 GA
All sounds are enabled in Jeti/2, and due to subscription
to several MUCs, a lot of (historical) activity is shown
at startup - resulting in a lot of sounds. It is very clear
that this goes wrong every time I start Jeti with Java 6
It either crashes or hangs. If I turn sounds OFF, Jeti is
a lot more stable, so there is clearly a problem with sound
implementation.

It has been tested by others, that Java 6 doesn't opens souns
in shared mode, and that is a very bad thing.

Crash087 and Crash100 are at JVM+0x25cdd1 which is java_lang_Throwable::fill_in_stack_trace(Handle throwable, TRAPS) again. Which most likely means that it fails when trying to write the java stack trace to the log. So what we ses is not the original problem...

Crash093 is at c1_ValueType.cpp:118 which looks like some memory corruption.

In either case, I need the full stack trace. Please grab the crash data with PROCDUMP. And too >bad that I can't reproduce it here.

Can't upload them here due to size, so I emailed a bunch to Dmik.

comment:9 follow-up: Changed 8 years ago by dmik

  • Priority changed from major to Feedback Pending

Please try the latest WSE release together with the -XX:+UseMembar command line option for java.exe to see if it fixes crashes for you.

comment:10 Changed 8 years ago by dmik

Actually, provided that you run it on UNI, the UseMembar? switch won't affect your execution at all. But still, test it with the new WSE release please.

I also can't see your procdump dumps in my mail for some reason. Could you please re-upload it to my ftp (ftp://ftp.dmik.org/incoming/)?

comment:11 Changed 8 years ago by yoda

I´m not sure, what you mean about "UNI".
I normally run system i SMP (2 cores), and use "mpunsafe" build of Java.
Are you saying I should try the "normal" version with the "usemembar" option ?

dumps will be sent to your ftp, when I have some new for WSE build.

comment:12 Changed 8 years ago by dmik

By UNI I mean that you run Java applications either with the UNI kernel or using the MPUSAFE build of Java.

comment:13 follow-up: Changed 8 years ago by dmik

The links to the new test build are available here: ticket:96#comment:14.

Please try it in both SMP mode (PSD=ACPI.PSD /SMP in config.sys) and UNI mode (just PSD=ACPI.PSD).

comment:14 in reply to: ↑ 9 Changed 8 years ago by Yoda

  • Priority changed from Feedback Pending to major
  • Version changed from 1.6.0-b22 RC2 to 1.6.0-b22 WSE

Replying to dmik:

Please try the latest WSE release together with the -XX:+UseMembar command line option for
java.exe to see if it fixes crashes for you.

Testing with the WSE release and -XX:+UseMembar? didn't make much changes, when using the
mpunsafe build, but using the true SMP build actually seems to stop most crashes (still
with membar option).

comment:15 in reply to: ↑ 13 Changed 8 years ago by Yoda

Replying to dmik:

The links to the new test build are available here: ticket:96#comment:14.

Please try it in both SMP mode (PSD=ACPI.PSD /SMP in config.sys) and UNI mode (just PSD=ACPI.PSD).

I've been trying this new build in SMP mode, and so far no repeatable crashes.

I'm currently running with sound disabled, as it previously created other crashes pretty often.
Will try to enable it, and put more feedback about that in here.

comment:16 Changed 8 years ago by Yoda

I enabled sound again, and have been running Jeti/2 for a few days.
I have not had any crashes at all in full SMP mode, using the new
versions from #96, so I think we can declare this (original)
problem solved.
The exclusive use of sounds is still annoying, but as this is
a generic problem, I opened ticket #120 for this.

comment:17 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Closing this.

Note: See TracTickets for help on using tickets.