Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#85 closed defect (wontfix)

TV Browser windows size in settings windows not correct

Reported by: Michaelhz Owned by:
Priority: major Milestone: RC2
Component: general Version: 1.6.0-b19 RC
Severity: low Keywords:
Cc:

Description

After certain testing TVBrowser (3.0 RC3) (http://www.tvbrowser.org/) works so far. Unfortunately the settings window do not appear in the correct size. Control-buttons (like "OK") are only visible after window resize by hand. This bug is probably not related to RC-Status of TVBrowser. It does not occur under WinXP-Java. See also the attached pictures.

Attachments (6)

Eingefangen002.jpg (27.7 KB) - added by Michaelhz 7 years ago.
Eingefangen003.jpg (65.4 KB) - added by Michaelhz 7 years ago.
Eingefangen004.jpg (54.7 KB) - added by Michaelhz 7 years ago.
Eingefangen001.jpg (117.1 KB) - added by Michaelhz 7 years ago.
tvbrowser.cmd (250 bytes) - added by Michaelhz 7 years ago.
settings.jpg (41.8 KB) - added by dmik 7 years ago.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by Michaelhz

Changed 7 years ago by Michaelhz

Changed 7 years ago by Michaelhz

comment:1 follow-up: Changed 7 years ago by dmik

I just tried TV Browser 3.0 RC3 and cannot confirm the problem: here I get the right size of the settings dialog (Nimbus theme, checked both English and Deutsch locale). Are you sure the right Odin version is being used?

Try also to remove TV Browser settings from your %HOME% and/or a fresh eComStation install (e.g. in VirtualBox?).

Changed 7 years ago by Michaelhz

Changed 7 years ago by Michaelhz

comment:2 in reply to: ↑ 1 Changed 7 years ago by Michaelhz

Replying to dmik:

I just tried TV Browser 3.0 RC3 and cannot confirm the problem: here I get the right size of the settings dialog (Nimbus theme, checked both English and Deutsch locale). Are you sure the right Odin version is being used?

Odin was Feb 21, 2011, see attached picture, also nimbus theme and tango icons

Try also to remove TV Browser settings from your %HOME% and/or a fresh eComStation install (e.g. in VirtualBox?).

%HOME% was set to an empty directory before installation (See tvbrowser.cmd), since importing 2.7.5 tvbrowser files failed.
Problem occured on two different eCS Silver installations. I'll try on a clean eCS GA Install later and get you informed.

comment:3 Changed 7 years ago by dmik

Okay. I'm attaching my screenshot of the settings page so that you don't think I misunderstood you. I didn't resize the window, I simply pressed the Settings button on the toolbar and then simply navigated to this page through the side list.

Changed 7 years ago by dmik

comment:4 Changed 7 years ago by dmik

  • Resolution set to wontfix
  • Status changed from new to closed

Okay, I reproduced the problem. I get the same result as you once I select the "Choose web browser:" radio button and enter a path to the executable into the following field.

However, I found that exactly the same layout error is shown by OpenJDK6 on Linux. And even Sun JDK6 has various layout errors (not exactly the same, but similar ones, in various places). So my conclusion is that it's a problem of the program and/or both Sun JDK and OpenJDK themselves, e.g. not related to our port at all. So we are not going to fix it.

comment:5 Changed 7 years ago by Michaelhz

Thanks for your efforts!! I have definetely no reason to think about any misunderstanding. The reason the problem does not come up under win-java is that the browser does not need to be configured.

Note: See TracTickets for help on using tickets.