Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#83 closed defect (invalid)

wps doesn't start after reboot after having installed odin

Reported by: haraldkamm Owned by:
Priority: major Milestone:
Component: general Version: 1.6.0-b19 RC
Severity: medium Keywords:
Cc:

Description

After having installed the latest odin-release the wps doesn't start anymore, i. e. freezes immediately after having visualized the background colour and mousepointer. A restore of the system configuration doesn't help (using robosave), I needed to restore the
complete os/2 directory (what does the installation routine?). The problem is reproduceable with all the newer odin releases. Any hint?

Sincerely, Harald

Change History (3)

comment:1 follow-up: Changed 9 years ago by dmik

  • Resolution set to invalid
  • Status changed from new to closed

This is probably your local failure. The Odin installer does not do anything special with WPS but creates ordinary WPS objects (and this part of the installer is the same for many years). It also writes to the Open32 registry (also in quite an ordinary way) but WPS should not have anything to do with it (though it's known that the registry API may give fancy failures with a variety of very strange consequences.

It's also known that WPS tends to f*ck itself up sometimes and that it is not solvable by restoring from the previous desktop archive (I don't know what robosave is).

Anyway, this doesn't look related to Java at all. Neither it looks such to Odin. So we are not going to work on that given what information we have now.

comment:2 in reply to: ↑ 1 Changed 9 years ago by haraldkamm

Replying to dmik:

I presume that there is some particular condition on my system, but as I use WarpIn? on a regular base _without_ any problems of this kind there must be something related to the installation procedure of the latest Odin releases. Robosave is an excellent EWS software, maybe nowadays almost forgotten: imho the best comandline backup-program for the OS/2 desktop:

ROBOSAVE (ROBOSV) V3.04 by Dick Kurtz and
Jeff Knauth. (c) Copyright International
Business Machines Corporation 1994. All
rights Reserved. ROBOSAVE allows you to
easily back up your OS/2 2.x Desktop and
later restore it to the same system. You
can also specify a limited number of files
to be saved/restored. A simple text
profile controls the ROBOSAVE operation.

Sincerely, Harald

This is probably your local failure. The Odin installer does not do anything special with WPS but creates ordinary WPS objects (and this part of the installer is the same for many years). It also writes to the Open32 registry (also in quite an ordinary way) but WPS should not have anything to do with it (though it's known that the registry API may give fancy failures with a variety of very strange consequences.

It's also known that WPS tends to f*ck itself up sometimes and that it is not solvable by restoring from the previous desktop archive (I don't know what robosave is).

Anyway, this doesn't look related to Java at all. Neither it looks such to Odin. So we are not going to work on that given what information we have now.

comment:3 Changed 9 years ago by dmik

Unfortunately, there is nothing we can do here. Mainly because there is no acceptable way to debug such WPS failures, but also (as already mentioned) due to the fact that there is a very low probability that Odin is guilty here: the installation procedure has not had any significant changes in years.

I can only recommend you to install eComStation 2.0 GA from scratch and try to reproduce the problem there. If you are able to do so, you may open a new ticket in the Odin trac (http://svn.netlabs.org/odin32).

Note: See TracTickets for help on using tickets.