Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#82 closed defect (fixed)

EXCEPTION_ACCESS_VIOLATION in connection with COM ports

Reported by: Tapio_Angervuori Owned by:
Priority: Feedback Pending Milestone:
Component: general Version: 1.6.0-b24 GA2
Severity: low Keywords: EXCEPTION_ACCESS_VIOLATION, COM ports
Cc:

Description

LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=031bf5c4 lock=0x1
pid=0x00a8 ppid=0x007c tid=0x0003 slot=0x00b3 pri=0x0200 mc=0x0000
F:\JAVA142_04\BIN\JAVA.EXE
Process dumping was disabled, use DUMPPROC / PROCDUMP to enable it.

What do I do next?

Attachments (10)

pmdf.log (71.9 KB) - added by Tapio_Angervuori 9 years ago.
hs_err_pid6251.log (2.1 KB) - added by Tapio_Angervuori 8 years ago.
ibmcomm.dll (45.3 KB) - added by Tapio_Angervuori 8 years ago.
javacomm.prp (576 bytes) - added by Tapio_Angervuori 8 years ago.
comm.jar (47.8 KB) - added by Tapio_Angervuori 8 years ago.
javacomm4.zip (116.8 KB) - added by Tapio_Angervuori 8 years ago.
hs_err_pid1400.log (2.4 KB) - added by Tapio_angervuori 8 years ago.
Latest Java build, communication ports still not working.
hs_err_pid123.log (19.9 KB) - added by Tapio_angervuori 7 years ago.
chashes in the beginning
hs_err_pid142.log (19.8 KB) - added by Tapio_angervuori 7 years ago.
crash in the beginning
hs_err_pid160.log (1.2 KB) - added by Tapio_angervuori 7 years ago.
crash in the beginnning

Download all attachments as: .zip

Change History (26)

comment:1 follow-up: Changed 9 years ago by diver

please provide more details about the java app you are trying. and how to reproduce that. we really can't read you mind.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 9 years ago by Tapio_Angervuori

Replying to diver:

please provide more details about the java app you are trying. and how to reproduce that. we really can't read you mind.

By starting the program with the PRCDUMP ON, and with the ibmcomm.dll, javacomm.prp and comm.jar:

[E:\JVMVaaka\JVM]F:\java142_04\bin\java.exe -cp E:\JVMVAAKA\JVM;F:\java142_04\jre\lib\ext\comm.jar;.\.; SCALEX -s 194.137.111.68 80 -p COM2 COM1

LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=031df5c4 lock=0x1
pid=0x00f7 ppid=0x0066 tid=0x0004 slot=0x00ad pri=0x0200 mc=0x0000
F:\JAVA142_04\BIN\JAVA.EXE
Process has been dumped

By replacing the windows OS/2 COM port software with the windows ones (WIN32COM.DLL, javax.comm.properties and COMM.JAR), the following messageges are seen:

Port COM2 not found!
Port COM1 not found!
No serial ports found!

I'm still using the old COM ports!

comment:3 in reply to: ↑ 2 Changed 9 years ago by Tapio_Angervuori

Replying to Tapio_Angervuori:

Replying to diver:

please provide more details about the java app you are trying. and how to reproduce that. we really can't read you mind.

By starting the program with the PRCDUMP ON, and with the ibmcomm.dll, javacomm.prp and comm.jar:

[E:\JVMVaaka\JVM]F:\java142_04\bin\java.exe -cp E:\JVMVAAKA\JVM;F:\java142_04\jre\lib\ext\comm.jar;.\.; SCALEX -s 194.137.111.68 80 -p COM2 COM1

LIBC PANIC!!
_um_free_maybe_lock: Tried to free block twice - block=031df5c4 lock=0x1
pid=0x00f7 ppid=0x0066 tid=0x0004 slot=0x00ad pri=0x0200 mc=0x0000
F:\JAVA142_04\BIN\JAVA.EXE
Process has been dumped

By replacing the windows OS/2 COM port software with the windows ones (WIN32COM.DLL, javax.comm.properties and COMM.JAR), the following messageges are seen:

Port COM2 not found!
Port COM1 not found!
No serial ports found!

I'm still using the old COM ports!

P.S. The jre version 6 resides in the path F:\java142_04, The folders are only renamed!

Changed 9 years ago by Tapio_Angervuori

comment:4 Changed 9 years ago by Tapio_Angervuori

  • Keywords COM ports added
  • Summary changed from LIBC PANIC!! to LIBC PANIC in connection with COM ports

comment:5 Changed 9 years ago by dmik

Sorry, but it's still not clear on how to reproduce this. Please give us the exact versions of applications and DLLs you are trying to use.

comment:6 Changed 8 years ago by dmik

  • Priority changed from major to Feedback Pending

Please note that the defect will be closed if there is no feedback within one week.

Changed 8 years ago by Tapio_Angervuori

comment:7 Changed 8 years ago by Tapio_Angervuori

The latest Build 22 RC2 (2011-03-28) goes further now:
Build 22 RC2 (2011-03-28)
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x6e696e75, pid=6251, tid=409665540
#
# JRE version: 6.0-b22
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode os2-x86 )
# Problematic frame:
# C 0x6e696e75
#
# An error report file with more information is saved as:
# E:\JVMprog\JVM\hs_err_pid6251.log
SYS1808:
The process has stopped. The software diagnostic
code (exception code) is 780E.

comment:8 Changed 8 years ago by Tapio_Angervuori

  • Keywords EXCEPTION_ACCESS_VIOLATION added; LIBC PANIC!! removed
  • Summary changed from LIBC PANIC in connection with COM ports to EXCEPTION_ACCESS_VIOLATION in connection with COM ports
  • Version changed from 1.6.0-b19 RC to 1.6.0-b22 RC2

comment:9 Changed 8 years ago by diver

we still don't know which app you try. w/o this information we are not able to reproduce the problem.

Changed 8 years ago by Tapio_Angervuori

Changed 8 years ago by Tapio_Angervuori

Changed 8 years ago by Tapio_Angervuori

comment:10 Changed 8 years ago by Tapio_Angervuori

Here are the files for the Java Com API. The Com API is the latest one available from Sun.

Version 0, edited 8 years ago by Tapio_Angervuori (next)

Changed 8 years ago by Tapio_Angervuori

Changed 8 years ago by Tapio_angervuori

Latest Java build, communication ports still not working.

comment:11 Changed 8 years ago by Tapio_angervuori

I tried with the latest Java build, but there still seems to be some null pointers!
P.S. I also suddenly needed the stdcpp.dll, which has to be situated together with the jli.dll in the working directory!

comment:12 Changed 8 years ago by Tapio_angervuori

Also the Odin build is the latest one odin32bin-0_8_3.WPI

comment:13 Changed 8 years ago by diver

if you read the odin wiki carefully you see which gcc4core is needed. this gcc4core brings all needed dll with it. if the odin wpi is done wrong please complain to the odin wpi creator. we only deliver rpm and zip of odin.

Changed 7 years ago by Tapio_angervuori

chashes in the beginning

Changed 7 years ago by Tapio_angervuori

crash in the beginning

Changed 7 years ago by Tapio_angervuori

crash in the beginnning

comment:14 Changed 7 years ago by Tapio_angervuori

I tested the latest version OPENJDK6_B24 together with the odin-0.8.4: Communication ports are working again!
I got couple of crashes in the beginning, which luckily vanished and did not reappear.
These log files are attached.

comment:15 Changed 7 years ago by Tapio_angervuori

  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 1.6.0-b22 RC2 to 1.6.0-b24 GA2

comment:16 Changed 7 years ago by dmik

Good, thanks for testing.

The logs look like the stack corruption (maybe due to the array overflow or like that). Hard to say more. Feel free to open a new report (+ all steps to reproduce, including JNI DLLs) if it reappears.

Note: See TracTickets for help on using tickets.