Opened 9 years ago

Closed 9 years ago

#55 closed defect (fixed)

Streamtastic problems or crash

Reported by: Batchheizer Owned by:
Priority: major Milestone:
Component: general Version: 1.6.0-b19 Beta 2
Severity: Keywords:
Cc:

Description

Streamtastic: Java GUI frontend for Streamripper

http://launchpad.net/streamtastic/0.4/0.4.0/+download/Streamtastic-0.4.0u2.zip

First try: grafic problems: No windows, only a few buttons appear.
Second try: Crash (see attached file)

Attachments (2)

hs_err_pid88.log (19.6 KB) - added by Batchheizer 9 years ago.
StreamtasticProblems.gif (26.7 KB) - added by Batchheizer 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by Batchheizer

Attachment: hs_err_pid88.log added

Changed 9 years ago by Batchheizer

Attachment: StreamtasticProblems.gif added

comment:1 Changed 9 years ago by dmik

The installer works in UNI mode now with the current Java/Odin? SVN (probably related to problems fixed within #48). Did you try it with UNI or SMP?

The game itself doesn't work but it doesn't crash either -- simply does not do anything. My guess is that it can't initialize audio or something like that. It does work with Java 1.5 here.

comment:2 Changed 9 years ago by dmik

Here is what I get

Exception occurred during event dispatching:
java.awt.image.ImagingOpException: Unable to convolve src image
	at java.awt.image.ConvolveOp.filter(ConvolveOp.java:197)
	at org.jvnet.substance.utils.SubstanceTextUtilities.paintTextWithDropShadow(SubstanceTextUtilities.java:97)
	at org.jvnet.substance.utils.SubstanceTitlePane.paintComponent(SubstanceTitlePane.java:1182)
	at javax.swing.JComponent.paint(JComponent.java:1029)
	at javax.swing.JComponent.paintChildren(JComponent.java:866)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:581)
	at javax.swing.JComponent.paintChildren(JComponent.java:866)
	at javax.swing.JComponent.paint(JComponent.java:1038)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5138)
	at javax.swing.BufferStrategyPaintManager.paint(BufferStrategyPaintManager.java:302)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1145)
	at javax.swing.JComponent._paintImmediately(JComponent.java:5086)
	at javax.swing.JComponent.paintImmediately(JComponent.java:4896)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:740)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:696)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:676)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:57)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1550)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:194)
	at java.awt.Dialog$1.run(Dialog.java:1072)
	at java.awt.Dialog$3.run(Dialog.java:1126)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.Dialog.show(Dialog.java:1124)
	at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:871)
	at javax.swing.JOptionPane.showConfirmDialog(JOptionPane.java:797)
	at javax.swing.JOptionPane.showConfirmDialog(JOptionPane.java:759)
	at org.kuehntopf.streamtastic.StreamtasticApp.checkStreamripperAvailable(StreamtasticApp.java:74)
	at org.kuehntopf.streamtastic.StreamtasticApp.access$1(StreamtasticApp.java:62)
	at org.kuehntopf.streamtastic.StreamtasticApp$2.run(StreamtasticApp.java:205)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:226)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:602)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)

comment:3 Changed 9 years ago by Batchheizer

I have no ACPI (so no UNI or SMP?)

Streamtastic is no game (make no sound or so, AFAIK). It is a frontend for streamripper.

I did not use the installer - I used the ZIP.

comment:4 Changed 9 years ago by dmik

Hmm, sorry, the "game" part of the comment clearly relates to #53 instead of this one. I must have mixed the browser tab.

Though the exception is definitely from streamtastic. And it's again java.awt.image.ImagingOpException?, in addition to #58 and #66. Definitely a candidate for the GA.

Another strange thing is that I can't reproduce this exception any longer: it asks me for a streamripper executable and doesn't let me go further. I really wonder how I could get the above call stack trace...

Anyway, I can't debug further since I can't find the streamripper executable: both the froloff site and os2site.com are down now. Please upload it to my ftp (ftp.dmik.org/incoming) or give a working link to it.

comment:5 Changed 9 years ago by Batchheizer

Uploaded file to your ftp.

comment:6 Changed 9 years ago by dmik

Resolution: fixed
Status: newclosed

Although the executable you uploaded is too old so that the latest version of the application complains about it and doesn't go beyond this error message window, I believe the problem has gone away after closing #58.

Feel free to reopen this once you have got a new Java released and still see this exception.

Note: See TracTickets for help on using tickets.