Opened 9 years ago

Closed 9 years ago

#47 closed defect (fixed)

Jeti/2 app crashes during startup

Reported by: yoda Owned by:
Priority: critical Milestone: RC
Component: general Version: 1.6.0-b19 Beta 2
Severity: Keywords:
Cc: yoda

Description

Jeti/2 (a Jabber app) works fine here with Java 1.41 or 1.42 - even 1.3 claims to be possible.

Trying to start Jeti/2 using java6 with following cmd file:


Set LIBPATHSTRICT=T
SET CLASSPATH=H:\java6a\jre\lib\rt.jar

SET PATH=H:\java6a\jre\bin;H:\Programs\Seamonkey2;%PATH%
Set BeginLibPath?=H:\java6a\jre\bin;H:\Programs\Seamonkey2;
SET USER_HOME=H:\Java1\Jeti2\download

H:\java6a\jre\bin\java.exe -jar Jeti2.jar


result is:


file:/H:/Java1/Jeti2/
file:/H:/Java1/Jeti2/
loading default prefs
Crystal (Jabber)not found or no description
Crittersnot found or no description
JIMnot found or no description
Patrick's Facesnot found or no description
RhymBoxnot? found or no description
ShinyIconsnot? found or no description
Stellarnot found or no description
Tarynnot found or no description
Initialized
icenegotiater started
stun.xten.net
2
2
Initializing...Resolved
3
4
Ini.loadProperties: H:\Java1\Jeti2\Compiere.properties
#
# A fatal error has been detected by the Java Runtime Environment:
#
# Internal Error (d:/Coding/javaos2/openjdk/hotspot/src/share/vm/classfile/placeholders.hpp:226), pid=161, tid=10551300
# Error: Unimplemented()
#
# JRE version: 6.0
# Java VM: OpenJDK Client VM (16.0-b13 mixed mode os2-x86 )
# An error report file with more information is saved as:
# H:\Java1\Jeti2\hs_err_pid161.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#


It creates an error log - attached.

A few times, it created an entry in POPUPLOG.OS2 instead:


01-11-2011 18:06:26 SYS3175 PID 007e TID 0004 Slot 00b1
H:\JAVA6A\JRE\BIN\JAVA.EXE
c0000005
1c0f7227
P1=00000002 P2=21110400 P3=XXXXXXXX P4=XXXXXXXX
EAX=0326f158 EBX=0326f4b4 ECX=0326f460 EDX=0326f158
ESI=00000000 EDI=0326f158
DS=0053 DSACC=f0f3 DSLIM=ffffffff
ES=0053 ESACC=f0f3 ESLIM=ffffffff
FS=18b7 FSACC=00f3 FSLIM=00000fff
GS=0000 GSACC= GSLIM=
CS:EIP=005b:00000027 CSACC=f0df CSLIM=ffffffff
SS:ESP=0053:0326f444 SSACC=f0f3 SSLIM=ffffffff
EBP=0326f46c FLG=00010206

JVM.DLL 0001:000c7227


01-11-2011 18:36:04 SYS3170 PID 008a TID 0001 Slot 0092
H:\JAVA141GA\JRE\BIN\JAVAW.EXE
c0010002
1c444fa5
P1=00000003 P2=XXXXXXXX P3=XXXXXXXX P4=XXXXXXXX
EAX=00183d74 EBX=00000000 ECX=1504009c EDX=ffffffff
ESI=1504009c EDI=15040128
DS=0053 DSACC=f0f3 DSLIM=ffffffff
ES=0053 ESACC=f0f3 ESLIM=ffffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC= GSLIM=
CS:EIP=005b:1c785117 CSACC=f0df CSLIM=ffffffff
SS:ESP=0053:000bef2c SSACC=f0f3 SSLIM=ffffffff
EBP=000bef4c FLG=00010206


Attachments (2)

hs_err_pid161.log (19.3 KB) - added by yoda 9 years ago.
jetilog.zip (4.7 KB) - added by yoda 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by yoda

comment:1 Changed 9 years ago by dmik

  • Milestone changed from Beta 2 to GA

The problem is really strange. Even the installer crashes here immediately. The crash is somewhere in JVM.DLL as well. Unfortunately I can't debug it as it is somewhere in the JIT/interpreter code that uses various "dangerous" techniques like changing the code segment which often kills the debug info.

I will work on this after Beta 2.

comment:2 Changed 9 years ago by dmik

  • Version set to 1.6.0-b19 Beta

The applications from #49 demonstrate similar crashes in JVM.DLL.

Changed 9 years ago by yoda

comment:3 Changed 9 years ago by yoda

  • Cc yoda added
  • Version changed from 1.6.0-b19 Beta to 1.6.0-b19 Beta 2

I tested with new Beta 2 - same crash as before.
After reading about SMP problems, I turned 1 CPU OFF.
Now Jeti/2 actually starts and runs - but all windows
are missing half of what should be there. There was also
no sound at all (should have been several).

I'm attaching output to cmd window - a lot of java fails.

comment:4 Changed 9 years ago by dmik

What I see now is that at some point during Java method execution FS changes from the Win32 value to the OS/2 value. This expectedly breaks the exception chain and probably some other thread-related machinery. I have to find out who is doing that.

comment:5 Changed 9 years ago by dmik

The crash should be fixed in r246. Turned out that we were calling OS/2 APIs directly, bypassing their Odin wrappers that save/restore the FS register (in particular, in this case it was the Prf* calls in the getOs2FontPath() method).

Now, the Jeti/2 installer works smoothly.

Jeti/2 itself doesn't work though giving java.lang.ClassNotFoundException?: com.sun.image.codec.jpeg.JPEGImageDecoder. This class is missing indeed both in the OS/2 build (b13) and in my own Win32 I made from the original sources build but it's present in OpenJDK6 (b20) for Linux. I will investigate.

comment:6 Changed 9 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Created #60 for the JPEGImageDecoder problem. Closing this defect.

Note: See TracTickets for help on using tickets.