Opened 6 years ago

Last modified 6 years ago

#198 new task

Port OpenJDK 7

Reported by: Joop Owned by:
Priority: major Milestone: Enhanced
Component: general Version: 1.6.0 Build 27 GA4
Severity: high Keywords:
Cc:

Description

More and more programs are now only for Java 7 (1.7) and don't support Java 6 (1.6) anymore. Next GA should be version 7.

Change History (4)

comment:1 Changed 6 years ago by diver

  • Priority changed from blocker to Feedback Pending

this will probably not happen very soon. As when you look at the sponsoring we are way behind. If you want to sponsor a bigger amount we of course consider it sooner.

comment:2 Changed 6 years ago by Joop

Right, but I don't go to sponser programs which don't work, at the moment there is too much which don't work. And I did already put in a fair amount of money as a private user.

comment:3 Changed 6 years ago by diver

  • Type changed from defect to task

if all think like that, then we will see no new java at all. do you really think i can finance everything by my own? and if we get sponsors i get the money back? i'm sorry but it's not working like this. i will not go any deeper in that discussion, but if we will not get more sponsorship units a 1.7 and also fixes are far away. i'm sorry about that, but in the end i have to pay the developer.

regards
Silvan

comment:4 Changed 6 years ago by diver

  • Priority changed from Feedback Pending to major
  • Summary changed from Java version too old to Port OpenJDK 7
Note: See TracTickets for help on using tickets.