Opened 7 years ago

Closed 6 years ago

#191 closed enhancement (fixed)

New OpenJdk release

Reported by: mrt Owned by:
Priority: blocker Milestone: GA4
Component: general Version: 1.6.0 Build 25 GA3
Severity: high Keywords:
Cc:

Change History (12)

comment:2 Changed 6 years ago by diver

  • Milestone changed from Enhanced to GA4

comment:4 Changed 6 years ago by diver

  • Priority changed from minor to major
  • Severity changed from medium to high

comment:5 Changed 6 years ago by diver

  • Priority changed from major to blocker

comment:6 Changed 6 years ago by dmik

b27 changes have been merged in in r406. Will try building it now.

comment:7 Changed 6 years ago by dmik

hotspot is successfully built, the Java itself has failed at some strange place (build.tools.hasher.Hasher.main). Investigating.

comment:8 Changed 6 years ago by dmik

Found the reason of the build break. This was a really tricky regression of r 22024 in Odin. This is a real mess I'd say but in fact reading from the standard input when it is a redirected file was broken in Java since then.

The matter is that when the standard input is redirected, the call to GetNumberOfConsoleInputEvents? ends up in HMDeviceOpen32Class::_DeviceRequest() (instead of HMDeviceConsoleInClass::_DeviceRequest() as in case of the not redirected standard input). Before r 22024 HMDeviceOpen32Class::_DeviceRequest() would always erroneously return TRUE which satisfied the java code in io_util_md.c (handleStdinAvailable) just by accident. After I fixed the wrong return values in r 22024, it started to return FALSE as it should. However, in this case handleStdinAvailable() delegates its work to handleNonSeekAvailable which in turn calls PeekNamedPipe? which seems to fail somehow on redirected stdin (with "invalid function") and this in turn aborts FileInputStream::available with an I/O exception.

I have to check on how to properly solve that. (I reverted the change to make Java build further but we need to fix it in Odin anyway).

comment:9 Changed 6 years ago by dmik

I created http://svn.netlabs.org/odin32/ticket/90 for tracking the issue in Odin.

comment:10 Changed 6 years ago by dmik

Odin ticket 90 is done. The build now goes further (finally).

comment:11 Changed 6 years ago by dmik

Builds and seems to work. Doing further testing.

comment:12 Changed 6 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Can be closed.

Note: See TracTickets for help on using tickets.