Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#171 closed defect (fixed)

Problem in Java Photo Album version 9.6.1 with Openjdk1.6.0.b25GA3

Reported by: Anchieri Owned by:
Priority: major Milestone: Next
Component: general Version: 1.6.0 Build 25 GA3
Severity: medium Keywords:
Cc:

Description

I have installed the last version of your OpenJDK+libodin+glib2
but I received the attached thre error, please can you investigate this error?

Attachments (9)

hs_err_pid151.log (22.7 KB) - added by Anchieri 7 years ago.
hs_err_pid163.log (23.6 KB) - added by Anchieri 7 years ago.
hs_err_pid71.log (28.6 KB) - added by Anchieri 7 years ago.
hs_err_pid71A.log (28.1 KB) - added by Anchieri 7 years ago.
hs_err_pid77.log (23.7 KB) - added by Anchieri 7 years ago.
hs_err_pid86.log (19.8 KB) - added by Anchieri 7 years ago.
hs_err_pid71.2.log (26.3 KB) - added by Anchieri 7 years ago.
hs_err_pid72.log (23.4 KB) - added by Anchieri 7 years ago.
hs_err_pid99.log (1.7 KB) - added by Anchieri 7 years ago.

Download all attachments as: .zip

Change History (22)

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

comment:1 Changed 7 years ago by David McKenna

Did you REM out the SET CLASSPATH= and SET JAVA_H...= statements in CONFIG.SYS? If not, try it with those REM'ed.

comment:2 Changed 7 years ago by Anchieri

In config.sys now I have REM also CLASSPATH JAVA_HOME already REMeded in previous version (GA2).
And now I insert a new hs_err_pid71A.log and hs_err_pid77.log

Last edited 7 years ago by Anchieri (previous) (diff)

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

comment:3 Changed 7 years ago by dmik

Questions:

  1. When exactly do you get this error?
  2. Did you try the latest version 10.8? If not, please do.
  3. Does it work with OpenJDK GA2?

comment:4 Changed 7 years ago by dmik

Here jAlbum 10.8 seems to work (created a sample album). As well as 9.3.

comment:5 Changed 7 years ago by dmik

Ok, got it crash at startup here as well. Seems to be the same SEH regression as seen in #161. GA2 works.

comment:6 Changed 7 years ago by Anchieri

3) yes with version ga2 it work well, no error.
2) I try last version 10.8 but I obtain a error log hs_err_pid86.log during it installation.
1) In vary circumstance, not immediately, I can do something.
I download the zip file of 10.8 and installed it.
The program permit only few thing, if I want delete a folder of photos it stop after the last photo is canceled with an error log file.
If I restart it after a crash the program enter in a loop forcing me to reboot the system (using CAD) and many other case.
I insert some error.log file if can give you a Idea of what is it.

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

Changed 7 years ago by Anchieri

comment:7 Changed 7 years ago by dmik

  • Priority changed from blocker to major
  • Severity changed from high to medium

comment:8 Changed 7 years ago by dmik

Please try this DLL ftp://ftp.netlabs.org/pub/odin/test/j4.zip (replace the one in the /bin/client dir) and report if it works now. Here it works with this DLL.

comment:9 Changed 7 years ago by Anchieri

I have tested Jalbum 10.8 with this j4.zip, I can insert a new group of photo and update the album with it, but when I want to view other group of photo the Jalbum enter a memory loop ?
with the meter high and the system don't respond any more to keyboard or mouse (if I use CTRL+ESC or ALT+ESC I obtain a window messages giving me the opportunity to cancel the program that don't respond I ask to cancel the task but nothing succeed) forcing me to reboot.
After reboot I run jalbum and during it initialization, I obtain an hs_err_pid99.log that I attach.

Changed 7 years ago by Anchieri

comment:10 Changed 7 years ago by dmik

This is the same crash as in #133 (comment 31).

comment:11 Changed 7 years ago by Anchieri

I have installed your last file: hotfix_ga3_1-20120807.zip and retested jalbum 10.8
now seem function very well for me, thank you for your work.

comment:12 Changed 7 years ago by diver

  • Resolution set to fixed
  • Status changed from new to closed

hmm seems like we overlooked that the reporter said it works ok now.
so i close it.

comment:13 Changed 7 years ago by dmik

Great.

Note: See TracTickets for help on using tickets.