Opened 8 years ago

Closed 7 years ago

#141 closed defect (invalid)

java6 prevents open ssh connections

Reported by: oara27 Owned by:
Priority: major Milestone: Enhanced
Component: general Version: 1.6.0-b22 GA
Severity: medium Keywords: ssh, tight vnc
Cc: oara27

Description

ssh sessions (OpenSSH_5.3p1) just won't start with java6. No error messages. There is no problem with java 1.4.2_09. What connection is there between ssh and java, anyway?

Thank you,

Oscar Rondon

Change History (5)

comment:1 Changed 8 years ago by dmik

  • Priority changed from major to Feedback Pending

Could you be more specific please? Do you mean that ssh.exe doesn't want to connect to servers when a Java application is running under OpenJDK?

comment:2 Changed 8 years ago by oara27

Sorry for the delay in replying.

When the paths are set to make java6 the global java version, so the result of java -version points to java6, ssh.exe just won't start. No java apps are running at the time. This does not happen with 1.4.2_09 or earlier javas.

Update on 11/07/11: it may have been a problem with GENMAC's Realtek NIC driver. With eCS 2.1 Realtek Gigabit NIC driver the problem is gone, but the problem below persists.

Moreover, other java apps sort of run under Java6. Example:

TightVNC for JAVA (all versions up to 1.5.1) works but the clipboard window (open from menu on top left of main VNC desktop window frame) has a "hole", through which the PM desktop is seen. The clipboard contents are not accessible. This "hole" is absent in v. 1.4.2_09.

Thank you.

Last edited 8 years ago by oara27 (previous) (diff)

comment:3 Changed 8 years ago by wlhartzell

When I ran this application, I got missing Windows dll WTSAPI32.dll. I assume that is the reason this program won't work. I checked version 2.0.4.

comment:4 Changed 8 years ago by oara27

  • Cc oara27 added
  • Keywords tight vnc added
  • Priority changed from Feedback Pending to major
  • Severity changed from high to medium

comment:5 Changed 7 years ago by diver

  • Resolution set to invalid
  • Status changed from new to closed

as the ssl cause is fixed i close this ticket. if the TightVNC problem is still there with latest java/odin, feel free to open a new ticket.

Note: See TracTickets for help on using tickets.