Opened 3 years ago

Last modified 2 years ago

#134 new defect

Sweethome3D can't be installed

Reported by: Joop Owned by:
Priority: blocker Milestone: Enhanced
Component: general Version: 1.6.0-b22 GA
Severity: medium Keywords:
Cc:

Description

The Linux distribution does contain some kind of error somewhere in tgz distribution file which causes to unpack half and then exits with an error. There is also a jar file ( http://sourceforge.net/projects/sweethome3d/files/SweetHome3D-3.2.jar ). I tried to run it with different memory parameters. It could be that it needs much more memory than the 1G in my system. When I run the .jar I get lots of errors which are running of screen, so I can't provide you with a screenprint.

Change History (3)

comment:1 Changed 3 years ago by Joop

I had made a remark on the forum of SweetHome3D and I got today an answer. It seems that eCS-OS/2 JAVA is unable to do 3D and can do only 2D. Sounds silly to me. I tried the suggestion which is:

@echo off
set BEGINLIBPATH=i:\JAVA\JAVA160\bin
set path=i:\JAVA\JAVA160\bin
set CLASSPATH=
I:
cd I:\CAD\SweetHome3D
java -Dcom.eteks.sweethome3d.no3D=true -jar SweetHome3D-3.2.jar

With this command file SweetHome3D does start, you can load libraries, examples etc. Reversed the java line with the old one without the "-D" parameter and SweetHome3D does fail to start. I found in my popuplog.os2 this error:

07-09-2011 17:42:16 SYS3170 PID 0067 TID 0016 Slot 00a1
I:\JAVA\JAVA160\BIN\JAVA.EXE
1d90482c
00a55120
P1=00000000 P2=00000000 P3=04a8f90c P4=16f43632
EAX=00000008 EBX=233425c8 ECX=00000002 EDX=00000008
ESI=233da710 EDI=fffffff8
DS=0053 DSACC=f0f3 DSLIM=ffffffff
ES=0053 ESACC=f0f3 ESLIM=ffffffff
FS=1fef FSACC=00f3 FSLIM=00000fff
GS=0000 GSACC= GSLIM=
CS:EIP=005b:17135d52 CSACC=f0df CSLIM=ffffffff
SS:ESP=0053:04a8f8f4 SSACC=f0f3 SSLIM=ffffffff
EBP=04a8f91c FLG=00012202

ODINCRT.DLL

It seems or a problem in ODIN parts or I can not use 3D due to my Matrox video card incompatibilities.

comment:2 Changed 2 years ago by wlhartzell

Exception in thread "main" java.lang.reflect.InvocationTargetException?

at sun.reflect.NativeMethodAccessorImpl?.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl?.invoke(NativeMethodAccessorImpl?.java:57)
at sun.reflect.DelegatingMethodAccessorImpl?.invoke(DelegatingMethodAccessorImpl?.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at com.eteks.sweethome3d.SweetHome3DBootstrap.main(Unknown Source)

Caused by: java.lang.NoClassDefFoundError?: sun/awt/X11GraphicsDevice

at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:186)
at javax.media.j3d.NativeConfigTemplate3D$1.run(NativeConfigTemplate3D.java:79)
at java.security.AccessController?.doPrivileged(Native Method)
at javax.media.j3d.NativeConfigTemplate3D.createNativeConfigTemplate3D(NativeConfigTemplate3D.java:74)
at javax.media.j3d.NativePipeline?.initialize(NativePipeline?.java:127)
at javax.media.j3d.Pipeline.createPipeline(Pipeline.java:170)
at javax.media.j3d.MasterControl?.loadLibraries(MasterControl?.java:965)
at javax.media.j3d.VirtualUniverse?.<clinit>(VirtualUniverse?.java:299)
at javax.media.j3d.GraphicsConfigTemplate3D.getBestConfiguration(GraphicsConfigTemplate3D.java:321)
at java.awt.GraphicsDevice?.getBestConfiguration(GraphicsDevice?.java:175)
at com.eteks.sweethome3d.j3d.Component3DManager.<init>(Unknown Source)
at com.eteks.sweethome3d.j3d.Component3DManager.getInstance(Unknown Source)
at com.eteks.sweethome3d.SweetHome3D.addComponent3DRenderingErrorObserver(Unknown Source)
at com.eteks.sweethome3d.SweetHome3D.init(Unknown Source)
at com.eteks.sweethome3d.SweetHome3D.main(Unknown Source)
... 5 more

Caused by: java.lang.ClassNotFoundException?: Class sun.awt.X11GraphicsDevice

at com.eteks.sweethome3d.tools.ExtensionsClassLoader?.findClass(Unknown Source)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:321)
at com.eteks.sweethome3d.tools.ExtensionsClassLoader?.loadClass(Unknown Source)
at java.lang.ClassLoader?.loadClass(ClassLoader?.java:266)
... 21 more

It says that we are missing an X11 class implementation. This is with the supposedly all systems Jar file.

comment:3 Changed 2 years ago by dmik

Most likely, there is a usual case like if (windows) { load windows.jar; } else { load(x11.jar); } . This is easy to fix per se but makes no sense since we don't support 3D classes anyway ATM (and this is not going to happen soon).

Note: See TracTickets for help on using tickets.