Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#129 closed defect (fixed)

josm EXCEPTION_ACCESS_VIOLATION at startup

Reported by: fbakan Owned by:
Priority: major Milestone: GA2
Component: general Version: 1.6.0-b22 GA
Severity: medium Keywords:
Cc:

Description

josm (Java-OpenStreetMap?-Editor) (for example version 4064) crashes at startup.

log reports:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x1c025de0, pid=57, tid=3735556
#
# JRE version: 6.0-b22
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode os2-x86 )
# Problematic frame:
# C  [DOSCALL1+0x1005de0]
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

---------------  T H R E A D  ---------------

Current thread (0x2112cc00):  JavaThread "main" [_thread_in_native, id=3735556, stack(0x04f50000,0x05060000)]

siginfo: ExceptionCode=0xc0000005, writing address 0x00000000

Registers:
EAX=0x00000000, EBX=0x0504f93c, ECX=0x00000013, EDX=0x00000000
ESP=0x0504f820, EBP=0x0504f82c, ESI=0x00000000, EDI=0x00000000
EIP=0x1c025de0, EFLAGS=0x00012202

Register to memory mapping:

EAX=0x00000000
0x00000000 is pointing to unknown location

EBX=0x0504f93c
0x0504f93c is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x390004 runnable [0x0504f000]
   java.lang.Thread.State: RUNNABLE

ECX=0x00000013
0x00000013 is pointing to unknown location

EDX=0x00000000
0x00000000 is pointing to unknown location

ESP=0x0504f820
0x0504f820 is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x390004 runnable [0x0504f000]
   java.lang.Thread.State: RUNNABLE

EBP=0x0504f82c
0x0504f82c is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x390004 runnable [0x0504f000]
   java.lang.Thread.State: RUNNABLE

ESI=0x00000000
0x00000000 is pointing to unknown location

EDI=0x00000000
0x00000000 is pointing to unknown location


Top of Stack: (sp=0x0504f820)
0x0504f820:   00000000 00000000 00000000 00000000
0x0504f830:   00000000 00000000 00000000 00000000
0x0504f840:   00000000 00000000 00000000 00000000
0x0504f850:   00000000 00000000 00000000 00000000
0x0504f860:   00000000 00000000 00000000 00000000
0x0504f870:   00000000 00000000 00000000 00000000
0x0504f880:   00000000 00000000 00000000 00000000
0x0504f890:   00000000 00000000 00000000 00000000 

Instructions: (pc=0x1c025de0)
0x1c025dd0:   55 8b ec 8d 65 f8 51 83 7d 10 00 74 05 8b 45 0c
0x1c025de0:   8a 08 6a 00 8d 45 fc 50 ff 75 14 ff 75 10 ff 75 


Stack: [0x04f50000,0x05060000],  sp=0x0504f820,  free space=1022k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [DOSCALL1+0x1005de0]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  0x22149e15

Attachments (1)

hs_err_pid100.log (2.7 KB) - added by dmik 8 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 8 years ago by dmik

  • Milestone changed from Enhanced to GA2

Thanks for the report.

I got a similar issue today when committing in SmartSVN. Must be a recent regression, never saw this before.

comment:2 Changed 8 years ago by dmik

Here it crashes in DOSCALL1.DLL 0002:00005e38.

Changed 8 years ago by dmik

comment:3 Changed 8 years ago by dmik

Note that I tried to switch the GA build to MPUSAFE mode with the execmode tool but it still crashes when I commit (the commit itself succeeds, it seems to crash soon afterwards). This means that the problem is not SMP-related.

comment:4 Changed 8 years ago by fbakan

after downgrading odin to odin32bin-20110512-release josm works again.

comment:5 Changed 8 years ago by dmik

Clearly, a regression. Thanks for testing. I will look into the issue.

comment:6 Changed 8 years ago by dmik

Please try a test Odin version which you can find here: ftp://ftp.dmik.org/tmp/j/o129.wpi. I fixed there something different, not directly related to this problem but I simply can't reproduce the crashes any more. I really wonder if you can.

comment:7 Changed 8 years ago by fbakan

Tried the test version, but josm (4064) still crashes (Hardware: T23 (PIII).
(First start of josm after installing the odin-test-version
with existing .josm directory didn't crash, but 'hang' with josm
splash-screen (progress bar moving from left to right and back).
I then killed josm (Ctrl-C), deleted .josm and started josm again.
Now josm (tried versions 4064 and 4181) again crash constantly with:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x1c025de0, pid=84, tid=5505027
#
# JRE version: 6.0-b22
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode os2-x86 )
# Problematic frame:
# C  [DOSCALL1+0x1005de0]
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

---------------  T H R E A D  ---------------

Current thread (0x2112cc00):  JavaThread "main" [_thread_in_native, id=5505027, stack(0x04f30000,0x05040000)]

siginfo: ExceptionCode=0xc0000005, writing address 0x00000000

Registers:
EAX=0x00000000, EBX=0x0502f93c, ECX=0x00000013, EDX=0x00000000
ESP=0x0502f820, EBP=0x0502f82c, ESI=0x00000000, EDI=0x00000000
EIP=0x1c025de0, EFLAGS=0x00012202

Register to memory mapping:

EAX=0x00000000
0x00000000 is pointing to unknown location

EBX=0x0502f93c
0x0502f93c is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x540003 runnable [0x0502f000]
   java.lang.Thread.State: RUNNABLE

ECX=0x00000013
0x00000013 is pointing to unknown location

EDX=0x00000000
0x00000000 is pointing to unknown location

ESP=0x0502f820
0x0502f820 is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x540003 runnable [0x0502f000]
   java.lang.Thread.State: RUNNABLE

EBP=0x0502f82c
0x0502f82c is pointing into the stack for thread: 0x2112cc00
"main" prio=6 tid=0x2112cc00 nid=0x540003 runnable [0x0502f000]
   java.lang.Thread.State: RUNNABLE

ESI=0x00000000
0x00000000 is pointing to unknown location

EDI=0x00000000
0x00000000 is pointing to unknown location


Top of Stack: (sp=0x0502f820)
0x0502f820:   00000000 00000000 00000000 00000000
0x0502f830:   00000000 00000000 00000000 00000000
0x0502f840:   00000000 00000000 00000000 00000000
0x0502f850:   00000000 00000000 00000000 00000000
0x0502f860:   00000000 00000000 00000000 00000000
0x0502f870:   00000000 00000000 00000000 00000000
0x0502f880:   00000000 00000000 00000000 00000000
0x0502f890:   00000000 00000000 00000000 00000000 

Instructions: (pc=0x1c025de0)
0x1c025dd0:   55 8b ec 8d 65 f8 51 83 7d 10 00 74 05 8b 45 0c
0x1c025de0:   8a 08 6a 00 8d 45 fc 50 ff 75 14 ff 75 10 ff 75 


Stack: [0x04f30000,0x05040000],  sp=0x0502f820,  free space=1022k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [DOSCALL1+0x1005de0]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
j  0x22149e15

After reinstalling odin32bin-20110512-release.wpi josm (4181) starts up normally.

comment:8 Changed 8 years ago by dmik

Please do a couple more tests (single DLL drop-in replacements for o129.wpi):

  1. ftp://ftp.dmik.org/tmp/j/kernel32_1.zip
  2. ftp://ftp.dmik.org/tmp/j/kernel32_2.zip

comment:9 Changed 8 years ago by fbakan

I tried both dlls and both work well. josm starts up normally again.
This fixes the crash.
Thanks.

comment:10 Changed 8 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

Thank you for testing. The fix represented by the first DLL is committed in Odin r 21667. We were accidentally invalidating wrong memory mapped file's pages.

The second one was simply the build with Odin r 21655 rolled back (to prove that this change was the initial reason for the crash).

comment:11 Changed 8 years ago by dmik

I will release the new Odin build in a while. So far, the above hot fixes (o129.wpi + kernel32_1.zip) can be used.

Note: See TracTickets for help on using tickets.