Opened 4 years ago

Closed 2 years ago

#124 closed defect (fixed)

Error message from JAlbum 9.5

Reported by: Joop Owned by:
Priority: Feedback Pending Milestone:
Component: general Version: 1.6.0-b22 GA
Severity: highest Keywords:
Cc:

Description

I'm not sure if you can do something with it, but its a report from JAlbum 9.5.
I'm running eCS 1.2Dutch, available memory 1Gb. Enclosed the error file. It looks like its running okay, but at start all is upside down, starting something else will correct this. I'm not sure if this is with this Java version or with JAlbum, its since 9.4.1. So I'm more on the side of JAlbum for this, but the developer from JAbum says otherwise.

Attachments (2)

hs_err_pid75.log (1.9 KB) - added by Joop 4 years ago.
hs_err_pid126.log (20.8 KB) - added by Joop 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 4 years ago by Joop

comment:1 Changed 4 years ago by Joop

JAlbum is started with this command file;
@echo off
set BEGINLIBPATH=i:\JAVA\JAVA160\bin
set path=i:\JAVA\JAVA160\bin
set appdata=T:\plaatjes\MyAlbums?
I:
cd I:\DTP\JAlbum_95
java -Xmx400M -Dbrowser.arg=%@url% -Dbrowser.cmd=I:\firefox_401\Firefox!EL.exe -jar Jalbum.jar

Version of Java is in the log file.

comment:2 follow-up: Changed 4 years ago by dmik

  • Priority changed from major to Feedback Pending

This is not enough, can you say what build exactly do you use? The WSE one or the test one available at ftp://ftp.dmik.org/tmp/j/?

Also, a screen shot would not hurt, as well as steps to reproduce. I am not a magician (unfortunately) and can't read your mind. Thanks.

comment:3 in reply to: ↑ 2 Changed 4 years ago by Joop

Replying to dmik:

This is not enough, can you say what build exactly do you use? The WSE one or the test one available at ftp://ftp.dmik.org/tmp/j/?

Also, a screen shot would not hurt, as well as steps to reproduce. I am not a magician (unfortunately) and can't read your mind. Thanks.

The last, I will try and keep in mind, but sometimes I don't have that luck and end with what I can give you. First, the WSE, I'm not sure what I have to take from your j directory, there are three files. All tickets up to today are with WSE.

comment:4 Changed 3 years ago by Joop

Today tried with latest JAVA (1.6.0-b22 GA) and I thought I got the problem by including the CLASSPATH with nothing as parameter, in fact a space.
I use this cmd file;
@echo off
set BEGINLIBPATH=i:\JAVA\JAVA160\bin
set path=i:\JAVA\JAVA160\bin
set CLASSPATH=
set appdata=T:\plaatjes\MyAlbums?
I:
cd I:\DTP\JAlbum_95
java -Dbrowser.arg=%@url% -Dbrowser.cmd=I:\firefox_401\Firefox!EL.exe -Xmx400m -jar Jalbum.jar

The -D commands still not work, ie, normal FF is started but without page. Beyond that it worked, but this is the second time I get a error message with fatal followup, ie program not starting. I don't know if this is JAVA or JALBUM. Enclosed the error log file (hs_err_pid126.log).

In the command screen I could save this for you;
OpenJDK Client VM warning: Attempt to protect stack guard pages failed.
#
# A fatal error has been detected by the Java Runtime Environment:
#
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x16cfdb61, pid=126, tid=825756
5
#
# JRE version: 6.0-b22
# Java VM: OpenJDK Client VM (19.0-b09 mixed mode os2-x86 )
# Problematic frame:
# V [JVM+0x25db61]
#
# An error report file with more information is saved as:
# I:\DTP\JAlbum_95\hs_err_pid126.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

Above this kind of information;
for (int i=1; i<10; i++) System.out.println(i); Iterations
window.messageBox("You can interact with any Java object");

Below the error message just the prompt.

This is ALL I have, I hope you can do something with it.

Changed 3 years ago by Joop

comment:5 Changed 3 years ago by Joop

  • Version changed from 1.6.0-b22 WSE to 1.6.0-b22 GA

comment:6 Changed 2 years ago by dmik

  • Resolution set to fixed
  • Status changed from new to closed

AFAIR, this kind of crash (and the guard stack page warnings) was fixed in GA2. So seems to be irrelevant now.

Note: See TracTickets for help on using tickets.