Opened 13 years ago

Closed 13 years ago

#77 closed defect (fixed)

Closing Dialog after viewing file EA causes SYS3175

Reported by: mwizard (Mark Vollmer) Owned by: stevenhl
Priority: major Milestone: Release_3.5.9
Component: fm/2 base Version: 3.05
Keywords: VIEW EAs Cc:

Description

Selecting a file, VIEW -> INFO. Brings up a dialog box. Click the EAs button to display yet another dialog with the EA's for the file listed. Select the .TYPE and view the result in the dialog showing it's setting.

Click OK from that dialog, and the whole FM/2 app crashes with the SYS3175.

Follow up: If you rename the FM2.INI file, restart FM/2, this problem goes away.

Attachments (1)

tosteve.zip (75.3 KB) - added by guest 13 years ago.
zip of file with EA's included.

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by guest

zip of file with EA's included.

comment:1 Changed 13 years ago by gyoung

  • Milestone Release_3.05_beta8 deleted

comment:2 Changed 13 years ago by stevenhl

  • Milestone set to Release_3.05_beta8
  • Owner changed from StevenHL to stevenhl
  • Status changed from new to assigned

comment:3 Changed 13 years ago by gyoung

  • Milestone changed from Release_3.5.8 to Release_3.5.9

comment:4 Changed 13 years ago by stevenhl

  • Priority changed from minor to major
  • Reporter changed from guest to mwizard (Mark Vollmer)

comment:5 Changed 13 years ago by stevenhl

Appears to be triggered when fSwitchTreeOnFocus is enabled

The relevant code is

dircnrs.c:1269
      if (fSwitchTreeOnFocus && hwndTree && dcd && *dcd->directory)
	!WinSendMsg(hwndTree, UM_SHOWME, MPFROMP(dcd->directory), MPVOID);

treecnr.c:512

  case UM_SHOWME

comment:6 Changed 13 years ago by stevenhl

  • Resolution set to fixed
  • Status changed from assigned to closed

Caused by FileInfoProc/IconProc? race. Corrected at svn revision 576.

Note: See TracTickets for help on using tickets.