Opened 13 years ago

Closed 12 years ago

#24 closed defect (fixed)

Repeated hangs with FM2 requiring reboot

Reported by: htravis Owned by: StevenHL
Priority: critical Milestone: Release_3.7
Component: fm/2 base Version: 3.07
Keywords: hang Cc:

Description

FM/2 (V3.04 pre7) choked repeatedly on accessing a 600 file 600 gig directory, causing the WPS and system to be unresponsive. Repeatedly, requiring reboots, when CAD handler /TOP could not kill FM/2 or restore the desktop. No Filestar was able to read the same directory. Solution was to copy all files elsewhere, erase the directory and copy the files back.

A JFS problem with broken files? Is there a trace or log I can start to keep?

htravis@…

I have seen some similar freeze here. JSF Volume but much smaller 110 GB.

rbri

Actually, now that Harry has corrected his numbers, your volume is larger. Fm/2 has known issues with very large numbers of files. Basically it runs out of memory. I would prefer to fail gracefully, but I have not been able to recreate the failure here.

Fm/2 contains code that should fail gracefully, but it's clearly not 100%.

What needs to be done is for some of the users that can recreate this failure on demand to work with me to capture some diagnostic data.

Steven

I now am seeing a slightly different hang using the beta 6. It seems to happen when I serially open several files from an archive I am viewing. For example I open the ACPI archive then view the ACPI.doc close it then view ACPISMP.doc close it then try to view any other of the doc files the archive (unzip) window opens and will hang with the window title reading closing unzip. I can't get to CADPOP but if I hit CAD multiple times the machine reboots. Just before the reboot WPS & FM2 unfreeze and start to complete the operation. Unfortunately, this is very intermittent and I haven't been able to create a test case. There is no popup log entry. Thanks

Gregg

I saw this again this morning only this time it occurred when I opened an archive containing one small file. It opened but the system immediately became non responsive. Same result as above. The archive file work fine after the reboot.

I have also noticed that it occurs while I am scrolling with a wheel mouse using the amouse driver. I remember that at one point I was able to scroll off the end of the internal viewer because of the specific call that amouse makes for scrolling. Is it possible this hang is related. Again this is not reproducible but occurs occasionally.

Gregg

Change History (8)

comment:1 Changed 13 years ago by gyoung

I am leaving this open since a better solution may be found. This was addressed by change dossleep(0) to dossleep(1) in common.c

comment:2 Changed 13 years ago by stevenhl

  • Milestone set to Release_3.05_beta8

comment:3 Changed 13 years ago by stevenhl

  • Reporter changed from gyoung to htravis

comment:4 Changed 13 years ago by gyoung

  • Milestone changed from Release_3.5.8 to Release_3.5.9

comment:5 Changed 13 years ago by stevenhl

  • Keywords hang added
  • Summary changed from Repeated freezes with FM2 requiring reboot to Repeated hangs with FM2 requiring reboot
  • Version set to 3.05

comment:6 Changed 13 years ago by gyoung

  • Milestone Release_3.5.9 deleted
  • Version 3.05 deleted

comment:7 Changed 12 years ago by gyoung

  • Milestone set to Release_3.7
  • Version set to 3.07

comment:8 Changed 12 years ago by gyoung

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.