Opened 13 years ago

Closed 13 years ago

#143 closed defect (fixed)

Processing of certain archiver signatures with hex bytes is broken.

Reported by: John Small Owned by:
Priority: minor Milestone: Release_3.7
Component: fm/2 base Version: 3.07
Keywords: Cc:

Description

The "Edit an archiver" details dialog appears to have a bug when dealing with certain signatures which are defined with hex notation (i.e. \x..). The problem is that extraneous \xff bytes are inserted into the signature EVERY time the ARCHIVER.BB2 file is rewritten.

It appears that the common feature of the signatures affected by this bug is that the second byte of the signature is defined in hex.

Attachments (1)

ARCHIVER.BB2 (25.0 KB) - added by John Small 13 years ago.
Archiver.BB2 with "broken" signatures

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by John Small

Attachment: ARCHIVER.BB2 added

Archiver.BB2 with "broken" signatures

comment:1 Changed 13 years ago by Gregg Young

Milestone: Release_3.7
Version: 3.063.07

comment:2 Changed 13 years ago by Gregg Young

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.