Opened 12 years ago

Closed 12 years ago

#125 closed defect (fixed)

SYS3175 when accessing subdirectory of removable USB drive (camera)

Reported by: gyoung Owned by: gyoung
Priority: critical Milestone: Release_3.7
Component: fm/2 base Version: 3.07
Keywords: Cc:

Description

PMCTLS.DLL is the newest. I can alway reproduce this so getting a trap dump is no problem. The usb drive can be accessed without problem from the drives folder.

Attachments (1)

SHLNotes.txt (5.2 KB) - added by gyoung 12 years ago.
trap dump analysis

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by gyoung

trap dump analysis

comment:1 Changed 12 years ago by gyoung

06-19-2007 17:24:03 SYS3175 PID 0055 TID 0001 Slot 00b8 F:\FM2.TEST\FM3.EXE c0000005 1b67c110 P1=00000001 P2=00000100 P3=XXXXXXXX P4=XXXXXXXX EAX=00000100 EBX=1c7826a0 ECX=80000308 EDX=13e8af20 ESI=00440030 EDI=1d8c474a DS=0053 DSACC=f0f3 DSLIM=ffffffff ES=0053 ESACC=f0f3 ESLIM=ffffffff FS=150b FSACC=00f3 FSLIM=00000030 GS=0000 GSACC= GSLIM= CS:EIP=005b:1b67c110 CSACC=f0df CSLIM=ffffffff SS:ESP=0053:000befec SSACC=f0f3 SSLIM=ffffffff EBP=000beff0 FLG=00012206

PMCTLS.DLL 0002:000bc110

comment:2 Changed 12 years ago by gyoung

The trap is occuring when TreeCnrWndProc? calls the original message handler to process a CN_QUERYRECORD mesasge.

I have to suspect that there's memory corruption of some sort occuring when the container is built.

The k command does not decode TreeCnrWndProc? as the active function because the delta is too large. When this happens you either need to use the map file or look at the stack. In this case the map file is easier.

comment:3 Changed 12 years ago by gyoung

Note the trap dump is from a VAC build the trap screen is from an open watcom build.

comment:4 Changed 12 years ago by gyoung

Remove from known issues when fixed

comment:5 Changed 12 years ago by gyoung

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.