Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#80 closed defect (invalid)

Pressing F1 on dialogs kills eFTE PM

Reported by: mrwarper Owned by:
Priority: minor Milestone: Release_1.1
Component: eFTEPM Version: Release_1.0
Keywords: Cc: mrwarper, abwillis

Description

Many operations to get user input are done via status line in VIO eFTE2 but little PM dialogs are brought up for these things in the PM version:

File Open (or Load Desktop, etc.) or File Save (as, write to, etc.), Set Dir, Rename file, Confirm deleting file, Line transform, Find/FindReplace?, Create Folds at RegExp?, Confirm compile command line, grep, Left/Right? Margin, TabSize?, Print to, About dialog (and maybe some I overlooked).

If I press F1 on any of the dialogs above, eFTE2 PM traps here, whereas VIO eFTE2 just ignores it (I don't know if it's supposed to bring up help).

Also, Help -> Contents does nothing, while VIO eFTE2 correctly opens eFTE2.HLP with newview.

eFTE path included in path, help and dpath via SET in an OS/2 prompt prior to running. Plain vanilla MCP2 system +XWP, no eStyler, FoC enhancers or the like.

I don't know if what gets in popuplog.os2 is useful or just garbage, I am attaching it just in case:
(First line sure keeps changing, but only SS:ESP and EBP lines do change after that)

`------------------------------------------------------
10-08-2017 12:47:28 SYS3175 PID 0151 TID 0001 Slot 00b1
D:\UTIL\EFTE\EFTEPM.EXE
c0000005
1df21bb0
P1=00000001 P2=1df21bb0 P3=XXXXXXXX P4=XXXXXXXX
EAX=1c77fffe EBX=1c772a84 ECX=00000000 EDX=1df21bb0
ESI=00000000 EDI=1c77cb3c
DS=0053 DSACC=f0f3 DSLIM=ffffffff
ES=0053 ESACC=f0f3 ESLIM=ffffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC= GSLIM=
SS:ESP=0053:0053ea94 SSACC=f0f3 SSLIM=ffffffff
EBP=0053eb18 FLG=00012246


Change History (12)

comment:1 Changed 2 years ago by mrwarper

  • Cc mrwarper added

comment:2 Changed 2 years ago by abwillis

I am running a build I built myself from (current) SVN. I am unable to reproduce issue here. F1 works in the program as expected and is ignored on File Open, File SaveAS, find, create fold regexp and about that I have tested.
I am using ArcaOS, full XWP, Styler2, FOC, dragtext, and possibly some I have forgotten.
I do not know when Gregg is expecting to have a new release out but it may already be resolved.

comment:3 follow-up: Changed 2 years ago by abwillis

  • Cc abwillis added

comment:4 in reply to: ↑ 3 Changed 2 years ago by mrwarper

Replying to abwillis:
I am waiting for Gregg to give me access to the SVN, so all of my reports refer to the only eFTE2 release at hobbes.

comment:5 Changed 2 years ago by gyoung

Alfredo you can get the code see below. I have given you trac admin privileges (you can edit the wiki and such) I will contact Adrian to get you commit privileges (username mrwarper). I am also sending you a build from the latest code (some uncommitted). I don't see this trap either F1 just does nothing.

Create efte repository directory and change directory to it.
Pull code, svn co http://svn.netlabs.org/repos/efte/trunk .
Use OpenWatcom?? to build efte.
wmake -f makefile or just wmake

comment:6 Changed 2 years ago by mrwarper

I am connection-challenged, so we'll have to see how that works out. Still a step forward, though :)

BTW, the build you sent me still dies when I press F1 on the secondary dialogs. Whatever it is, it has apparently been there forever - FTEPM/2006 dies too. Either my system does something that was never taken into account, or it does something wrong that I need to fix.

comment:7 Changed 2 years ago by mrwarper

I can't believe my connection stayed up for more than 20min without restarts when I needed -- got the source!! We're gonna rock the place down!

(Just kidding -- you can imagine how frustrating that kind of thing is. Now let's see if I can upload changes -- or if I remember how to read code first ;p)

comment:8 Changed 2 years ago by mrwarper

  • Resolution set to invalid
  • Status changed from new to closed

Nope, it's not eFTE2 but something in my system. Sorry for the hassle, but it's been ages since I actually used F1 to get some help and not just for testing -- other programs die the same way, a couple (PM123 and PMView) even manage to launch an empty NewView window and vanish. From the title at least NewView tries to load the right file but something fails.

Time to close this ticket I guess. I'll try to find out if it's NewView or my setup, and if relevant I'll open a new ticket at the NewView Trac :(

comment:9 Changed 2 years ago by gyoung

Are you using one of the REXX plugins in XCenter?

comment:10 Changed 2 years ago by mrwarper

Yup, I have one REXX gauge I never actually use, so it's usually not on display, but it's in there nonetheless.

Edit: I was to add this, but I've been 8 hours w/o connection...

Removed the REXX gauge, rebooted so the DLL wouldn't remain in memory -- tried again, and same problems with F1 :(

Last edited 2 years ago by mrwarper (previous) (diff)

comment:11 Changed 2 years ago by mrwarper

One last comment for completeness' sake: additionally closing the XCenter and renaming the DLLs as per our discussion via email works -- with my xCenter REXX gauge radically removed like that, F1 is ignored in PM eFTE2 secondary dialogs, and PM123 and PMView load their help OK.

comment:12 Changed 2 years ago by mrwarper

Nope, _this_ is the last round-up comment in case anyone finds this: Gregg fixed this like 10 years ago, and somehow I got an older copy of the xcenter widgets to be installed and interfere in my system.

His good version of the REXX xcenter widgets can be found at

http://hobbes.nmsu.edu/h-viewer.php?dir=/pub/os2/apps/wps/xworkplace&file=xwpwidgets-0-7-3.wpi&backto=%2Fh-browse.php%3Fdir%3D%2Fpub%2Fos2%2Fapps%2Fwps%2Fxworkplace

Note: See TracTickets for help on using tickets.