wiki:gutenprt

eCUPS printer driver

I've used the IBM postscript driver source as a basis, and fixed a couple of bugs in it that prevented OS/2 applications from being able to change CUPS printer settings.

Additionally, I've preloaded around 680 PPD files from Gutenprint 5.2.3 and Splix v1.1.1 into the driver so that most users won't need to go through the process of importing PPD files into the driver.

Download link: http://download.smedley.info/ecups-driver-20090324.zip

Also available is a build which includes the PPDs from HP-LIP instead. Download link: http://download.smedley.info/ecups-hp-driver-20100304.zip

Known issues:

  • Lucide and odin apps are unable to change some printer settings due to issues with pscript.drv's (on which gutenprt.drv is based) inability to inject the relevant postscript code when passed raw postscript code.
Last modified 4 years ago Last modified on Jan 9, 2011, 12:31:34 PM