Opened 6 years ago

Closed 3 years ago

#12 closed enhancement (fixed)

Ignore USB disks/sticks on boot

Reported by: erdmann Owned by: Ben Rietbroek
Priority: major Milestone:
Component: Boot Manager Version: 1.0
Keywords: Cc:

Description

I have a WD book permanently attached to the PC via USB.
The problem is that AIRBOOT will get confused after selection of the partition to boot, apparently attempting to boot from the WD book (which only contains a data partition but no bootable partition).
It would be nice if AIRBOOT would have the feature to ignore any USB mass media.

Change History (6)

comment:1 Changed 6 years ago by erdmann

Forgot to mention:
1) my hard drive (first drive: 0x80) has these partitions in this order: primary partition (for Windows 7), logical partition (for eCS productive), logical partition (for eCS MUT/development)
2) my WD book (second drive: 0x81) has a primary partition (formatted with JFS)

I am mentioning this as I have the feeling that this has a bearing on what partition Airboot chooses to boot (I guess the primary partition on the second drive "disturbes" the "sequence of partitions")

comment:2 Changed 6 years ago by Ben Rietbroek

Owner: set to Ben Rietbroek
Status: newaccepted
Version: 1.0

comment:3 in reply to:  description Changed 6 years ago by Ben Rietbroek

Replying to erdmann:

I have a WD book permanently attached to the PC via USB.
The problem is that AIRBOOT will get confused after selection of the partition to boot, apparently attempting to boot from the WD book (which only contains a data partition but no bootable partition).
It would be nice if AIRBOOT would have the feature to ignore any USB mass media.


Hi Lars,
Do you have a little bit more info?
Does it happen with all bootable partitions on the boot-disk or specific ones?
Does AB display a name it is trying to boot?
This is the part just before starting the system, where the animation dots appear.

I will send you a Rexx Script that uses DFSVOS2 to gather some info.
Please run it from eCS with the WD attached and mail me back the resulting output file.
(Or attach it here)

I can also send you a debug-build so we can track what happens.

comment:4 in reply to:  1 Changed 6 years ago by Ben Rietbroek

Replying to erdmann:

Forgot to mention:
1) my hard drive (first drive: 0x80) has these partitions in this order: primary partition (for Windows 7), logical partition (for eCS productive), logical partition (for eCS MUT/development)
2) my WD book (second drive: 0x81) has a primary partition (formatted with JFS)

I am mentioning this as I have the feeling that this has a bearing on what partition Airboot chooses to boot (I guess the primary partition on the second drive "disturbes" the "sequence of partitions")


That's a sound analysis, but then it should also happen with non-USB disks.
I'm guessing it has to do with the BPB, but we'll see.

It would be nice if AIRBOOT would have the feature to ignore any USB mass media.

Yep, that will be in v1.1.2, after code cleanup.

comment:5 Changed 6 years ago by Allan

Actually, AB have always had problems, when USB sticks were inserted:
but I don't like the idea, that AB should ignore them - AB should of
course instead make it possible to boot all partitions on USB devices;
just as BIOS does.

comment:6 Changed 3 years ago by Ben Rietbroek

Resolution: fixed
Status: acceptedclosed

* This issue is assumed to be fixed *

There is a new release of AiR-BOOT which should fix this issue.
It can be downloaded here: https://github.com/rousseaux/netlabs.air-boot/releases

If this specific issue is *not* fixed, then please create a *new* ticket
here, http://trac.netlabs.org/air-boot/newticket, describe the problem you
are experiencing and insert a *reference* to this issue if you think it is
related.

Happy booting,

Ben.

Note: See TracTickets for help on using tickets.