Opened 7 years ago

Closed 7 years ago

#36 closed enhancement (worksforme)

Unable to play or burn audio tracks on SATA drive using AHCI 1.31

Reported by: jjw Owned by: David Azarewicz
Priority: minor Milestone: Future Version
Component: driver Version: 1.31
Keywords: Cc:

Description

No audio cd will play using any player.
Neither cdrecord nor RSJ Copy Wizard is able to burn audio tracks.

iso images of Video DVDs and data CDs and DVDs burn ok. Video DVDs play ok and data CDs and DVDs can be read. In all of these cases that work it takes an inordinate amount of time for the drive to become ready as reported in ticket #35.

I include a startup log as well as logs of attempts to play an audio track using both CDPM and RSJ CdView? and an attempt to burn an audio CD using cdrecord.

Attachments (1)

ahcilogs.zip (41.1 KB) - added by jjw 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by jjw

Attachment: ahcilogs.zip added

comment:1 Changed 7 years ago by David Azarewicz

Milestone: Future Version
Owner: set to David Azarewicz
Priority: majorminor
Status: newaccepted

comment:2 Changed 7 years ago by David Azarewicz

Type: defectenhancement

Actually, this is not really an OS2AHCI driver issue. You must use an ATAPI filter driver in order to read/write CD-DA (audio) format disks. For example, DANIATAP.FLT must be in your config.sys. No filter driver is needed for data format disks.

In order for the filter driver to work with OS2AHCI version 1.31 you must disable the SCSI emulation with the /!s switch. To make it more convenient, I'll make a slight change to OS2AHCI so the filter driver will be able to work with OS2AHCI without the /!s switch.

comment:3 Changed 7 years ago by David Azarewicz

OS2AHCI version 1.32 is released. Use that version with no switches and make sure you have DANIATAP.FLT in your config.sys.

comment:4 Changed 7 years ago by jjw

I saw a notice from Voice that version 1.32 had been released and downloaded the new version. At that time, I had not seen your comments 2 and 3 above.

I renamed the existing OS2AHCI.ADD on the desktop machine, copied the new version to f:\os2\boot, and rebooted the machine. I tried playing an audio CD using CDPM and it worked. Before reporting that the problem was solved, I thought I ought to try the other applications that didn't work.

PM123 played the disk ok; CDView showed the tracks but would not play; cdrecord burned an audio cd ok. CopyWizard? complained that the CD burner was in use by another process.

I also tried a DVD movie which worked fine and looked at a couple of data cds and dvds. The time for these to become ready is much improved - about 5 - 15 seconds.

I then tried playing an audio cd again with CDPM. This time the track buttons appeared but there was no sound. Moreover the highlighted track button jumped about at random; sometimes several buttons were highlighted at once.

When I went to add this information to this ticket, I discovered your comments.

First of all your statement in comment 2 that a filter driver is required to read an audio cd seems to contradict what you wrote to me last August when version 1.30 was released:

On Sat, 03 Aug 2013 15:48:01 -0700 James J. Weinkam wrote:

According to the readme:

OS2AHCI is an AHCI driver for eComStation. It supports both ATA and
ATAPI devices in a single driver, thus there's no need for an
ATAPI/CDROM filter driver.

Yes, this is correct.

Accordingly, after copying os2ahci.add to d:\os2\boot, I remmed daniatap.flt. aspinkk.sys
would not load and the dvd drive was not accessible. I tried again with the /s switch (frequently
the actual defaults differ from what is stated in the documentation) with the same result.

I unremmed daniatap.flt and everything seems to work fine.

Am I misunderstanding the readme, or is this a fault I should report?

No the readme is correct as is and there is no fault to report.

If you think about it, it makes sense that the AHCI driver can only affect drives that it operates. If
a drive is operated by another driver, say the Dani driver for example, then nothing in the AHCI
driver has any effect on it. Your CD is probably not controlled by the AHCI driver.

As it turned out your analysis was correct. At the time, my sata cd/dvd burner was connected to an IDE port using a sata to ide converter and was operated by DANIS506.ADD. Since then, I have replaced the motherboard and processor and the new motherboard has only sata ports. The setup is configured to use AHCI mode.

Nevertheless, I went back to square one and followed your recommendation. For good measure I tried it both with no switches at all and with /!s. I also tried with the /s switch with and without daniatap.flt. I experimented with every combination I could think of for a couple of days and finally stumbled upon the reason CDPM wouldn't play. Something I ran after the original successful play turned off digital transfer. I can't imagine what caused this and have not been able to reproduce it. In fact, I can't turn off digital transfer even if I want to; an attempt to do so causes CDPM to terminate with the following popuplog entry:

11-12-2013 22:30:17 SYS3175 PID 0063 TID 0001 Slot 00a8
F:\MMOS2\MMPLAYER\CDPM.EXE
c0000005
1da6f672
P1=00000001 P2=00000000 P3=XXXXXXXX P4=XXXXXXXX
EAX=0003d070 EBX=00000000 ECX=0003d0c0 EDX=1da6f602
ESI=003ba6a0 EDI=00000000
DS=0053 DSACC=d0f3 DSLIM=5fffffff
ES=0053 ESACC=d0f3 ESLIM=5fffffff
FS=150b FSACC=00f3 FSLIM=00000030
GS=0000 GSACC= GSLIM=
CS:EIP=005b:1da6f672 CSACC=d0df CSLIM=5fffffff
SS:ESP=0053:0003d070 SSACC=d0f3 SSLIM=5fffffff
EBP=0003d0c8 FLG=00010212

ECSPRTS.DLL 0001:000ef672

It's been a long time since I have had a CD drive with analog output so I have to turn on digital transfer after every fresh install. The install I am using dates back to last May and CDs have played fine all summer. At any rate here is the current state of affairs using the 1.32 driver:

application -- /!s daniatap.flt loaded --------------- /s daniatap.flt rammed out

aspinkk.sys --- can't get SCSIMGR$ entry point -- loads ok

CDPM -------- works -------------------------------- works

PM123 -------- works ------------------------------- works

cdrecord ------- can't open aspinkk$ --------------- works

--------- can't open aspirou$

cdda2wav ----- can't open aspinkk$ --------------- works, index scan very slow

---------- can't open aspirou$ --------------- copy speed very good

CDView ------- Displays tracks, won't play ------ Displays tracks, won't play

CopyWizard?:

rip ------------- works ------------------------------- works

burn ----------- CD Recorder device not found ---- CD Recorder device not found

--------- or used by another application ----- or used by another application

comment:5 Changed 7 years ago by David Azarewicz

Resolution: worksforme
Status: acceptedclosed

I'm glad you got it working.

Note: See TracTickets for help on using tickets.