Opened 7 years ago

Closed 7 years ago

#560 closed defect (Unrelated)

interrupt clash UHCB versus e1000e

Reported by: landb Owned by: dazarewicz
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.21.02
Keywords: Cc: landb

Description

System T61; ECS2.1; up to date ACPI and USB drivers (185 + fixes)

I find that when I am using WIFI (driver e1000e) at the same time the system locks up. I even get a message about improper eject from the USB manager tool when nothing was done to eject the USB but something was happening on the TCPIP front.

rmview /irq shows a shared interrupt which seems suspicious. I have attached the output.

I tried both 3.21.02 and 3.20.03

Attachments (1)

irq (1.7 KB) - added by landb 7 years ago.

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by landb

comment:1 Changed 7 years ago by landb

  • Cc landb added

comment:2 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

I don't understand what this has to do with ACPI. Perhaps you could provide more information.

The E1000E driver is not a wifi driver. It is the wired ethernet driver. You are probably using a genmac driver for your wifi.

There is nothing suspicious about shared interrupts. That is perfectly normal.

From the brief description you provided, your symptoms are similar to the problems caused by the eCenter USB widget. I would suspect that before I suspected anything else. Try removing the USB widget from the eCenter and see if your problems go away.

comment:3 Changed 7 years ago by landb

OK. I will try that.

comment:4 Changed 7 years ago by landb

removing the Xcentre USB widget does seem to cure the problem. Sorry about that.

comment:5 Changed 7 years ago by dazarewicz

  • Resolution set to Unrelated
  • Status changed from new to closed

No problem. I'm glad you found the problem. That USB widget is so buggy that I remove it first thing on all my systems and put back the "Removable Device Monitor" into my startup folder.

If you find you still have problems that might be related to ACPI, feel free to re-open this ticket or open another one.

Note: See TracTickets for help on using tickets.