Opened 8 years ago

Closed 7 years ago

#540 closed defect (fixed)

Trap2 loading ACPI.PSD

Reported by: yoda Owned by: dazarewicz
Priority: critical Milestone: Release 4.00
Component: ACPI PSD Version: 3.20.04
Keywords: Cc:

Description

Notebook Acer TravelMate? 4672LMI i945 chipset 2GB RAM. While previous ACPI driver up to around 3.19.10 were able to boot this notebook, the latest drivers Traps during load of ACPI.PSD

Here is Trap info:

Slot Pid Ppid Csid Ord Sta Pri pTSD pPTDA pTCB Disp SG Name

*0001# 0001 0000 0000 0001 run 0200 ffde0000 ffde1898 ffde1594 0f36 00 OS2BOOT eax=00009b95 ebx=ffde1594 ecx=ffde1898 edx=ffdbc747 esi=ffde1600 edi=fe7ed80c eip=00007d74 esp=0000c000 ebp=00007ffa iopl=0 -- -- -- nv up di pl nz na po nc cs=2a48 ss=1530 ds=0160 es=0160 fs=0000 gs=0000 cr2=00000000 cr3=00211000 p=00 2a48:00007d74 e90e03 jmp 8085 # Loading version data ... please wait Loading structure info for WSeB/ACP SMP ... please wait. ....Structure definition file (warp45_s\kernel.sdf) loaded. ....Structure definition file (warp45_s\shell.sdf) loaded. Done. #

TRAP SCREEN INFORMATION

OS/2 Kernel Revision 14.104a_SMP Exception in module:

TRAP 0002 ERRCD=0001 ERACC= ERLIM= CPU=01

EAX=0000000b EBX=f96b0db1 ECX=00200282 EDX=00005fb9 ESI=00000000 EDI=fd380000 EBP=ffe88fd4 FLG=00200282 CS:EIP=0168:f96b58c5 CSACC=c09b CSLIM=ffffffff SS:ESP=1520:ffe88f94 SSACC=c097 SSLIM=ff7fffff DS=0160 DSACC=c0f3 DSLIM=ffffffff CR0=8001001b ES=0160 ESACC=c0f3 ESLIM=ffffffff CR2=ffd02000 FS=0108 FSACC=0093 FSLIM=000085bf GS=0000 GSACC= GSLIM= %f96b586d ACPI PrintInterruptState? + 58 Syspem dump (2GB) available on request.

Serial log attached.

Attachments (1)

ACER120405-1447.LOG (24.3 KB) - added by yoda 8 years ago.

Download all attachments as: .zip

Change History (20)

Changed 8 years ago by yoda

comment:1 Changed 7 years ago by yoda

Same TRAP 2 with version 3.20.02

IBM OS/2 Dump Formatter for a retail or an hstrict SMP kernel. Formatter is --> Internal revision 14.100g_SMP Dump file is --> Internal revision 14.104a_SMP (system dump) Symbol (d:\os2\pdpsi\pmdf\warp45_s\os2krnlr.sym) linked Symbol (d:\os2\pdpsi\pmdf\warp45_s\acpi.sym) linked Current slot number: 0001

Slot Pid Ppid Csid Ord Sta Pri pTSD pPTDA pTCB Disp SG Name

*0001# 0001 0000 0000 0001 run 0200 ffde0000 ffde1898 ffde1594 0f36 00 OS2BOOT eax=00009b95 ebx=ffde1594 ecx=ffde1898 edx=ffdbc747 esi=ffde1600 edi=fe7ed80c eip=00007d74 esp=0000c000 ebp=00007ffa iopl=0 -- -- -- nv up di pl nz na po nc cs=2a48 ss=1530 ds=0160 es=0160 fs=0000 gs=0000 cr2=00000000 cr3=00211000 p=00 2a48:00007d74 e90e03 jmp 8085 # Loading version data ... please wait Loading structure info for WSeB/ACP SMP ... please wait. ....Structure definition file (warp45_s\kernel.sdf) loaded. ....Structure definition file (warp45_s\shell.sdf) loaded. Done. #

TRAP SCREEN INFORMATION

OS/2 Kernel Revision 14.104a_SMP Exception in module:

TRAP 0002 ERRCD=0001 ERACC= ERLIM= CPU=01

EAX=00000080 EBX=f96d06f3 ECX=f9c12a9c EDX=000000b2 ESI=00000000 EDI=fbc00000 EBP=ffcfff50 FLG=00200297 CS:EIP=0168:f96d4b6f CSACC=c09b CSLIM=ffffffff SS:ESP=1520:ffcfff50 SSACC=c097 SSLIM=ff7fffff DS=0160 DSACC=c0f3 DSLIM=ffffffff CR0=8001003b ES=0160 ESACC=c0f3 ESLIM=ffffffff CR2=ffe8d000 FS=0108 FSACC=0093 FSLIM=000085bf GS=0000 GSACC= GSLIM= %f96d4b53 ACPI AcpiOsWritePort? + 1c #

As always, the DUMPFILE is available on request.

comment:2 Changed 7 years ago by yoda

  • Version changed from 3.20.01 to 3.20.02

comment:3 Changed 7 years ago by yoda

  • Version changed from 3.20.02 to 3.20.03

Tested version 3.20.03 Trap 2 again.

Since nobody seems to care, there is no reason to spend any time for further info.

comment:4 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

What size does the trap dump zip up to? Do you have a place I can download it from?

comment:5 Changed 7 years ago by yoda

  • Milestone changed from Feedback pending to Release Version 4.0.0

Tested version 3.20.04 - Trap 2 again

Yes, I can put it on my FTP - will be back when it is zipped and sent to FTP.

comment:6 Changed 7 years ago by yoda

  • Version changed from 3.20.03 to 3.20.04

187.993K Available here:

ftp://ftp.warpspeed.dk/pdumps/Trap2-01.zip

If there is anything else I can provide, just tell....

comment:7 Changed 7 years ago by dazarewicz

  • Milestone changed from Release Version 4.0.0 to Feedback pending

Thanks, I got the dump file.

I have a couple of questions.

  1. I need to know what version of OS2LDR you are using. The easiest way to tell is by the MD5 checksum of the oS2LDR file. Please provide the MD5 checksum of your OS2LDR file.
  1. Does the system boot with the retail PSD?

comment:8 Changed 7 years ago by yoda

1:

ABA04BEA4AC9E4D04910D7A82E6DE333 *OS2LDR

This should be a basic eCS 2.1 GA partition, although kernel 104a is installed.

2: It is the retail PSD, that was used for this dump.

Tests with earlier drivers gave the same trap - no matter what switches was used on both retail and debug versions.

comment:9 Changed 7 years ago by yoda

I changed to debug PSD and tried again - Trap 2

Dump file is here:

ftp://ftp.warpspeed.dk/pdumps/Trap2-02.zip

in case it helps

comment:10 Changed 7 years ago by dazarewicz

I have determined that the trap 2 appears to be an actual fault generated by the hardware. The type of fault is probably an I/O parity error or I/O timeout. It is still unknown whether or not this fault is legitimate. The chipset does have the ability to generate this type of interrupt, so it is possible. Since this is the only time I have ever seen this type of error, I wonder if there is some type of error detection or error reporting enabled in your BIOS that is not normally enabled.

If it cannot be disabled in the BIOS, I have another idea of how to track it down.

comment:11 Changed 7 years ago by yoda

I don't recall there is any kind of error checking possibilities to enable in BIOS. I'll check; when I can reboot.

I have however never seen a Trap 2 before on this (or any other PC) before, and it does run SMP here everyday - with one of Pasha's drivers (as PCIWRITE is needed to avoid other problems).

comment:12 Changed 7 years ago by dazarewicz

This is a long shot, but try this.

Please add /TEST=1028 to the PSD= line: PSD=ACPI.PSD /TEST=1028 Start from completely powered off and then boot the system. Please let me know if the trap 2 still occurs. This test is only valid for version 3.20.04. It doesn't matter retail or debug PSD.

comment:13 Changed 7 years ago by yoda

Good shot :-)

Both cold and warm boot works fine now - no trap @ init time.

The system completely resets at desktop startup. this is most likely due to another problem already known in another ticket - although it used to trap at this point too. (Ticket #19 and #233)

comment:14 Changed 7 years ago by yoda

Forgot to say:

I looked through BIOS; no settings for error checks. The only things that can be changed besides passwords are a few setting for paralel, serial and irda.

comment:15 Changed 7 years ago by dazarewicz

  • Milestone changed from Feedback pending to Release Version 4.0.0

The trap 2 was being caused by an adapter generating system errors. Masking the errors allows the system to continue without getting the trap 2. It is unknown whether or not the adapter is really malfunctioning.

In the rare cases when the BIOS fails to properly setup the PCI configuration, this indicates a fault either in the BIOS, or the adapter in question, or both. When this occurs, it is probably unwise to enable the system error interrupt as is normal since this is an abnormal situation and something in the system has obviously failed.

In version 3.20.05 of the PSD, when the BIOS fails to properly setup the PCI configuration, the PSD will no longer enable the system error interrupt for the adapter configuration it fixes. This will allow a possibly malfunctioning adapter to fail separately, rather than taking down the whole system.

This change to the PCI configuration fixup logic in the PSD only has an effect in abnormal situations where the BIOS fails to do its job and will not affect properly functioning systems.

comment:16 Changed 7 years ago by yoda

I wonder if this is the Wlan adapter; which still isn't correctly configured, when ACPI driver is used. See ticket #19 for this problem.

comment:17 Changed 7 years ago by dazarewicz

The problematic adapter is 8086:4222 at 3:0:0 "PRO/Wireless 3945ABG [Golan] Network Connection". Apparently this adapter is not working correctly. That, in addition to the questionable BIOS, and the known faulty ACPI, means that this system does not meet the minimum requirements for support by this PSD. Therefore, this system is officially not supported.

If you want, you may keep one ticket open regarding this system to consolidate and document any progress that you may make. Whichever ticket you choose, I will monitor it and I am willing to try to help on a time permitting basis.

comment:18 Changed 7 years ago by yoda

Ticket #19 already represents that specific Wlan adapter problem, so I guess we just continue there with that problem.

On the short test of 05 testbuild, I noticed problems with embedded controller. I'm seeing unreliable results for battery and Temp. Ex Temp switches between 0-61-164 or something like that. This was seen in some of Pashas builds too - but the l8r ones worked OK.

comment:19 Changed 7 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.