Opened 7 years ago

Closed 7 years ago

#513 closed defect (fixed)

Peripherals don't work on Compaq laptop

Reported by: dazarewicz Owned by: dazarewicz
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.19
Keywords: Cc:

Description

ACPI 3.19 built from SVN 351 sources.

System boots. Screen, keyboard, touchpad, and disk work, but nothing else. LAN, USB, Audio, etc. don't work.

Logs are attached.

Attachments (3)

AZARLAP-20110611.zip (45.4 KB) - added by dazarewicz 7 years ago.
AZARLAP-20110614-acpi-3.19.zip (39.6 KB) - added by dazarewicz 7 years ago.
pci-acpi-nod.log (15.7 KB) - added by dazarewicz 7 years ago.

Download all attachments as: .zip

Change History (13)

Changed 7 years ago by dazarewicz

comment:1 Changed 7 years ago by pasha

  • Owner changed from eco to pasha

comment:2 Changed 7 years ago by pasha

  1. What is in "rmview /IRQ"
  1. What is in \ibmcom\lantran.log ?

comment:3 Changed 7 years ago by ecsnl

Output of PCI.EXE with the proper switches might be more useful.

Starting with eCS 2.0 GA we generate the file: Contains a wealth of information \var\log\1_HWINFO.LOG

But that is of course without ACPI installed...

comment:4 Changed 7 years ago by pasha

Output from PCI.EXE I see in attached .zip. I need see rmview /IRQ

comment:5 Changed 7 years ago by ecsnl

Looking at it the ouput the defect might not be in shared IRQ's.

I loaded gfc pci-noacpi.log pci-acpi.log from David his ZIP file:

Check line 101 of the USB controller: None ACPI boot: Status 02B0h (Has Capabilities List, Supports 66MHz,

ACPI boot: Status 02B8h (Signalled Interrupt, Has Capabilities List, Supports 66MHz,

Check line 120 of the USB controller:

Device 4375h IXP SB400 USB Host Controller

None ACPI boot: Status 02B0h (Has Capabilities List, Supports 66MHz,

ACPI boot: Status 02B8h (Signalled Interrupt, Has Capabilities List, Supports 66MHz,

Down at line 350 and 357 of the Realtek driver:

none acpi boot: Revision 10h, Header Type 00h, Bus Latency Timer 40h

ACPI boot: Revision 10h, Header Type 00h, Bus Latency Timer 80h

none acpi boot: Address 1 is a Memory Address (0-4GiB) : D0202000h..D02020FFh

ACPI boot: Address 1 is a Memory Address (0-4GiB) : D0202000h

We see it with more devices on David his laptop that memory address on none ACPI boot has an end. Like with the Realtek card. But with ACPI booted the address range does not end.

Seems much more likely the output of PCI seems the error is there then shared IRQ problem. At least the output of PCI.EXE looks interesting to give more attention to that.

The question is are the other value's we see correct ?

Last edited 7 years ago by ecsnl (previous) (diff)

Changed 7 years ago by dazarewicz

comment:6 Changed 7 years ago by ecsnl

David just for more information. When APCI is loaded it patches (in memory) the OEMHLP$ service out that the os2krnl provides. That is also the reason that 2 people reported that ecomstation bug #2981 (note not in this bugtracker) was "resolved". They got a TRAP when screen01.sys was loaded. This is fixed by loading ACPI.

But 2 other people had a hang caused by ACPI.

Pasha would know the details but we write to PCI config space. Also where would these value's we see in PCI.EXE output come from.

comment:7 Changed 7 years ago by dazarewicz

Interesting. I tried the /!NOD switch and now it works. I attached the PCI output for this case. It seems that the ACPI OEMHLP$ changes the interrupt mode of USB controllers.

Changed 7 years ago by dazarewicz

comment:8 Changed 7 years ago by diver

this seems similar to what i have/had with ticket:501

comment:9 Changed 7 years ago by pasha

  • Owner changed from pasha to dazarewicz

comment:10 Changed 7 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.