Opened 10 years ago

Closed 7 years ago

#408 closed task (worksforme)

nmake fails to report compiler errors when building on JFS volume

Reported by: stevenhl Owned by: stevenhl
Priority: major Milestone: Feedback pending
Component: Build system Version: 3.14
Keywords: Cc:

Description

Pasha reports that nmake sometimes fails to report compile errors when building on a jfs volume

A typical report looks like

Entering directory: .\src\acpi\intel Entering directory: .\src\acpi\psd

icc /O3 /Os- /Op- /Ms /Rn /C /Ss /Sp8 /W3 /Gi+ /Gf+ /Gs+ /Fa+ /G5 /qtune=pentium /qarch=pentium /DMJVER=3 /DMNVER=14 /DACPI_DEBUG /D_ACPI_DEBUG /DACPI_FULL_DEBUG /FoD:\work\ddk\base32\src\acpi\obj\acpi\psd\nonintel.obj /FaD:\work\ddk\base32\src\acpi\obj\acpi\psd\nonintel.lst nonintel.c

nonintel.c(39:1) : error EDC0046: Syntax error.

D:\work\ddk\base32\src\acpi\createpath.cmd D:\work\ddk\base32\src\acpi\bin\os2 ilink /nofree /map /nod /exepack @D:\work\ddk\base32\src\acpi\obj\acpi\psd\acpi.lnk

IBM(R) Linker for OS/2(R), Version 03.06.PPK1010917.011116ilink

To correct response would be to stop after the syntax error.

Change History (3)

comment:1 Changed 10 years ago by stevenhl

  • Component changed from ACPI.PSD to Build system
  • Status changed from new to assigned

comment:2 Changed 7 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

Is this still an issue? I don't have any problems with the build system and reporting errors and I build on a JFS file system.

comment:3 Changed 7 years ago by dazarewicz

  • Resolution set to worksforme
  • Status changed from assigned to closed

No response from reporter. I cannot reproduce this problem on my build system.

Note: See TracTickets for help on using tickets.