Opened 11 years ago

Closed 7 years ago

#353 closed defect (Unsupported Version)

SMP APIC, Compaq Presario C700

Reported by: dpshea2415 Owned by:
Priority: major Milestone: Release version 3.19
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

Tested my notebook with SMP. Boots fine with ACPI.psd AND NO SWITCHES (SEE FIRST LOGS) BOOTS FINE WITH /pic /SMP (2nd logs) but workplace shell freezes if use /apic /smp and also /apic /smp /cd.

sleep works and resume wakes up laptop but screen stays off.

it is intel chipset dual core processor.

Attachments (8)

acpi-log-Model-of-your-PC- ACPI.PSD.ziq (221.8 KB) - added by dpshea2415 11 years ago.
acpi-log-Model-of-your-PC PIC SMP.ziq (222.6 KB) - added by dpshea2415 11 years ago.
acpi-log-Model-of-your-PC NO SWITCHES.ziq (100.7 KB) - added by dpshea2415 11 years ago.
with new build no switches
acpi-log-Model-of-your-PC SMP PIC.ziq (101.1 KB) - added by dpshea2415 11 years ago.
with new build smp pic switches only
acpi-log-Model-of-your-PC SMP APIC.ziq (101.4 KB) - added by dpshea2415 11 years ago.
with new build smp apic switches only
screen.jpg (85.6 KB) - added by dpshea2415 11 years ago.
screen with ac power unplugged
acpi-log-Model-of-your-PC - SMP.ziq (120.4 KB) - added by dpshea2415 11 years ago.
acpi-log-Model-of-your-PC.ziq (206.3 KB) - added by dpshea2415 10 years ago.

Download all attachments as: .zip

Change History (41)

Changed 11 years ago by dpshea2415

Changed 11 years ago by dpshea2415

comment:1 Changed 11 years ago by eco

e-co:

seems it's core duo notebook: http://h10010.www1.hp.com/wwpc/ru/ru/ho/WF06a/321957-321957-3329742-89318-89318-3466274.html

Pasha:

This is "illegal pci access" problem (pci standard, align, Rudi)

There are two computers with similar symptoms.

Special build for you is planned for 20090115

RUS:

это уши руедигера вощим пока так и не решено че делать с тем что противоречит уставу pci завтра ченидь сделаю и залью на тестинг то есть раз уже попался второй, буду ченидь изобретить

руедигер сказал что устав pci гласит чтоб было выровнено и ткунл носом в доку скорее illegal pci access найду в архиве acpi версии 1.xx, выдеру оттуда то что там было, поставлю дополнительно к руедигеровскому чем ему не понравилось то что было я не знаю

comment:2 Changed 11 years ago by pasha

Please download experimental ACPI

build from

Mensys site:

  • Experimental build for you:

acpi14012009.zip

  • Read instructions:

http://ecomstation.ru/projects/acpitools/?action=testcase

Independent from result, need attach log

comment:3 Changed 11 years ago by dpshea2415

I tried the test case build but the boot process stops on trying to load pmshell.exe and hence the wps does not load - therefore i cannot include any logs.

I tried it with /SMP /PIC and /APIC switches but no difference.

During the boot process there are two error messages about PCI read and write - if needed I can provide the exact error message.

comment:4 Changed 11 years ago by eco

e-co:

Pasha: wait a bit.. it's necessary try other special build

e-co:

in N hours or days

comment:5 Changed 11 years ago by eco

e-co:

Pasha compiled new build, please try:

ACPI14012009-1.ZIP

Changed 11 years ago by dpshea2415

with new build no switches

Changed 11 years ago by dpshea2415

with new build smp pic switches only

Changed 11 years ago by dpshea2415

with new build smp apic switches only

comment:6 Changed 11 years ago by dpshea2415

Laptop froze when i was adding the above comments on the new test build. I have attached new set of logs - with new build APIC now works with /SMP /APIC switches. Laptop appears stable so far expect for one freeze using firefox.

suspend works with S3 mode but when resumes laptop screen stays blank and does not come back therefore needing reboot. i will test with other settings in acpid.cfg.

comment:7 Changed 11 years ago by dpshea2415

Further testing in both APIC and PIC mode with this build suggests not so stable. Frequent freezes in WPS. Maybe linked to acpideamon as one freeze occurred when I unplugged AC power cable to run on battery.

comment:8 Changed 11 years ago by dpshea2415

I think i may have solved the problem of instability with /SMP /APIC /CD switches. I rem'd out acpidaemon.exe from config.sys and am not running it at all. It seems this may be causing the freezes. Is it okay to run without acpidaemon?

comment:9 Changed 11 years ago by eco

e-co:

try load acpidaemon.exe from startup.cmd, not config.sys

comment:10 Changed 11 years ago by dpshea2415

I tried loading acpidaemon.exe from a command prompt but when i unplugged the AC power cable the WPS froze. If I do not load acpidaemon at all, the system runs very stable with ACPI.psd /SMP /APIC switches.

It appears there is a problem with acpidaemon or APM mode? This is not a problem for me as suspend does not work as yet.

thank you for good work so far

comment:11 Changed 11 years ago by pasha

Need:

  • open full screen os/2 session
  • unplug power cable
  • check for freeze
  • attach photo of screen

comment:12 Changed 11 years ago by ecsnl

I read this:

"I tried the test case build but the boot process stops on trying to load pmshell.exe and hence the wps does not load - therefore i cannot include any logs."

Do you mean by this you press ALT F2 to see the device drivers load and then you see C:\OS2\ACPIDEAMON.EXE and C:\OS2\PMSHELL.EXE then the machine freezes ?

and you write:

"I tried loading acpidaemon.exe from a command prompt but when i unplugged the AC power cable the WPS froze. If I do not load acpidaemon at all, the system runs very stable with ACPI.psd /SMP /APIC switches."

Do you have any space left on your hard disc for a partition ? Second how much RAM do you have in your machine ? It would be very interesting to see if you can create memory dump.

The reason for this is because your ticket seems to have a lot in common with ticket 320 and ticket 344.

comment:13 Changed 11 years ago by ecsnl

Create a memory dump without /APIC that is and /SMP and then run ACPIdeamon.exe.

comment:14 Changed 11 years ago by pasha

memory dump don't need in this case. Need photo of screen

comment:15 Changed 11 years ago by dpshea2415

Pasha - I tried what you asked - no need for photo i copied the details as below:

AcpiOsSleep? 21ms Check _IRQ AcpiWaitOBF Ctl=2B OBF=0 EC arm "_Q38" N:6 Cur:6 ======Ex

ecsnl - thanks for your suggestions i dont know how to create memory dump but will follow pasha's lead for the moment. To answer your other questions yes i did alt f2 to see drivers load and only got it to boot by removing acpideamon from config.sys and NOT running it at all.

Changed 11 years ago by dpshea2415

screen with ac power unplugged

comment:16 Changed 11 years ago by eco

e-co:

Please try ACPI 3.09, 3.13

Pasha: the problem may be related to Intel ACPI-CA. wait for updates or downgrade.

comment:17 Changed 11 years ago by dpshea2415

With ACPi 3.14 - version that comes with RC6a - I can run successfully in APIC mode by using the /SMP /SPIC /CD switch.

No probelm with acpidaemon when plug or unplug the ac plug

comment:18 Changed 11 years ago by eco

e-co:

Hmm, repeat please what is the result?

special build of ACPI 3.14+ works for your notebook. with acpidaemon?

or ACPI 3.14 works too? with acpidaemon?

Let's write the results. If the problem is fixed then it's necessary close the ticket.

comment:19 Changed 11 years ago by eco

e-co:

correct me if I wrong,

Ticket #353, the fix is included to SVN revision: 166 or 167

Pasha,

Again, we don't have notes what is the problem? how it was fixed?

comment:20 Changed 11 years ago by dpshea2415

ACPI 3.14 that comes with ECs RC6a now works in APIC mode using switches /smp /apic /cd whereas before it froze when loading wps - see earlier post. The testcase 3.14+ boots okay but freezes when load acpidaemon and remove ac power cord. This does not happen with 3.14 version.

Only remaining problem is resume does not work and thermal.exe only shows proper temperature on boot but not while laptop has been running.

comment:21 Changed 11 years ago by pasha

comport log with remove ac power cord?

comment:22 Changed 11 years ago by dpshea2415

Not sure what you want me to do. Using release 3.14 there is no problem with acpidaemon using /smp /apci /cd switches. But if i use 3.14+ cannot use acpidaemon as it causes system to freeze especially if unplug or plug back in the ac power cord. I cannot capture a log as systems freezes.

comment:23 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:24 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

Changed 11 years ago by dpshea2415

comment:25 Changed 11 years ago by dpshea2415

tested new build acpi-apci-bat.zip. laptop now does not boot with /SMP /APIC or /SMP / APIC /CD switches. Only boots with /SMP switch. When plugin ac power cable laptop still freezes. attached log

comment:26 Changed 11 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.15

comment:27 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI315PRE.ZIP

Changed 10 years ago by dpshea2415

comment:28 Changed 10 years ago by dpshea2415

tested acpi315pre.zip - boots and runs okay with /SMP switch. Boots okay with /SMP /APIC switch however then freezes when use synaptics mouse that is built into laptop. i fixed this by disabling synpatics mouse and used an external usb mouse instead. it booted okay running from battery - i then plugged in the ac power cord computer did not freeze - however when i then unplugged the ac power cord the laptop froze.

i have attached the logs running it in /smp /apic mode.

comment:29 Changed 10 years ago by pasha

if you are use amouse.sys driver, check for device=....\amouse.sys SMP

comment:30 Changed 10 years ago by dpshea2415

thanks - i added SMP to amouse.sys statement in config.sys and this fixed the problem with the mouse. However the only remaining problem is the laptop (wps) freezes when i plug in the ac power cord.

comment:31 Changed 10 years ago by dpshea2415

I tried ACPIPRE2 version and this has fixed my problem of the ac power cord freezing the computer. I can now boot in /SMP /APIC mode and everything works okay and i can plugin ac power cord and unplug it again and no more freezes. Only remaining issues are suspend/resume does not work - ie no resume and laptop runs a bit hot using smp kernel - when run uni kernel is a lot cooler.

comment:32 Changed 10 years ago by pasha

  • Owner pasha deleted

comment:33 Changed 7 years ago by dazarewicz

  • Resolution set to Unsupported Version
  • Status changed from new to closed

This ticket is really old and not really relevant to the current software. If you still have problems with the current version, please open a new ticket.

Note: See TracTickets for help on using tickets.