Opened 9 years ago

Closed 6 years ago

#351 closed defect (unknown)

IBM ZPRO ACPI Hang and No Shutdown

Reported by: mkgreene Owned by:
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.15
Keywords: Cc:

Description

Running 3.14 using /APIC /SMP system sometimes hangs after WPS starts and even if it does not hang network card does not work. Using /PIC /SMP system boots and runs.

Using /APIC or /PIC system will not shutdown (power off). This did work with 3.09 I believe.

Logs attached.

MikeG

Attachments (4)

acpi-log-Model-of-your-PC.ziq (67.7 KB) - added by mkgreene 9 years ago.
acpi-log-apic-singlecpu.ziq (67.7 KB) - added by mkgreene 9 years ago.
IBM6221_PIC_SMP.ziq (79.1 KB) - added by mkgreene 9 years ago.
with SMP and PIC mode
IBM6221_APIC_NOSMP.ziq (78.6 KB) - added by mkgreene 9 years ago.
APIC mode single CPU

Download all attachments as: .zip

Change History (27)

Changed 9 years ago by mkgreene

comment:1 Changed 9 years ago by mkgreene

comment:2 Changed 9 years ago by pasha

Log when using /APIC ?

comment:3 Changed 9 years ago by mkgreene

This log is APIC without SMP. When I put /APIC back in config.sys with /SMP, I get a system trap during boot.

Changed 9 years ago by mkgreene

comment:4 Changed 9 years ago by pasha

For use /APIC with /SMP you need to remap IRQ48

comment:5 Changed 9 years ago by eco

e-co:

RUS: [Pasha]: ну я пока в этом тикете ничего не вижу

No more advices..

1) acpi.log -> 3:1.0 14E4:16A7 'PCI1' IRQs: PCI:11 PIC:'LNKC':11 APIC:48 MSI

the device is going use reserved IRQ 48 in SMP APIC. It necessary remap

2) e-co: How do you start acpidaemon? try without it, try start it from startup.cmd

comment:6 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:7 Changed 9 years ago by eco

e-co:

MikeG continues:

"I can disable all USB and it boots. Do you mean with /ACPI option and no USB? "

e-co:

I recommend disable USB Legacy in BIOS Setup, try boot /SMP /APIC.

comment:8 Changed 9 years ago by mkgreene

I will try what you suggested. I am not concerned with the /APIC switch operation, but I would like the poweroff option to work again on this system.

comment:9 Changed 9 years ago by mkgreene

I turned off USB and added /APIC switch. System traps before WPS starts.

comment:10 Changed 9 years ago by pasha

You have 92 IRQ in your MB. IBM kernel support 32 IRQ only. So you need remap:

3:1.0 14E4:16A7 'PCI1' IRQs: PCI:11 PIC:'LNKC':11 APIC:48 MSI - broadcom network card

But you have problem with remap, because have:

0:31.1 8086:24CB 'ICHX' IRQs: PCI:0 PIC:'LNKC':11 APIC:18 - EIDE controller

So, you can't use IRQ11 for remap. try IRQ13 . Also, you can insert your netcard to another slot. It be change IRQ for broadcom and do possible easy for remap.

comment:11 Changed 9 years ago by mkgreene

I will try to remap to IRQ13. The network card is built in to the motherboard.

comment:12 Changed 9 years ago by mkgreene

I tried remap REMAP 48 to 13 which still resulted in a trap. I have reverted back to ACPI 3.09 which will only run PIC, but will power off system. Also, the system is more responsive (faster) than 3.14.

I recommend closing this ticket because I intend to stay with ACPI 3.09.

comment:13 Changed 9 years ago by pasha

3.14 don't boot with psd=acpi.psd /SMP /PIC? Where is stopping/trapped?

comment:14 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.15
  • Resolution set to unknown
  • Status changed from new to closed

comment:15 Changed 9 years ago by mkgreene

No! System boots with 3.14 using /SMP /PIC but it will not poweroff. Using 3.09 the system powers off and runs a bit faster.

comment:16 Changed 9 years ago by pasha

You probe ACPI29012009.ZIP with PowerOff?.exe and it don't work?

comment:17 Changed 9 years ago by mkgreene

Pasha,

I did not know about ACPI29012009.ZIP but I did just try it. No good, as soon as I type poweroff the system hangs. Version 3.09 seems to work with /PIC and powers the system off. I just installed eCS RC6 on a IBM XSeries 335 and every thing works fine - except ACPI. Again, if I use v3.09 that system works with /PIC. The XSeries 335 is a few years old but in is a main stream IBM server - WTF?

MikeG

comment:18 Changed 9 years ago by stevenhl

  • Resolution unknown deleted
  • Status changed from closed to reopened

comment:19 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending
  • Owner pasha deleted
  • Status changed from reopened to new

Mike,

Please review

http://svn.netlabs.org/acpi/wiki/TicketProcessingGuide

and

http://cz.ecomstation.ru/projects/acpitools/?action=logs

It is unreasonable to expect issues to be resolved unless you supply Pasha with the data he needs. This means new logs when you test a new builds and proper handling of the ticket fields. If you leave the ticket closed, Pasha is supposed to ignore it. He's plenty busy working on the open tickets for the 3.15 milestone. Since you have a hang, you might need to work with a debug build or a system dump to capture the data Pasha needs. I not sure which will provide better test data.

Also, it should be obvious, but regressions are never an intended work product. However, Intel continues to make significant changes to the ACPICA sources that provide a lot of the acpi.psd functionality. Most times, these changes resolve open issues, but regressions can and will happen.

comment:20 Changed 9 years ago by mkgreene

  • Version changed from 3.14 to 3.15

I tried acpipre2.zip from betazone. As a note I have the patched B57.OS2 driver installed.

When I boot with the /APIC and /SMP options the system traps early in the boot process. If I boot with /APIC and no SMP (single CPU) the system boots (logs IBM6221_APIC_NOSMP.ziq). Booting with only /SMP switch (PIC mode) works and power off from xworkplace also works (logs: IBM6221_PIC_SMP.ziq).

Changed 9 years ago by mkgreene

with SMP and PIC mode

Changed 9 years ago by mkgreene

APIC mode single CPU

comment:21 Changed 8 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.19

comment:22 Changed 6 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

This ticket is for an unsupported version. Have you tried the new 3.20.01 release?

comment:23 Changed 6 years ago by dazarewicz

  • Resolution set to unknown
  • Status changed from new to closed

Ticket closed due to no response from reporter.

Note: See TracTickets for help on using tickets.