Opened 11 years ago

Closed 8 years ago

#335 closed defect (Unsupported Version)

Sound loops with latest uniaud and SMP

Reported by: Hansi Owned by:
Priority: minor Milestone: Release version 3.19
Component: ACPI PSD Version: 3.14
Keywords: Cc:

Description

SMP works again with version 3.13. There was no booting with SMP possible with versions 3.09-3.11. But sound loops, that stop when the sound object is opened.

Motherboard: Asrock AM2NF3-VSTA Soundcard: C-Media -- CMI8738 eCS2.0rc5 All drivers (Uniaud, USB, Dani) latest version No legacy hardware exept PS/2 keyboard

Attachments (16)

smp-kernel-smp-apic.ziq (90.2 KB) - added by Hansi 11 years ago.
smp-kernel-without-smp-option.ziq (86.7 KB) - added by Hansi 11 years ago.
config.sys (6.9 KB) - added by Hansi 11 years ago.
uniaud16.txt (464 bytes) - added by Hansi 11 years ago.
uniaud32.txt (525 bytes) - added by Hansi 11 years ago.
alsa.log (45.1 KB) - added by Hansi 11 years ago.
uniaud16.2.txt (462 bytes) - added by Hansi 11 years ago.
uniaud32.2.txt (525 bytes) - added by Hansi 11 years ago.
acpi.log (14.9 KB) - added by Hansi 11 years ago.
acpi_smp_apic_tmr.log (16.8 KB) - added by Hansi 11 years ago.
alsa_smp_apic_tmr.log (16.9 KB) - added by Hansi 11 years ago.
tmrtest.exe (29.7 KB) - added by pasha 11 years ago.
tmrtest.zip (16.8 KB) - added by pasha 11 years ago.
IMG_1394.jpg (51.3 KB) - added by Hansi 10 years ago.
acpi.2.log (15.0 KB) - added by Hansi 10 years ago.
alsa.2.log (52.1 KB) - added by Hansi 10 years ago.

Download all attachments as: .zip

Change History (44)

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

comment:1 Changed 11 years ago by ecsnl

What is the build level of uniaud32.sys and uniaud16.sys. Run bldlevel.exe and post that information.

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

comment:2 Changed 11 years ago by Hansi

With 3.14: No boot possible. Needs /!NOD switch, but traps when the mouse is touched. Same with eCSrc6a.

comment:4 Changed 11 years ago by eco

e-co:

Pasha: RUS: в топку, вернее к родерику, тут надо или даунгрейтить или апгрейтить acpi ca

ENG: this may be related to Intel Acpi-ca. Works with 3.13, doesn't with 3.14 because 3.14 is based on different Intel source code.

comment:5 Changed 11 years ago by Hansi

  • Version changed from 3.13 to 3.14

rc6a works with switches /SMP /APIC /!NOD /CD with acpi 3.14 and uniaud from rc6a. Sound loops still there until I open the sound object (startup sound after startup). During drag and drop operations the drag sound loops again until the operation is finished.

comment:6 Changed 11 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:7 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:8 Changed 11 years ago by Hansi

Results with ACPI-APIC-BAT, official kernel and latest uniaud32 from January, 25th:

-No switches: OK -/SMP /APIC /!NOD /CD: Additional messages during boot, but stops during boot.

Other switches not tested yet.

BTW: Quite good results with OS/4 kernel, ACPI 3.14 and latest uniaud32 from January, 25th. Only intermittent sound loops.

comment:9 Changed 11 years ago by pasha

boot with psd=acpi.psd /SMP /APIC, after boot do copy alsahlp$ alsa.log and copy acpica$ acpi.log. both log attach here.

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

comment:10 Changed 11 years ago by Hansi

Done, booting was possible with /SMP /APIC. Sound loops are present. I have also attached actual build level information for uniaud 16 and 32.

comment:11 Changed 11 years ago by pasha

try boot with /SMP /APIC /TMR. If boot attach acpi.log here

comment:12 Changed 11 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.15

comment:13 Changed 11 years ago by eco

e-co:

ACPI docs contain some useful information:

  • SBLive, driver (0.81), SMP APIC you can boot but sound plays in loop. To stop the sound loop open the Sound window (Sound object).

Changed 11 years ago by Hansi

Changed 11 years ago by Hansi

comment:14 Changed 11 years ago by Hansi

Done, booting was possible, loops present.

@ eco: Yes the loops stop when I am opening the sound object, but occasionally are coming back. And there are sound loops during a drag and drop operation.

Changed 11 years ago by pasha

comment:15 Changed 11 years ago by pasha

try boot with /SMP /APIC /TMR and /SMP APIC. For each boot run attached exe and say, where comparing is wrong

comment:16 Changed 11 years ago by Hansi

Result with all switches:

SYS0191: C:\tmrtest.exe cannot be run in an OS/2 session.

Changed 11 years ago by pasha

comment:17 Changed 11 years ago by pasha

try get from .zip

comment:18 Changed 11 years ago by Hansi

Cannot open with archive viewer or kazip:

Archive: C:/TMRTEST.ZIP

End-of-central-directory signature not found. Either this file is not a zipfile, or it constitutes one disk of a multi-part archive. In the latter case the central directory and zipfile comment will be found on the last disk(s) of this archive.

unzip: cannot find zipfile directory in C:/TMRTEST.ZIP,

and cannot find C:/TMRTEST.ZIP.zip, period.

comment:19 Changed 11 years ago by Hansi

I got it working. First I have to follow the link and then downloading it instead of right clicking and "safe as".

Result:

/SMP /APIC: wrong

/SMP /APIC /TMR: correct

In both cases the loops are present.

comment:21 Changed 11 years ago by Hansi

Loops are gone, but unreliable boot with experimental build of ACPI. System stops during bootup, second attempt always works.

With older versions 3.13 and 3.14 the loops are still present.

comment:22 Changed 10 years ago by pasha

Where is stopping boot?

Changed 10 years ago by Hansi

Changed 10 years ago by Hansi

Changed 10 years ago by Hansi

comment:23 Changed 10 years ago by Hansi

I cannot reproduce the boot stop at the moment, but have found an older screenshot that I have taken five weeks ago.

But now the sound loops are back intermittent. That means sometimes I can boot without sound loops, sometimes with and sometimes only during drag and drop operations.

comment:24 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPIPRE3.ZIP

and download http://download.smedley.info/uniaud32-1.9.12.zip

comment:25 Changed 10 years ago by Hansi

No change. Sometimes sound loops with or without /TMR switch.

The problem only affects system sounds, so turning system sound off is a good solution for me.

comment:26 Changed 10 years ago by pasha

I think you need open ticket in uniaud bugtracker.... you are need in /tmr. you don't need in http://download.smedley.info/uniaud32-1.9.12.zip exactly. Next step from me can be only in create own uniaud build then debugging with you. But I can't help if problem is in your C-media adapter support. Now I think - problem is in support C-media adapter.

comment:27 Changed 10 years ago by pasha

  • Owner pasha deleted

comment:28 Changed 8 years ago by dazarewicz

  • Resolution set to Unsupported Version
  • Status changed from new to closed

This ticket is really old and not really relevant to the current software. If you still have problems with the current version, please open a new ticket.

Note: See TracTickets for help on using tickets.