Opened 11 years ago

Closed 8 years ago

#307 closed defect (wontfix)

New VPIC.SYS doesn't work

Reported by: eco Owned by:
Priority: major Milestone: Release version 3.19
Component: VPIC.SYS Version: 3.13
Keywords: Cc: criguada@…

Description

From: Andreas Buchinger

source: http://bugs.ecomstation.nl/view.php?id=2235

Message 1:

RC2 with ACPI3.11 - DOS/WinOS2 do not work anymore (okay with 3.10)

I've upgraded ACPI from 3.10 to 3.11 and now DOS/WinOS2 do not work anymore. No high IRQs.

PSD=ACPI.PSD /SMP /EIS working DOS/WinOS2 with ACPI3.10 but not with 3.11 PSD=ACPI.PSD /SMP /PIC working DOS/WinOS2 with ACPI3.10 but not with 3.11

Tried with 3.11 the following too, but without sucess - PSD=ACPI.PSD /SMP /EIS /PIC

DEVICE=D:\OS2\MDOS\VPIC.SYS do not make a difference. Is vpic.sys described anywhere?

Logs: http://ecomstation.ru/projects/acpitools/logs/acpi-log-MSI_P35-20081023.zip

Message 2:

Verified - it's the new vpic.sys which prevents DOS / WinOS2 from loading.

This version do not work for me -

9.10.08 6.15 11.156 54 a--- VPIC.SYS

This works - 30.04.01 14.39 9.942 49 a--- VPIC.SYS

Tooks a while for me to find out I've to reboot before the 'other' version will be loaded, but now it's clear to me - VPIC.SYS is the reason.

Change History (8)

comment:1 follow-up: Changed 11 years ago by eco

e-co:

Please don't use this version of VPIC.SYS, wait for new version.

comment:2 in reply to: ↑ 1 Changed 11 years ago by criguada

  • Cc criguada@… added
  • Version changed from 3.11 to 3.13

Replying to eco:

e-co:

Please don't use this version of VPIC.SYS, wait for new version.

Where do I find this VPIC.SYS? x:\OS2\MDOS\VPIC.SYS on my system is dated 30/04/2001, and I don't have it loaded in CONFIG.SYS. Still, I can't use DOS or WINOS2 sessions:

{0}[root@ecsbox | G:\]start /DOS SYS1059: The system cannot execute the specified program.

I have ACPI 3.13 installed and working on my AMD SMP system. What should I do? Do you need more infos?

Bye Cris

comment:3 Changed 11 years ago by pasha

wait end of developing vpic.sys acpi compitable

comment:4 Changed 11 years ago by andib

DOS works with Acpi3.13 and original vpic.sys. 2 cores (CPU0 & CPU1) are running.

config.sys entry which works - PSD=ACPI.PSD /SMP /PIC

Never had a problem with DOS and 1 CPU (without /SMP), but did not test 1 CPU very much.

comment:5 Changed 11 years ago by stevenhl

  • Component changed from ACPI.PSD to VPIC.SYS

comment:6 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Release version 3.16

comment:7 Changed 11 years ago by stevenhl

  • Owner pasha deleted

comment:8 Changed 8 years ago by dazarewicz

  • Resolution set to wontfix
  • Status changed from new to closed

The vpic.sys driver has been discontinued and removed from the distribution.

Note: See TracTickets for help on using tickets.