Opened 10 years ago

Closed 6 years ago

#305 closed defect (fixed)

Suspend/resume, Thinkpad T61

Reported by: eco Owned by:
Priority: major Milestone: Feedback pending
Component: ACPI PSD Version: 3.11
Keywords: Suspend Resume Cc:

Description

From: Peter Verweij

I use acpi 3.11

Suspend test

with the supplied kernel of ecs2.0 rc 5 i get suspend working, with resume, even with genmac and uniaud version of paul smedley (1.9.8 version) only problem is only the first suspend works, if I do it another time, the machine reboots. with the test case kernel (found on betazone the machine goes into suspend, but won't wake up, the moon icon keeps burning. suspend state started always from xcenter. in the config I have

PSD=ACPI.PSD /SMP /vbe /R /APIC

The lid doesn't do anything (no suspend started)

If you need more information let me know.

http://ecomstation.ru/projects/acpitools/logs/20081020-acpica.log

http://ecomstation.ru/projects/acpitools/logs/20081020-acpidaemon.log

Attachments (4)

CONFIG.SYS (8.9 KB) - added by vrwp 10 years ago.
acpica.log (123.7 KB) - added by vrwp 10 years ago.
acpi316.log (16.3 KB) - added by vrwp 9 years ago.
acpi$ from acpi316 fu warpin package
acpi230709.log (19.8 KB) - added by vrwp 9 years ago.
acpi$ from acpi316 test version of 23-07-09

Download all attachments as: .zip

Change History (18)

comment:1 Changed 10 years ago by pasha

Try ACPI22102008.ZIP. read how to download special build: http://ecomstation.ru/projects/acpitools/?action=testcase

Changed 10 years ago by vrwp

Changed 10 years ago by vrwp

comment:2 Changed 10 years ago by vrwp

Hi tested the new version. Both kernels (official release from ecs2.0 rc5) and the one from betazone (with hlt instructions) won't work with suspend now. machine goes in suspend (done with suspend from xcenter or supend from power icon) after hitting the powerbutton or fn key the machine tries to wake up, but the suspend ions keeps on. with the betazone kernel I got the following message: leave suspend cpu0 max lvt=6 begin wakeup app cpu from cpu0 send ini app proc, save:fa134d00 send sipi cpu1-6c000,id:1-17 cpu waleave suspend cpu0 remax lvt=6p return sleep cpu1 ======wakeup cpu1 lock:0======== irqmask set ff82acfc rc=0

one time i got a black screen afterwards, with the following text powerbutton event rc=0

On startup I also get an error message, about not loading a driver, but it goes to fast. (have to try with pauseonerror (forgot that one) the driver vpic.sys is included in the zip file, but isn't normally loaded with my config. so i added the line device=c:\os2\mdos\vpic.sys at the moment I have no working dos environment in os/2,

tested also with the sound disabled (remmed out the driver, no difference for suspend.

If sound driver is enabled I still have working system sounds. :-) Attached the acpi.log from few last boots (only with official kernel) and config.sys

comment:3 Changed 9 years ago by pasha

suspend don't possible in IBM kernel

comment:4 Changed 9 years ago by ecsnl

Dear customer,

A short reply. This is still in research and the statement "suspend don't possible in IBM kernel" is meant its currently not supported.

Best regards,

Roderick Klein Mensys

comment:5 Changed 9 years ago by ecsnl

Dear customer,

A short reply. This is still in research and the statement "suspend don't possible in IBM kernel" is meant its currently not supported. Panorama is indeed required for suspend resume with ACPI.

Best regards,

Roderick Klein Mensys

comment:6 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Release version 3.16
  • Owner pasha deleted

comment:7 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.17 to Feedback pending

Please retry with acpi 3.16 or cpi316-07-23.zip from the BetaZone?.

comment:8 Changed 9 years ago by vrwp

Hi,

Even on vacation I can't resist to test :-) Tested with acpi 3.16, error in sleepbutton event, attached the acpi$.log Have to see if I have time to test the special build.

Changed 9 years ago by vrwp

acpi$ from acpi316 fu warpin package

comment:9 Changed 9 years ago by vrwp

Hi,

tested the acpi316-07-23 version, same problem, tested it with the supplied kernel (and the official one), problem with initiating sleep event. Log file from acpi$ added. If you want more information let me know.

Changed 9 years ago by vrwp

acpi$ from acpi316 test version of 23-07-09

comment:10 Changed 8 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.19

comment:11 Changed 6 years ago by dazarewicz

  • Keywords Suspend Resume added

comment:12 Changed 6 years ago by dazarewicz

  • Milestone changed from Release version 3.19 to Feedback pending

Please try the current version.

comment:13 Changed 6 years ago by vrwp

Hi,

It works!

comment:14 Changed 6 years ago by dazarewicz

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.