Opened 10 years ago

Closed 8 years ago

#303 closed defect (unknown)

PowerOff, ASUS M6800N notebook

Reported by: eco Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.11
Keywords: Cc:

Description

From: Hans v. Mangoldt

source: http://bugs.ecomstation.nl/view.php?id=678#5768

The battery state is now displayed correctly with ACPI 3.09 or 3.11 installed. Unfortunatley shutdown with power off is not working any more. The installed eCS is still on level 1.2, so I only tried power off via APM and could not try the eCenter power off via ACPI.

Attachments (1)

acpidaemon.log (125.1 KB) - added by Jack 10 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by eco

e-co:

Please try tests: http://ecomstation.ru/projects/acpitools/?action=faq -> Shutdown via ACPI

comment:2 Changed 10 years ago by eco

thank you for your quick answer. I testet shutdown via PowerOff?.exe. This works as expected (switches off after about 3 seconds). Can I use ACPI PowerOff? with eCS 1.2? APM shutdown with power off workes fine with only apm.sys installed - so without ACPI.

comment:3 Changed 10 years ago by pasha

check in config.sys: rem apm.sys basedev=apm.add

check , that AcpiDaemon? is running.

Then object Power -> PowerOff?

comment:4 Changed 10 years ago by Jack

apm.add is the second entry in config.sys after acpi.psd, both without parameters. APM.SYS is commented out (with rem). ACPIDaemon.exe is started with an entry in config.sys (RUN=X:\OS2\AcpiDaemon?.exe) - I tried two in the autostart folder. PowerOff? (german "Ausschalten") in Power object (german "Energie") settings menu does nothing (nothing happens if you select the menu entry - with only apm.sys loaded it shuts down and does power off). When I try PowerOff? via Desktop, RMB, shutdown and use the eStylerLite option "PowerOff?" ("Abschalten"), eCS 1.2 shuts down but does not power off. If you switch off the notebook then the filesystems are dirty. If you restart the notebook via ctrl-alt-del after it hangs at the end off shut down with power off it restarts well and the filesystems are clean.

comment:5 Changed 10 years ago by pasha

I installed german version of Power object. PowerOff? in this menu has 4 letter and I see as "Sluk"

comment:6 Changed 10 years ago by Jack

I hope we are both talking about the "Battery" icon which in german is called "Energie" and afaik in english "Power". The ninth option in the 12 options menu is "Ausschalten".

comment:7 Changed 10 years ago by pasha

Hmm, I have 13 options, PowerOff? is 9. Check pls property, second entry in main menu. Must set - APM BIOS and OS/2 support enabled

comment:8 Changed 10 years ago by Jack

OK, I was not able to count. Yes, it's 13 options. But yes, too, APM BIOS and OS/2 support was and is enabled. I did not change this from the eCS 1.2 installation I am using for some time now. I only added ACPI.PSD and APM.ADD to config.sys

comment:9 Changed 10 years ago by pasha

Check pls, that APMDAEMN.EXE or gsvdaemn.exe absent in config.sys (usially RUN=). Before PowerOff? check "APM BIOS and OS/2 support enabled". Some application can do turnoff APM support.

comment:10 Changed 10 years ago by Jack

APMDAEMN.EXE is remmed out, GSVDAEMN.EXE was never used. Before PowerOff? I checked several times that "APM BIOS and OS/2 support enabled" is marked, and now tried it again. There is no change. The notebook does not PowerOff? with ACPI.PSD only without and with APM.SYS loaded.

comment:11 Changed 10 years ago by pasha

Can you attach AcpiDaemon?.log ?

Changed 10 years ago by Jack

comment:12 Changed 9 years ago by eco

e-co:

Pasha: please try ACPI 3.14

comment:13 Changed 9 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:14 Changed 9 years ago by stevenhl

  • Milestone changed from Release version 3.15 to Feedback pending

comment:15 Changed 9 years ago by pasha

  • Owner pasha deleted

comment:16 Changed 8 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.