Opened 10 years ago

Closed 10 years ago

#268 closed defect (wontfix)

ACPI is not tested with W4

Reported by: eco Owned by: pasha
Priority: major Milestone: Release version 3.11
Component: ACPI PSD Version: 3.10
Keywords: Cc:

Description

e-co:

I posted bug-report to eComStation bug-tracker:

Pasha said me in the spring:

ACPI.PSD supports three kernels only: 104a_Uni, 104a_SMP ? 104a_SMP/debug. Why? the address of devhelper is scanned using hack methods.

OK, you upgraded the kernel of eCS to 10.104 - good.

New request: Problem: eComStation CD1 uses W4 kernel. As you can see, it is not supported. Try to use UNI kernel when expanding floppy disks. I don't know which new troubles this creates.

Change History (3)

comment:1 Changed 10 years ago by eco

e-co:

IMHO, it's very expensive to test eCS with UNI kernel.

Better add support of W4 kernel to eComStation.

Hello Pasha,

Rudi helped us, now you are maintaining the source code of the whole ACPI project, so please, try to fix this.

comment:2 Changed 10 years ago by eco

e-co:

Pasha talks that

The behaviour of KEE and other stuff in W4 is different.

comment:3 Changed 10 years ago by eco

  • Resolution set to wontfix
  • Status changed from new to closed

OK,

Conclusion: ACPI doesn't support IBM OS/2 W4 kernel, please use UNI kernel only.

  • mutexes are different (Scott refused to update them to the level of UNI/SMP)
  • memory lock is different
  • mapping of physical memory is different
  • KEE is different, (because the DevHelpers? in W4 are different)
Note: See TracTickets for help on using tickets.