Opened 11 years ago

Closed 9 years ago

#258 closed task (unknown)

It's necessary add new switch for NVidia: APICasPIC

Reported by: eco Owned by:
Priority: major Milestone: Release version 3.18
Component: ACPI PSD Version: 3.09
Keywords: Cc:

Description (last modified by eco)

It's necessary add new switch to acpi.cfg: APICasPIC

(Pasha was going to do this at 2008/04/10)

there was a ticket:

Nvidia has two modes of APIC mode.

Now we recommend to user add /!NOD The purpose of this switch is different but by "accident" it enables needed mode and allows use this PC (and other NVidias).

Why to spend efforts? 1) It's difficult to document why/when to use /!NOD switch. 2) /!NOD - it's a dirty method.

Change History (19)

comment:1 Changed 11 years ago by stevenhl

  • Milestone changed from Release version 3.10 to Release version 3.11

comment:2 Changed 11 years ago by eco

  • Description modified (diff)

Alan Beagley:

the following is what works for me with my Asus M2N-SLI Deluxe motherboards (nVidia chipset), AMD dual-core CPU and LSILogic U320 SCSI card:

PSD=ACPI.PSD /APIC /SMP /!NOD

The ACPI documentation is confusing, especially (IMO) wrt the /!NOD switch: at one point I was told to remove that switch, which I had found I had always had to use, and with that particular version of ACPI removing the switch solved the problem. When the next version came out, I found by trial and error that I had to restore the switch. A later version of the docs. announced that the switch was no longer needed, but I found that I still needed it.

comment:3 Changed 11 years ago by eco

e-co:

Test message, 20080811, 23:23 MSK

2 Pasha: Why this depends on VPIC.SYS?

comment:4 Changed 11 years ago by eco

e-co:

OK, Pasha confirmed that he can do this switch.

2008/09/29 (?)

comment:5 Changed 11 years ago by eco

  • Resolution set to wontfix
  • Status changed from new to closed

I close this ticket,

Pasha is working on VPIC.SYS (http://svn.netlabs.org/acpi/ticket/287) which automatically to resolve this ticket.

comment:6 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.12 to Release version 3.16
  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:7 Changed 10 years ago by losepete

How will a DOS support driver resolve the problem?

What about those who do not install the ancient OS/2 DOS support?

comment:8 Changed 10 years ago by eco

e-co:

You are right, I don't see relation of VPIC.SYS to "NVidia problem". Sometimes I post the information from Pasha without preliminary discussing.

comment:9 Changed 10 years ago by eco

e-co:

reminder:

/!NOD doesn't relate to VPIC

RUS: для юзеров NVidia мы писали: чтобы просто загрузиться

/!NOD /SMP /APIC

Pasha: if using /!NOD then no HighIRQs

e-co:

Let's analyze why is it important?

1) We declared that start work on APICasPIC 7 monthes ago,

2) Users were waiting for this switch

3) Modern NVidia computer has.. 10.. 15 devices.. there are notebooks based on NVidia chipset. So, HighIRQs are critical for reliable work and easy setup of computer.

comment:10 Changed 10 years ago by ecsnl

What would be interesting for Steve and me is some more information (some kernel traces for example) why /APIC with Nvidia does not work.

comment:11 Changed 10 years ago by eco

e-co:

Peter: 1] ACPI does not work as it should - this nVidia chipset will *NOT* boot if using /ACPI unless using /!NOD.

2] No specific need for HighIRQs at this point in time - but if I need them it would be great if they worked.

comment:12 Changed 10 years ago by ecsnl

More and more modern chipsets only run in APIC with all computers features enabled.

comment:13 Changed 10 years ago by pasha

What is the version of tested acpi.psd?

comment:14 Changed 10 years ago by pasha

Please download experimental ACPI build from Mensys site:

  • Experimental build for you:

ACPI-APIC-BAT.ZIP

comment:15 Changed 10 years ago by stevenhl

  • Milestone changed from Release version 3.16 to Feedback pending

comment:16 Changed 10 years ago by eco

  • Type changed from defect to task

e-co:

This ticket unites other N tickets. It's more fast to mention one "node" ticket than 10 separate tickets

comment:17 Changed 10 years ago by eco

e-co:

Users want buy cheap AMD-chipset.. but it is not supported. They want buy NVidia.. but no high IRQs. So.. Intel chipset only..

Yoda:

The problem seems to be you. IF /!NOD is needed, that is just an indication, that ACPI driver isn't working as it should. So please tell users the real facts: IF YOU EVER NEED YO USE /!NOD please flame EG every day You do that by replying to his mail here every day, or create a ticket, and send a 'fresh' log every day to ticket !

Alan Beagley (N 297)

Yes. I'm the one who originated this report. In fact everything is working OK on my desktop system, but I had opened that ticket because I thought that I had read that it was purely by chance that the /!NOD switch solved problems with the nVidia chipsets and that a better method (a new parameter for ACPI.PSD) was being worked on.

comment:18 Changed 10 years ago by pasha

  • Owner pasha deleted
  • Status changed from reopened to new

comment:19 Changed 9 years ago by stevenhl

  • Milestone changed from Feedback pending to Release version 3.18
  • Resolution set to unknown
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.